Jump to content
Калькуляторы

Cisco asr1001-x Настройка PPPoE server без Radius

Добрый день.

Есть задача поднять PPPoE сервер на Cisco asr 1001-x без использования Radius. 

И самая главная функция, которая нужна, привязать к конкретной учетной записи конкретный IP. Чтобы при подключении учеток, выделялся конкретный IP, закрепленный за ней.

До этого все было развернуто на микротике. там этот функционал работает без проблем.

Share this post


Link to post
Share on other sites

Видимо что-то типа

aaa new-model
aaa authentication ppp default none
aaa authorization network default none
!
bba-group pppoe global
 virtual-template 1
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 pppoe enable group global
!
interface Virtual-Template1
 ip unnumbered Loopback0
 peer default ip address pool default
 ppp authentication pap callin
 ppp ipcp dns 8.8.8.8 8.8.4.4
!
ip local pool default 10.0.0.2 10.0.0.254

 

Share this post


Link to post
Share on other sites
1 hour ago, Andrei said:

Видимо что-то типа


aaa new-model
aaa authentication ppp default none
aaa authorization network default none
!
bba-group pppoe global
 virtual-template 1
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 pppoe enable group global
!
interface Virtual-Template1
 ip unnumbered Loopback0
 peer default ip address pool default
 ppp authentication pap callin
 ppp ipcp dns 8.8.8.8 8.8.4.4
!
ip local pool default 10.0.0.2 10.0.0.254

 

Из этого конфига выходит, что клиенту назначается рандомный IP из пула 10.0.0.2 10.0.0.254

А надо, чтобы конкретному пользователю присваивался конкретный IP.

Share this post


Link to post
Share on other sites

Если циска умеет анализовать маки внутри pppoe, то наверное сделать привязку по ним.

Share this post


Link to post
Share on other sites
46 минут назад, Andrei сказал:

Если циска умеет анализовать маки внутри pppoe, то наверное сделать привязку по ним.

либо создавать свой пул для каждого из маков.

Share this post


Link to post
Share on other sites

или перестать изобретать костыли и поставить радиус/такакс

Share this post


Link to post
Share on other sites

 


 

aaa attribute list vasia_pupkin_attrs
  attribute type addr 192.168.168.230 service ppp protocol ip

!
!

username vasia_pupkin password XXXX

!

username vasia_pupkin aaa attribute list vasia_pupkin_attrs

 

 

On 7/8/2021 at 11:32 AM, VooDDi said:

без использования Radius. 

Для тестов сойдет, но в продакшен.... сколько там пользователей?

 

Share this post


Link to post
Share on other sites

Сейчас в продкшене микрот 1072. На нем 2000 пользователей. При трафике более 3Гб/с пользователи начинают жаловаться на скорость.

На микроте все просто, учетка с IP адресом и все. А динамикой нельзя раздавать IP из-за СОРМа

Share this post


Link to post
Share on other sites
16 минут назад, VooDDi сказал:

2000 пользователей

Биллинг какой-никакой на таких объемах уже обычно имеют. Если у вас он есть, то в нем наверняка есть и встроенный радиус-сервер, тогда даже ставить ничего не придется.

А 2000 пользователей заводить на циску... Ну я бы не стал.

Share this post


Link to post
Share on other sites
4 часа назад, Andrei сказал:

Биллинг какой-никакой на таких объемах уже обычно имеют. Если у вас он есть, то в нем наверняка есть и встроенный радиус-сервер, тогда даже ставить ничего не придется.

А 2000 пользователей заводить на циску... Ну я бы не стал.

2000 абонентов на Микроте, это жесть !!!!!   Срочно переезжайте на Циску или Джун и обязательно радиус !!!

Share this post


Link to post
Share on other sites
1 час назад, rdmitrich сказал:

2000 абонентов на Микроте, это жесть !!!!!   Срочно переезжайте на Циску или Джун и обязательно радиус !!!

Только мне не надо это советовать, а ТС. У меня-то циска с биллингом и радиусом :)

Share this post


Link to post
Share on other sites
13 часов назад, Andrei сказал:

Только мне не надо это советовать, а ТС. У меня-то циска с биллингом и радиусом :)

Тыща извинений ))) Разумеется это к ТС

Share this post


Link to post
Share on other sites
22 часа назад, Andrei сказал:

А 2000 пользователей заводить на циску... Ну я бы не стал.

т.е. лучше их оставить на микроте?

Может я и неправ, но более 1-2Гб/сек микротик лучше не использовать уже. И 2000 пользователей многовато для 1072.

Share this post


Link to post
Share on other sites
5 минут назад, kapydan сказал:

т.е. лучше их оставить на микроте?

Может я и неправ, но более 1-2Гб/сек микротик лучше не использовать уже.

У меня нет микрота, это у ТС.

Про заводить "2000 абонентов на циску я бы не стал" я имел ввиду, что не стал бы заводить на нее 2000 пользователей, чтобы не использовать внешнюю авторизацию, например через радиус, как хочет ТС. Тем более, что появляются новые пользователи, расторгают договора старые. Каждый раз править конфиг на циске, пусть даже автоматизированным скриптом? Сомнительное и явно костыльное решение.

Share this post


Link to post
Share on other sites
23 hours ago, VooDDi said:

Сейчас в продкшене микрот 1072. На нем 2000 пользователей. При трафике более 3Гб/с пользователи начинают жаловаться на скорость.

На микроте все просто, учетка с IP адресом и все. А динамикой нельзя раздавать IP из-за СОРМа

А билинг? в Экселе? Как вы счета выставляете? А полосу как выдаете?

Жесть.

Share this post


Link to post
Share on other sites
20 часов назад, kapydan сказал:

т.е. лучше их оставить на микроте?

Может я и неправ, но более 1-2Гб/сек микротик лучше не использовать уже. И 2000 пользователей многовато для 1072.

Если на нем шейпить сессии, то при 2000  - он загнется на 800 - 900 мегабитах

 

19 часов назад, ShyLion сказал:

А билинг? в Экселе? Как вы счета выставляете? А полосу как выдаете?

Жесть.

Сдается мне, ТС очень лукавит про 2000 пользователей... Уже при 500, без работы биллинга почти никак !! Более того, это глупо, держать штат инженеров и бухов, только для того, чтобы производить манипуляции , которые может делать биллинг за секунды!!

Edited by rdmitrich

Share this post


Link to post
Share on other sites
В 11.07.2021 в 07:53, rdmitrich сказал:

Если на нем шейпить сессии, то при 2000  - он загнется на 800 - 900 мегабитах

выходит по примерно 0,5мб на подключение - в текущих условиях маловато.

Share this post


Link to post
Share on other sites
1 минуту назад, kapydan сказал:

выходит по примерно 0,5мб на подключение - в текущих условиях маловато.

Там одна из проблем в том, что он не может нормально раскидывать нагрузку по ядрам, в результате нагрузка 50%, а у абонентов начинается задержка пакетов 20 - 100 мс !!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now