Jump to content
Калькуляторы

Транк между CISCO и DELL

Коллеги, есть у кого-то опыт соединения транком CISCO и DELL? не могу заставить его пропускать все VLAN-ы в транке.
Конфиги ниже:

 

---------- CISCO 2960XR---------

interface Port-channel2
 description DELL_SW
 switchport mode trunk
end
!
interface GigabitEthernet1/0/11
 description DELL-SW1-LAG
 switchport mode trunk
 channel-group 2 mode active
end

------- DELL S5224F-ON ---------

interface port-channel100
 description C2960XR-LINK
 no shutdown
 switchport mode trunk
!
interface ethernet1/1/24:1
 description C2960XR-LINK
 no shutdown
 channel-group 100 mode active
 no switchport
 flowcontrol receive off
!

Share this post


Link to post
Share on other sites

Ну, для начала со стороны Cisco должно быть switchport mode trunk encapsulation dot1q . Потому что 802.1q по дефолту у Cisco только потом стало, а раньше дефолтом было своё.

Share this post


Link to post
Share on other sites
16 минут назад, jffulcrum сказал:

Ну, для начала со стороны Cisco должно быть switchport mode trunk encapsulation dot1q . Потому что 802.1q по дефолту у Cisco только потом стало, а раньше дефолтом было своё.

 

Предположу, что дело не в этом. Дата выхода серии коммутаторов 2960 это 2013г. и Cisco на тот момент уже вроде не поддерживала ISL.

Может со стороны DELL нужно сказать что-то типа:

switchport trunk allowed vlan all

И со стороны 2960 тоже, кстати.

Share this post


Link to post
Share on other sites
3 часа назад, Вова72 сказал:

channel-group 2 mode active

 

3 часа назад, Вова72 сказал:

 channel-group 100 mode active

Надеюсь, топикстартер с обеих строно LACP включил, потому как опять же в дефолте Cisco PAGP, который не факт что умеет Dell.

Share this post


Link to post
Share on other sites
15 минут назад, jffulcrum сказал:

 

Надеюсь, топикстартер с обеих строно LACP включил, потому как опять же в дефолте Cisco PAGP, который не факт что умеет Dell.

channel-group 2 mode active

Как бы и предполагает использование LACP. 

Share this post


Link to post
Share on other sites
9 часов назад, jffulcrum сказал:

Ну, для начала со стороны Cisco должно быть switchport mode trunk encapsulation dot1q

А оно и не даст switchport mode trunk пока ему тип энкапсуляции не укажешь.

Share this post


Link to post
Share on other sites
14 hours ago, StSphinx said:

switchport trunk allowed vlan all

На DELL нет такого параметра "all". Можно только перечислить VLANы по номерам. т.е.:

 

sts-dell-sw1(conf-if-po-100)# switchport trunk allowed vlan
  <1-4093>    VLAN IDs to add to the current list

 

Может быть дело в максимально возможном количестве возможных VLAN-ов, на DELL мы видим что оно равно 4093 ?

Share this post


Link to post
Share on other sites
56 минут назад, Вова72 сказал:

на DELL мы видим что оно равно 4093 ?

Там просто 4094 и 4096 зарезервированы. У Cisco зарезервированы 1002-1005.

 

В мануале на Dell есть упоминание о лимитах по числу активных VLAN, связанных с памятью, конкретно с разделением её с правилами ACL, QoS и т.п. Почитайте про VLAN Scaling в документации

 

Цитата

Since ACL rules are created on a per VLAN basis, the scale of VLANs is dependent on the number of ACL rules available. The ACL space is also shared by other applications such as FCoE. When more VLANs are created, the L2 QoS ACL space for the VLAN ACLs get exhausted. If the VLAN ACL creation fails, it results in VLAN creation failure. As a result, there cannot be more than 256 VLANs in Fabric mode.

Не знаю точно про эту модель, но свитчи от Dell обычно полу-софт-балалайки на FPGA, соответственно в них куча режимов работы со своими ограничениями. Вам надо найти режим, в котором больше возможностей для L2 функционала.

Share this post


Link to post
Share on other sites

ТС, а как вы поняли что не пропускает? Маки смотрели?

Share this post


Link to post
Share on other sites
25 minutes ago, VolanD666 said:

ТС, а как вы поняли что не пропускает? Маки смотрели?

port-channel не поднимается

Share this post


Link to post
Share on other sites

Port-channel имеет отношение только к одному вилану - номер 1, который на порту будет нетегированным, и в нём будут бегать LACP.

LACP не бегают - Port-channel не поднимается...

Все остальные виланы на Port-channel не влияют.

Share this post


Link to post
Share on other sites
36 минут назад, Вова72 сказал:

port-channel не поднимается

 

Так с этого и стоит начинать. Проверяйте параметры port-channel с обеих сторон. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this