Jump to content
Калькуляторы

Возможные причины проблем (кроме причин на стороне абонента)

Не в основном разделе, потому что это скорее отвлеченный опрос, не упустил ли я чего очевидного.

Есть магистральный оператор и у него есть клиент. Мы даем магистральщику ПМ до клиента, протягиваем VPN до стыка.

Стык с магистральщиком транковый, с пачкой VLAN (и с перенумерацией тех, по которым наши нумерации пересекаются). У клиента аксесный порт.

Не знаю, что за сервис дает магистральщик, но скорее всего централизованный интернет по контракту с головной организацией (на клиентском CPE прописаны 172.16.*.*).

В ПМ мы даем 10 Мбит/с. Клиент довольно часто жалуется магистральщику на то, что ему не докладывают мяса и у него скорость интернета выше 3-4 Мбит/с не поднимается. Магистральщик, соответственно, просит проверить нашу зону ответственности.

На графике действительно нет трафика — процентиль 95 за сутки в среднем меньше 200 Кбит/с, с редкими кратковременными всплесками. В статистике по порту нет ни дропов, ни ошибок. В реалтайм-статистике порта трафик также незначительный, либо вообще нулевой.

Собственно на этом мы сообщаем, что в нашей ЗО проблем не видим и проблема либо у магистральщика, либо у абонента.

Несколько раз предлагал магистральщику согласовать с клиентом время, вообще отключить PE и CE, включить вместо них ноутбуки с iperf и погонять трафик туда-сюда, но магистральщик отвечал, что пока этого не требуется.

Один раз все-таки проверил — предупредил о кратковременных работах, в абонентский порт включил ноутбук, а VLAN на стыке отключил и протянул его на тестовый стенд (то есть продлил на пару транзитных коммутаторов), в который включил второй ноутбук. Погонял между ноутбуками iperf, полоса пропускания в норме, ошибок нет.

Переслал магистральщику эти логи и сказал, что пусть проверяют или заменяют CE.

У магистральщика в качестве PE какая-то взрослая железка, у клиента в качестве CE какая-то циска, но какая, кто и как настраивал, мне неизвестно. Склоняюсь к тому, что либо она дефектная, либо кто-то с настройками накосячил.

Может быть я что-то упустил?

Share this post


Link to post
Share on other sites

@alibek

1. А почему не в QinQ гоняете? С Jumbo frames - самое то.

2. Можно на время поднять лимит до 20-30 Мбит, если картинка улучшиться, то дело скорее всего в policing или в маленьких буферах на shaping.

3. Проверьте не зарезан ли где-то размер пакетов, это тоже может сильно влиять на скорость.

Share this post


Link to post
Share on other sites

2. А смысл, если текущий лимит (10 Мбит/с) и на 5% не задействуется? Если бы полисер дропал пакеты, разве это бы в счетчике не видно было?

3. На всем участке голый L2 со стандартным размером кадра. Ну и были бы характерные жалобы, что часть сайтов не открывается. А жалобы только на скорость.

Share this post


Link to post
Share on other sites

Поинтересуйтесь откуда ноги про 3…4 мегабита, можно еще узнать что там за услуга тоже. Может они там какой-нибудь туннель с шифрованием поднимают вообще.

Share this post


Link to post
Share on other sites
2 часа назад, alibek сказал:

А смысл, если текущий лимит (10 Мбит/с) и на 5% не задействуется?

Вы откините одну из возможных причин.

 

2 часа назад, alibek сказал:

3. На всем участке голый L2 со стандартным размером кадра. Ну и были бы характерные жалобы, что часть сайтов не открывается. А жалобы только на скорость. 

Это зависит от того, на что жалуются и как?

Share this post


Link to post
Share on other sites
8 часов назад, alibek сказал:

В ПМ мы даем 10 Мбит/с. Клиент довольно часто жалуется магистральщику на то, что ему не докладывают мяса и у него скорость интернета выше 3-4 Мбит/с не поднимается. Магистральщик, соответственно, просит проверить нашу зону ответственности.

Тут в соседней ветке форума кто то был с кошкой, она ему тоже скорость резала, кажется причину так и не нашёл.

Share this post


Link to post
Share on other sites

Ситуация прямо один-в-один с одним из наших клиентов, до которого мы даем ПМ в качестве кажется суб-суб-подрядчика. Похоже, что проблема была в туннелях: клиентом был заказан просто доступ  в инет на скорости 10 Мбит/сек (и тут совпадение!) без всяких SLA и т.п. Стандартно мы включили его по pppoe. У субподрядчика pppoe поднимал микротик, у нас терминировала cisco ASR, у клиента - тоже какая-то циска. Когда была первая жалоба, послушали трафик, видим внутри нашего pppoe еще один туннель в областной центр до серверов суб-подрядчика. Позже выяснилось, что непосредственно сам клиент внутри этих двух туннелей поднимал еще свой шифрованный.

Тоже тестировал свою ЗО - шейпер работал нормально, а конечный клиент жаловался. Загрузку канала до клиента тоже подцепили к мониторингу и картинка была как описано ТС - в 90% времени до 0.5 Мбит/сек, редкие всплески до 5 Мбит/сек.

Share this post


Link to post
Share on other sites
11 часов назад, Ivan_83 сказал:

Тут в соседней ветке форума кто то был с кошкой, она ему тоже скорость резала, кажется причину так и не нашёл.

Нашёл, дело было не в бобине кошке

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now