Jump to content
Калькуляторы

Вопрос про PPPoE c NAT на RB750Gr3

Имею подключение от провайдера по PPPoE на интерфейсе ether1. При замере скорости speedtest показывает 850 мбит на вход и 600 на выход, причем во время первой половины теста (вход) загрузка процессора в среднем 45%, во время второй половины теста (выход) в среднем 87%, причем три ядра из четырех используются на 100%.   

Из firewall убрал все, кроме fasttrack и src-nat. Если вместо микротика подключить машину с убунтой, то скорость 850 на вход и 890 на выход. Подскажите, пожалуйста, как побороть эту проблему с исходящим трафиком.

image.png

image.png

Share this post


Link to post
Share on other sites

Ясно дело поставить другой микротик, более мощный.

Share this post


Link to post
Share on other sites

@Saab95 А почему этого на вход хватает? Этот, как известно, почти самый мощный из soho сегмента, а ставить домой RB3011 слишком жирно.

На PPPoE Туполиньк раньше стоял, пока не сдох, отдавал по 900 мбит в обе стороны (мерял в 4 утра).

Share this post


Link to post
Share on other sites

Вы точно уверены что все лишнее убрали из настроек?

Все фильтры дефолтной конфигурации должны быть удалены.

В настройках pppoe клиента размеры mtu верно указаны? max mtu, max mru, mrru, может микротик их не верно определил.

 

/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 password=user use-peer-dns=yes user=user1
/ip pool
add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether2 name=dhcp1
/ip address
add address=192.168.0.1/24 interface=ether2
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.0.0/24

Если сбросить начальный конфиг, и залить подобные настройки, прокачивает сколько надо? Пароль только не забудьте поставить на микротик=)

 

2 часа назад, medmm сказал:

ставить домой RB3011 слишком жирно

Если надумаете менять, то берите RB4011 он на голову выше, разница в цене не такая большая.

 

И не забывайте про то, как подключены порты у вашего RB750Gr3 - гонять трафик можно только через 1-3-5 и 2-4, иначе скорость общая ограничится гигабитом. То есть нужно смотреть диаграмму устройства, прежде чем покупать=)

 

RB750Gr3-dsw-161125140316.png

Share this post


Link to post
Share on other sites

@Saab95 Не первый раз убеждаюсь, что 95% проблем с микротиком решаются сбросом конфига. Начал с ваших настроек, потом ввернул fasttrack и все завертелось. Постепенно возвращая свои настройки по одному, очень сильно удивился, когда обнаружил, что после добавления EoIP туннеля в основной бридж скорость упала и утилизация подскочила до 85%. Никогда бы не подумал, что EoIP так влияет на производительность.

Без EoIP в бридже имею 800/900 при утилизации 40/45. Надо было сразу все сбросить, просто был уверен в своем конфиге и не хотел делать его заново) Спасибо!

ЗЫ Переткнул свой комп в ether3, другой комп в ether5, чтоб при передаче по локалке не нагружать проц.

Share this post


Link to post
Share on other sites
1 hour ago, medmm said:

Никогда бы не подумал, что EoIP так влияет на производительность.

MTU скорее всего не 1500 у туннеля, как надо. 

Share this post


Link to post
Share on other sites

@McSea У туннеля MTU 1500, L2MTU 65535, все как обычно. 

Share this post


Link to post
Share on other sites
В 05.06.2020 в 02:08, McSea сказал:

MTU скорее всего не 1500 у туннеля, как надо. 

скорее всего - влкючение IPoE в бридж молча ломает fastpath/аппаратные оффлоады набортного недосвича, и все становится очень и очень печально по производительности...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this