Jump to content
Калькуляторы

Настройка на Cisco 3750 DHCP relay и OPTION82

Уважаемые коллеги!

 

Прошу Вас подсказать имеем коммутаторы Catalyst 3750.

Клиент находится в VLAN 50

Управляющий VLAN 1

Мне нужно чтобы коммутатор делал DHCP relay

 

Клиент подключен в Fa 1/0/1 vlan 50

сервер DHCP в fa 1/0/24 vlan 1 ip adress 10.0.15.1

 

 

Куски конфига

 

!
ip dhcp relay information trust-all
!
!
ip dhcp snooping vlan 1,50
ip dhcp snooping information option format remote-id hostname
ip dhcp snooping

interface FastEthernet1/0/1
 switchport access vlan 50
 switchport mode access
 no cdp enable
 ip dhcp snooping limit rate 10

interface FastEthernet1/0/24
 switchport mode access
 ip dhcp snooping trust
interface Vlan1
 ip address 10.0.1.59 255.255.240.0
 ip helper-address 10.0.15.1
 no ip route-cache cef
 no ip mroute-cache

Что не так я сделал

Share this post


Link to post
Share on other sites
ip helper-address 10.0.15.1

Это надо прописать не в интерфейсе Vlan1, а в интерфейсе Vlan50. А вообще, гугл выдаёт миллион примеров на запрос...

Share this post


Link to post
Share on other sites
Пробовал я так делать, у меня почему-то пакет идет мультикастом (0.0.0.0 - 255.255.255.255) а по идее должен быть юникастом (10.0.1.59 - 10.0.15.1)

interface Vlan50
 no ip address
 ip helper-address 10.0.15.1

 

 

r 10 11:57:32: DHCPSNOOP(hlfm_set_if_input): Setting if_input to Fa1/0/1 for pak.  Was Vl50
Apr 10 11:57:32: DHCPSNOOP(hlfm_set_if_input): Setting if_input to Vl50 for pak.  Was Fa1/0/1
Apr 10 11:57:32: DHCPSNOOP(hlfm_set_if_input): Setting if_input to Fa1/0/1 for pak.  Was Vl50
Apr 10 11:57:32: DHCP_SNOOPING: received new DHCP packet from input interface (FastEthernet1/0/1)
Apr 10 11:57:32: DHCP_SNOOPING: process new DHCP packet, message type: DHCPDISCOVER, input interface: Fa1/0/1, MAC da: ffff.ffff.ffff, MAC sa: b0b2.dcd7.b56f, IP da: 255.255.255.255, IP sa: 0.0.0.0, DHCP ciaddr: 0.0.0.0, DHCP yiaddr: 0.0.0.0, DHCP siaddr: 0.0.0.0, DHCP giaddr: 0.0.0.0, DHCP chaddr: b0b2.dcd7.b56f
Apr 10 11:57:32: DHCP_SNOOPING: add relay information option.
Apr 10 11:57:32: DHCP_SNOOPING_SW: Encoding opt82 CID in vlan-mod-port format
Apr 10 11:57:32: DHCP_SNOOPING_SW: Encoding opt82 RID in MAC address format
Apr 10 11:57:32: DHCP_SNOOPING: binary dump of relay info option, length: 20 data:
0x52 0x12 0x1 0x6 0x0 0x4 0x0 0x32 0x1 0x3 0x2 0x8 0x0 0x6 0xA4 0x18 0x75 0x6B 0xA 0x80
Apr 10 11:57:32: DHCP_SNOOPING_SW: bridge packet get invalid mat entry: FFFF.FFFF.FFFF, packet is flooded to ingress VLAN: (50)
Apr 10 11:57:32: DHCP_SNOOPING_SW: bridge packet send packet to cpu port: Vlan50.
 

Share this post


Link to post
Share on other sites
5 минут назад, Bozman сказал:

у меня почему-то пакет идет мультикастом (0.0.0.0 - 255.255.255.255)

Броадкастом.

Share this post


Link to post
Share on other sites
4 minutes ago, stalker86 said:

Броадкастом.

Верно, спасибо что поправили. 

Share this post


Link to post
Share on other sites

А разве DHCP relay может работать на интерфейсе без IP адреса?

Что в таком случае должно быть в полях "SRC IP" и "Relay Agent IP" отрелееного юникаст пакета?

Попробуйте назначить на interface Vlan50 адрес из той же сети, из которой должны выдаваться адреса клиентам в этом vlan-е.

Share this post


Link to post
Share on other sites
17 минут назад, azhur сказал:

А разве DHCP relay может работать на интерфейсе без IP адреса?

Что в таком случае должно быть в полях "SRC IP" и "Relay Agent IP" отрелееного юникаст пакета?

Попробуйте назначить на interface Vlan50 адрес из той же сети, из которой должны выдаваться адреса клиентам в этом vlan-е.

И главное как ему понять из какого пула выдавать адрес...

Share this post


Link to post
Share on other sites
5 hours ago, VolanD666 said:

И главное как ему понять из какого пула выдавать адрес...

Я назначил на VLAN 50

interface Vlan50
 ip address 192.168.1.10 255.255.255.252
 ip helper-address 10.0.15.1

Запросы стали доходить до DHCP сервера. Но с IP адреса 192.168.1.10, вот тут самое интересное. Нам нужно было чтобы запросы шли от IP адреса управляющего VLAN 1.

Второе, DHCP сервер будет выдавать IP адреса с диапазонов 85.202.ххх.ххх

Как реализовать такую схему?

Share this post


Link to post
Share on other sites
8 минут назад, Bozman сказал:

Нам нужно было чтобы запросы шли от IP адреса управляющего VLAN 1.

Как реализовать такую схему?

Замените на любой порядочный L2-свич (например, D-Link). Он будет релеить именно так, как вам надо :) .

Share this post


Link to post
Share on other sites
18 minutes ago, VolanD666 said:

А вот этот адрес: 85.202.хх.хх он у вас где прописан?

Этот IP будет прописан в пуле адресов RADIUS с ним абонент будет попадать на ISG

Share this post


Link to post
Share on other sites

Я ничего не понимаю. Вы выдаете клиент адрес из посдети. У клиента должен быть шлюз в этой подсети. Вот этот шлюз он где прописан?

Share this post


Link to post
Share on other sites
5 minutes ago, VolanD666 said:

Я ничего не понимаю. Вы выдаете клиент адрес из посдети. У клиента должен быть шлюз в этой подсети. Вот этот шлюз он где прописан?

Шлюз, это интерфейс на ISG маршрутизаторе в VLAN 50

Share this post


Link to post
Share on other sites

ну дык вы на нем и настраивайте релей. Либо на коммутатор дайте адрес из этого пула. Откуда ваш DHCP знает из какого пула ему следует выдавать адрес, если вы запрос шлете с какого-то левого ИПа? И кстати, а зачем вам релей, на 50ом влане и выдавайте адрес, вроде можно как-то через радиус его выдвать на ISG прям.

Share this post


Link to post
Share on other sites

Может я чего-то не понимаю, я сейчас только строю общую схему. Планируем реализовать схему IPoE, клиент авторизовывается на коммутаторе, получая IP адрес с диапазона 85.202.ххх.ххх от DHCP сервера, который выдает ему IP из собственного пула. Попадая на ISG маршрутизатор, RADIUS авторизовывает клиента по IP адресу и назначает сервисы.

Думали еще о втором варианте, чтобы коммутаторы доступа 3750 общались по RADIUS с АСР.

Share this post


Link to post
Share on other sites

Как я понимаю топикстартеру нужно чтобы циска броадкастовый запрос от клиента пересылала  юникастом на dhch-сервер который уже выдаст всё нужное клиенту

Share this post


Link to post
Share on other sites
1 минуту назад, stalker86 сказал:

Как я понимаю топикстартеру нужно чтобы циска броадкастовый запрос от клиента пересылала  юникастом на dhch-сервер который уже выдаст всё нужное клиенту

Дык релей потом на основании сорса юникаста выдает адрес. Поэтому этот юникас должен идти с сорса, который находится в одной подсети (обычно это клиентский шлюз)

Share this post


Link to post
Share on other sites
6 minutes ago, stalker86 said:

Как я понимаю топикстартеру нужно чтобы циска броадкастовый запрос от клиента пересылала  юникастом на dhch-сервер который уже выдаст всё нужное клиенту

Правильно понимаете :)

Share this post


Link to post
Share on other sites
41 минуту назад, VolanD666 сказал:

Дык релей потом на основании сорса юникаста выдает адрес. Поэтому этот юникас должен идти с сорса, который находится в одной подсети (обычно это клиентский шлюз)

Релей ничего не выдаёт. Релей - "курьер" между  DHCP-сервером и клиентом

Share this post


Link to post
Share on other sites
12 минут назад, stalker86 сказал:

Релей ничего не выдаёт. Релей - "курьер" между  DHCP-сервером и клиентом

Ну в смысле dhcp выдает. Я знаю как релей рабоатет. И еще раз повторю. DHCP адрес выдает на основе сорса с которого пришел пакет от релея.

Share this post


Link to post
Share on other sites

Пока сделал вот так. Этим я добился того что в source пишется IP адрес устройства. Дальше будем копать DHCP, чтобы выдавал, что мне нужно.

 

interface Vlan1
 ip address 10.0.1.59 255.255.240.0
 no ip mroute-cache
!
interface Vlan50
 ip unnumbered Vlan1
 ip helper-address 10.0.15.1

 

1 hour ago, VolanD666 said:

Ну в смысле dhcp выдает. Я знаю как релей рабоатет. И еще раз повторю. DHCP адрес выдает на основе сорса с которого пришел пакет от релея.

У нас в планах, DHCP должен выдавать на основе данных АСРа

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now