Jump to content
Калькуляторы

Балансировка на CCR

В 29.04.2020 в 12:31, Saab95 сказал:

Вам надо начать с того, что определить что там за каналы. Это должны быть IP интерфейсы. Одному интерфейсу заводите вручную маршрут на 0.0.0.0/0 с метрикой 1 и меткой inet1, второму то же самое, только метка inet2.

Делаете 2 правила НАТ, в каждом указываете src-address-list соответственно inet1 и inet2, и действие src-nat = внешнему IP одного и другого провайдера.

В манглах делаете так же 2 правила, где src-address-list так же inet1 и inet2, там действие марк роутинг на inet1 и inet2.

 

Дальше те IP пользователей, которые добавите в адрес листы inet1 пойдут через 1 канал, из inet2 через второй канал.

А не проще ли:

/interface list;
add name=WAN comment="Wide Area Network Interface groupe";
/interface list member;
add interface=ISP1 list=WAN;
add interface=ISP2 list=WAN;
add interface=ISP3 list=WAN;/

/ip firewall nat;
add action=masquerade chain=srcnat out-interface-list=WAN;/

 

 

 

Share this post


Link to post
Share on other sites

на линуксе давно еще делал балансировку ip route nexthop via ну типа того.
В итоге разные DST IP на разных интерфейсах были, и их количеством можно соотношение подобрать скорости канала, типа 2 next и 1 next соотношение 1\2 если канал падал то всё через 1.

Share this post


Link to post
Share on other sites

Подскажите,

На сайте микротика приведен пример: https://wiki.mikrotik.com/wiki/Manual:PCC

/ ip firewall mangle

add chain=prerouting in-interface=ISP1 connection-mark=no-mark action=mark-connection new-connection-mark=ISP1_conn

add chain=prerouting in-interface=LAN connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=ISP1_conn 

add chain=prerouting connection-mark=ISP1_conn in-interface=LAN action=mark-routing new-routing-mark=to_ISP1
add chain=prerouting connection-mark=ISP2_conn in-interface=LAN action=mark-routing  new-routing-mark=to_ISP2

Правильно ли я понимаю, в первом абзаце: 

1. connection-mark=no-mark скидываем все метки.

2. new-connection-mark=ISP1_conn  определяем новое значение для метки соединения action=mark-connection.

 

Во втором абзаце всё сходно, отсюда сразу возникает вопрос: в первом правиле метиться трафик из интернета с меткой  ISP1_conn, а во втором правиле метиться трафик из локальной сети с меткой  ISP1_conn. 

Как так, разные правила с одинаковыми метками? Должно же быть по смыслу одно правило одна уникальная метка!?

 

 

Share this post


Link to post
Share on other sites
6 hours ago, feeman said:

Правильно ли я понимаю, в первом абзаце: 

1. connection-mark=no-mark скидываем все метки.

 

Нет, действие это action, все остальное - условия-критерии применимости правила. В данном случае, маркируются соединения, еще не имеющие меток.

 

6 hours ago, feeman said:

Во втором абзаце всё сходно, отсюда сразу возникает вопрос: в первом правиле метиться трафик из интернета с меткой  ISP1_conn, а во втором правиле метиться трафик из локальной сети с меткой  ISP1_conn. 

Как так, разные правила с одинаковыми метками? Должно же быть по смыслу одно правило одна уникальная метка!?

 

Если нужно и те и другие пускать через ISP1, зачем еще одна метка ? 

Share this post


Link to post
Share on other sites

подскажите, как завернуть трафик до внешней сети 194.54.14.0/24 через определенный канал?

 

т.е., чтоб все запросы до 194.54.14.0/24 шли только через один заранее определенный канал.

Share this post


Link to post
Share on other sites
13 часов назад, feeman сказал:

подскажите, как завернуть трафик до внешней сети 194.54.14.0/24 через определенный канал?

 

т.е., чтоб все запросы до 194.54.14.0/24 шли только через один заранее определенный канал.

простой стат маршрут через шлюз выбранного канала, + маршрут с метрикой роутер марк

Share this post


Link to post
Share on other sites

image.thumb.png.95be495e682a7f4d8624f8ac64979640.png

 

А какая дистанция должна быть у такого маршрута?

Share this post


Link to post
Share on other sites

указал метрику 1 и входе проверки выяснилось, что правило не работает... 

 

мож есть какие-то еще варианты как завернуть трафик?

Share this post


Link to post
Share on other sites

Если вы маркируете трафик, то нужно еще и для этого маршрута добавить маркировку.

Share this post


Link to post
Share on other sites

@Saab95 , само собой создано два правила.

Share this post


Link to post
Share on other sites

Вот наглядный скрин всех правил.

Но, по по неведомой мне причине, маршрут до сети 194.54.14.0/24 и 194.54.12.0 не заворачивается на PPPoE2, либо заворачивается, но как-то не корректно...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now