Jump to content
Калькуляторы

Трансляция VLAN на S2960

Есть коммутатор SNR-S2960-24G.

В порт 28 подключен клиент, которому дается несколько VLAN.

В моей стороны это должны быть 355, 357, 357. Со стороны клиента это должны быть 1367, 1010, 1000.

#vlan-translation 355 to 1367 out 
Vlan translation out not support

Как можно настроить смену VLAN 1:1?

Share this post


Link to post
Share on other sites

Установлена какая-то из свежих версий, точно не помню, а сейчас посмотреть не могу. 7.3.какая-то.

Только in недостаточно, мне надо и выходящие пакеты перенумеровать (по одну сторону должны быть 3xx, по другую сторону должны быть 1xxx).

Это в принципе возможно на S2960 или нужно менять коммутатор?

Если возможно, то как это сделать (через vlan-translation, service-policy, selective-qinq или как еще)?

Если невозможно, то можно ли это сделать на S2985G?

 

Или имеется ввиду делать in-трансляции на аплинке и на доступе?

Теоретически может подойти, нужно проверить.

Можете привести пример исходя из того, что порт клиента 28, аплинк (в мою сторону) 25?

У меня с направлениями ingress/egress всегда были сложности.

Share this post


Link to post
Share on other sites

@alibek Нет, имел ввиду на данной модели достаточно прописать трансляцию только на in, при этом будет работать как in/out.

Share this post


Link to post
Share on other sites

Судя по всему, не работает.

in — это ingress-трафик, который пришел на порт из провода?

Или внутренняя коммутация тоже попадает под in?

Share this post


Link to post
Share on other sites

Тогда можете привести пример?

У меня сейчас настроено так:

Interface Ethernet1/28
 vlan-translation enable
 vlan-translation 1365 to 353 in
 vlan-translation 1366 to 354 in
 vlan-translation 1367 to 355 in
 vlan-translation 1000 to 356 in
 vlan-translation 1010 to 357 in
 dot1q-tunnel selective enable
 switchport mode trunk
 switchport trunk allowed vlan 355-357;1000;1010;1367 

Порт 28 — это порт клиента.

Порт 25 — это аплинк, в него нужные пакеты приходят с тегами 353-357.

Share this post


Link to post
Share on other sites

Все виланы добавлены в конфиг? Даже не свои нужно тоже.

Share this post


Link to post
Share on other sites

Не помогло.

Обновился на последнюю версию:

SW-KALAN37-01#sh ver
  SNR-S2960-24G Device, Compiled on Jul 18 17:12:33 2018
  sysLocation Cherkessk,
  CPU Mac 00:1f:ce:8d:eb:40
  Vlan MAC 00:1f:ce:8d:eb:3f
  SoftWare Version 7.0.3.5(R0217.0170)
  BootRom Version 7.1.3
  HardWare Version 1.0.2
  CPLD Version 1.2
  Serial No.:1407004169
  Copyright (C) 2018 NAG LLC
  All rights reserved
  Last reboot is warm reset.
  Uptime is 0 weeks, 0 days, 0 hours, 2 minutes

SW-KALAN37-01#sh run int eth 1/28
!
Interface Ethernet1/28
 vlan-translation enable
 vlan-translation 1365 to 353 in
 vlan-translation 1366 to 354 in
 vlan-translation 1367 to 355 in
 vlan-translation 1000 to 356 in
 vlan-translation 1010 to 357 in
 switchport mode trunk
 switchport trunk allowed vlan 355-357;1000;1010;1367 
!

SW-KALAN37-01#sh mac-address-table int eth 1/28
Read mac address table....
Vlan Mac Address                 Type    Creator   Ports
---- --------------------------- ------- -------------------------------------
1    e8-28-c1-15-c4-c0           DYNAMIC Hardware Ethernet1/28

Иногда я вижу MAC-адрес клиента в VLAN 356 (помимо 1), то есть трансляция пакетов от клиента частично осуществляется (у клиента используются VLAN 1xxx).

Попросил клиента разрешить на транке VLAN 3xx и посмотреть MAC-адреса — он говорит, что видит MAC-адреса в VLAN 3xx.

То есть в его сторону трансляция не выполняется.

Share this post


Link to post
Share on other sites

Ерунда какая-то.

Сейчас клиент сообщил, что за портом видит MAC-адреса в VLAN 1xxx.

То есть получается, коммутатор просто ночь постоял и заработал.

Нет предположений, почему не заработало вчера?

dotiq-tunnel selective enable я не включал, эта опция автоматически включалась при vlan-translation enable (по крайней мере на версии ПО до обновления).

 

И еще вопрос, как избавиться от VLAN 1?

Когда я пробую указать switchport forbidden vlan 1, то получаю сообщение "Can not set trunk port native vlan 1 as switchport forbidden vlan".

Share this post


Link to post
Share on other sites

@alibek 
 

Цитата

Нет предположений, почему не заработало вчера?

Из-за версии ПО, вероятно.

Цитата

И еще вопрос, как избавиться от VLAN 1?

switchport discard packet untag, работает на входящий трафик

Share this post


Link to post
Share on other sites

Версия была достаточно свежая и в changelog я не увидел каких-то замечаний об исправлении работы vlan-translate или qinq.

Ок, заработало и хорошо.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this