Jump to content
Калькуляторы

Cisco nexus маршрутизация между vlan

Приветствую. С циской впервой столкнулся, поэтому наивный вопрос:

как настроить маршрутизацию между вланами?

 

конфиг

Скрытый текст

!Command: show running-config
!Time: Mon Sep 23 09:04:48 2019

version 6.0(2)U2(4)
hostname switch

feature telnet
feature interface-vlan
feature lldp

username admin password 5 $1$Xmtc6mZn$ZT4MuWRkUsEkFj7tYElVP/  role network-admin
no password strength-check
ip domain-lookup
logging event link-status default
service unsupported-transceiver
ip access-list copp-system-acl-eigrp
  10 permit eigrp any 224.0.0.10/32
ipv6 access-list copp-system-acl-eigrp6
  10 permit 88 any ff02::000a/128
ip access-list copp-system-acl-icmp
  10 permit icmp any any
ip access-list copp-system-acl-igmp
  10 permit igmp any any
ip access-list copp-system-acl-ntp
  10 permit udp any any eq ntp
  20 permit udp any eq ntp any
ip access-list copp-system-acl-pimreg
  10 permit pim any any
ip access-list copp-system-acl-ping
  10 permit icmp any any echo
  20 permit icmp any any echo-reply
ip access-list copp-system-acl-routingproto1
  10 permit tcp any gt 1024 any eq bgp
  20 permit tcp any eq bgp any gt 1024
  30 permit udp any 224.0.0.0/24 eq rip
  40 permit tcp any gt 1024 any eq 639
  50 permit tcp any eq 639 any gt 1024
  70 permit ospf any any
  80 permit ospf any 224.0.0.5/32
  90 permit ospf any 224.0.0.6/32
ip access-list copp-system-acl-routingproto2
  10 permit udp any 224.0.0.0/24 eq 1985
  20 permit 112 any 224.0.0.0/24
ip access-list copp-system-acl-snmp
  10 permit udp any any eq snmp
  20 permit udp any any eq snmptrap
ip access-list copp-system-acl-ssh
  10 permit tcp any any eq 22
  20 permit tcp any eq 22 any
ip access-list copp-system-acl-stftp
  10 permit udp any any eq tftp
  20 permit udp any any eq 1758
  30 permit udp any eq tftp any
  40 permit udp any eq 1758 any
  50 permit tcp any any eq 115
  60 permit tcp any eq 115 any
ip access-list copp-system-acl-tacacsradius
  10 permit tcp any any eq tacacs
  20 permit tcp any eq tacacs any
  30 permit udp any any eq 1812
  40 permit udp any any eq 1813
  50 permit udp any any eq 1645
  60 permit udp any any eq 1646
  70 permit udp any eq 1812 any
  80 permit udp any eq 1813 any
  90 permit udp any eq 1645 any
  100 permit udp any eq 1646 any
ip access-list copp-system-acl-telnet
  10 permit tcp any any eq telnet
  20 permit tcp any any eq 107
  30 permit tcp any eq telnet any
  40 permit tcp any eq 107 any
ipv6 access-list copp-system-acl-v6routingProto2
  10 permit udp any ff02::0066/128 eq 2029
  20 permit udp any ff02::00fb/128 eq 5353
ipv6 access-list copp-system-acl-v6routingproto1
  10 permit 89 any ff02::0005/128
  20 permit 89 any ff02::0006/128
  30 permit udp any ff02::0009/128 eq 521
ip access-list copp-system-dhcp-relay
  10 permit udp any eq bootps any eq bootps
class-map type control-plane match-any copp-icmp
  match access-group name copp-system-acl-icmp
class-map type control-plane match-any copp-ntp
  match access-group name copp-system-acl-ntp
class-map type control-plane match-any copp-s-arp
class-map type control-plane match-any copp-s-bfd
class-map type control-plane match-any copp-s-bpdu
class-map type control-plane match-any copp-s-dai
class-map type control-plane match-any copp-s-default
class-map type control-plane match-any copp-s-dhcpreq
class-map type control-plane match-any copp-s-dhcpresp
  match access-group name copp-system-dhcp-relay
class-map type control-plane match-any copp-s-dpss
class-map type control-plane match-any copp-s-eigrp
  match access-group name copp-system-acl-eigrp
  match access-group name copp-system-acl-eigrp6
class-map type control-plane match-any copp-s-glean
class-map type control-plane match-any copp-s-igmp
  match access-group name copp-system-acl-igmp
class-map type control-plane match-any copp-s-ipmcmiss
class-map type control-plane match-any copp-s-l2switched
class-map type control-plane match-any copp-s-l3destmiss
class-map type control-plane match-any copp-s-l3mtufail
class-map type control-plane match-any copp-s-l3slowpath
class-map type control-plane match-any copp-s-pimautorp
class-map type control-plane match-any copp-s-pimreg
  match access-group name copp-system-acl-pimreg
class-map type control-plane match-any copp-s-ping
  match access-group name copp-system-acl-ping
class-map type control-plane match-any copp-s-ptp
class-map type control-plane match-any copp-s-routingProto1
  match access-group name copp-system-acl-routingproto1
  match access-group name copp-system-acl-v6routingproto1
class-map type control-plane match-any copp-s-routingProto2
  match access-group name copp-system-acl-routingproto2
class-map type control-plane match-any copp-s-selfIp
class-map type control-plane match-any copp-s-ttl1
class-map type control-plane match-any copp-s-v6routingProto2
  match access-group name copp-system-acl-v6routingProto2
class-map type control-plane match-any copp-s-vxlan
class-map type control-plane match-any copp-snmp
  match access-group name copp-system-acl-snmp
class-map type control-plane match-any copp-ssh
  match access-group name copp-system-acl-ssh
class-map type control-plane match-any copp-stftp
  match access-group name copp-system-acl-stftp
class-map type control-plane match-any copp-tacacsradius
  match access-group name copp-system-acl-tacacsradius
class-map type control-plane match-any copp-telnet
  match access-group name copp-system-acl-telnet
policy-map type control-plane copp-system-policy
  class copp-s-selfIp
    police pps 500
  class copp-s-default
    police pps 400
  class copp-s-l2switched
    police pps 200
  class copp-s-ping
    police pps 100
  class copp-s-l3destmiss
    police pps 100
  class copp-s-glean
    police pps 500
  class copp-s-l3mtufail
    police pps 100
  class copp-s-ttl1
    police pps 100
  class copp-s-ipmcmiss
    police pps 400
  class copp-s-l3slowpath
    police pps 100
  class copp-s-dhcpreq
    police pps 300
  class copp-s-dhcpresp
    police pps 300
  class copp-s-dai
    police pps 300
  class copp-s-igmp
    police pps 400
  class copp-s-routingProto2
    police pps 1300
  class copp-s-v6routingProto2
    police pps 1300
  class copp-s-eigrp
    police pps 200
  class copp-s-pimreg
    police pps 200
  class copp-s-pimautorp
    police pps 200
  class copp-s-routingProto1
    police pps 1000
  class copp-s-arp
    police pps 200
  class copp-s-ptp
    police pps 1000
  class copp-s-vxlan
    police pps 1000
  class copp-s-bfd
    police pps 350
  class copp-s-bpdu
    police pps 12000
  class copp-s-dpss
    police pps 1000
  class copp-icmp
    police pps 200
  class copp-telnet
    police pps 500
  class copp-ssh
    police pps 500
  class copp-snmp
    police pps 500
  class copp-ntp
    police pps 100
  class copp-tacacsradius
    police pps 400
  class copp-stftp
    police pps 400
control-plane
  service-policy input copp-system-policy
hardware profile portmode 64x10G

snmp-server user admin network-admin auth md5 0x5d8a4fbcd42db16e021837cf3c95fb77
 priv 0x5d8a4fbcd42db16e021837cf3c95fb77 localizedkey

vrf context management
vlan 1,10,100-109,201-279
vlan 655
  name 655
vlan 776
  name 776

interface Vlan1

interface Vlan10
  no shutdown
  ip address 10.10.10.254/24

interface Vlan100
  no shutdown
  ip address 10.10.0.254/24

interface Vlan101
  no shutdown
  ip address 10.10.1.254/24

interface Vlan102
  no shutdown
  ip address 10.10.2.254/24

interface Vlan103
  no shutdown
  ip address 10.10.3.254/24

interface Vlan104
  no shutdown
  ip address 10.10.4.254/24

interface Vlan105
  no shutdown
  ip address 10.10.5.254/24

interface Vlan106
  no shutdown
  ip address 10.10.6.254/24

interface Vlan107
  no shutdown
  ip address 10.10.7.254/24

....

interface Vlan279
  no shutdown
  ip address 10.255.79.254/24

interface Ethernet1/1
  switchport access vlan 10
  speed 100

interface Ethernet1/2
  switchport access vlan 10
  speed 100

interface Ethernet1/3
  switchport mode trunk
  speed 1000

interface Ethernet1/4
  switchport access vlan 776
  speed 1000

interface Ethernet1/5
  switchport mode trunk
  speed 1000

interface Ethernet1/6
  switchport mode trunk
  speed 1000

interface Ethernet1/7
  switchport access vlan 10
  speed 1000

interface Ethernet1/8
  switchport mode trunk
  speed 1000

interface Ethernet1/9
  switchport mode trunk
  speed 1000

interface Ethernet1/10
  switchport mode trunk
  speed 1000

interface Ethernet1/11
  switchport mode trunk
  speed 1000

interface Ethernet1/12
  switchport mode trunk
  speed 1000

interface Ethernet1/13
  speed 1000

interface Ethernet1/14
  speed 1000

interface Ethernet1/15
  speed 1000

interface Ethernet1/16
  speed 1000

interface Ethernet1/17
  speed 1000

interface Ethernet1/18
  speed 1000

interface Ethernet1/19
  speed 1000

interface Ethernet1/20
  speed 1000

interface Ethernet1/21
  speed 1000

interface Ethernet1/22
  speed 1000

interface Ethernet1/23
  speed 1000

interface Ethernet1/24
  speed 1000

interface Ethernet1/25
  speed 1000

interface Ethernet1/26
  speed 1000

interface Ethernet1/27
  speed 1000

interface Ethernet1/28
  speed 1000

interface Ethernet1/29
  speed 1000

interface Ethernet1/30
  speed 1000

interface Ethernet1/31
  speed 1000

interface Ethernet1/32
  speed 1000

interface Ethernet1/33
  switchport mode trunk
  speed 1000

interface Ethernet1/34
  switchport mode trunk
  speed 1000

interface Ethernet1/35
  switchport mode trunk
  speed 1000

interface Ethernet1/36
  switchport mode trunk
  speed 1000

interface Ethernet1/37
  switchport mode trunk
  speed 1000

interface Ethernet1/38
  switchport mode trunk
  speed 1000

interface Ethernet1/39
  switchport mode trunk
  speed 1000

interface Ethernet1/40
  switchport mode trunk
  speed 1000

interface Ethernet1/41
  switchport mode trunk
  speed 1000

interface Ethernet1/42
  switchport mode trunk
  speed 1000

interface Ethernet1/43
  switchport mode trunk
  speed 1000

interface Ethernet1/44
  switchport mode trunk
  speed 1000

interface Ethernet1/45
  switchport mode trunk
  speed 1000

interface Ethernet1/46
  switchport mode trunk
  speed 1000

interface Ethernet1/47
  switchport mode trunk
  speed 1000

interface Ethernet1/48
  switchport mode trunk
  speed 1000

interface Ethernet1/49/1

interface Ethernet1/49/2

interface Ethernet1/49/3

interface Ethernet1/49/4

interface Ethernet1/50/1

interface Ethernet1/50/2

interface Ethernet1/50/3

interface Ethernet1/50/4

interface Ethernet1/51/1

interface Ethernet1/51/2

interface Ethernet1/51/3

interface Ethernet1/51/4

interface Ethernet1/52/1

interface Ethernet1/52/2

interface Ethernet1/52/3

interface Ethernet1/52/4

interface mgmt0
line console
line vty
boot kickstart bootflash:/n3000-uk9-kickstart.6.0.2.U2.4.bin
boot system bootflash:/n3000-uk9.6.0.2.U2.4.bin
ip route 0.0.0.0/0 10.10.10.1

 

лицензии:

Скрытый текст

switch#  sh lic u
Feature                      Ins  Lic   Status Expiry Date Comments
                                 Count
--------------------------------------------------------------------------------
LAN_BASE_SERVICES_PKG         Yes   -   Unused Never       -
ALGO_BOOST_SERVICES_PKG       No    -   Unused             -
LAN_ENTERPRISE_SERVICES_PKG   Yes   -   Unused Never       -
--------------------------------------------------------------------------------
 

с самой циски пингуется только адрес в 10 влане, он же есть в выводе 

sh ip route

других маршрутов нет.

Share this post


Link to post
Share on other sites

гугл тоже про нее говорил, но у меня она не работает

switch# conf
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# ip routing
                          ^
% Incomplete command at '^' marker.
switch(config)# ip routing ?
  event-history  Configure routing event log
  multicast      Configure multicast

switch(config)# ip routing

 

может я как то не так создаю интерфейсы в вланах?

в каких то случаях появляется маршрут в ip route

в большинстве случаев нет.

 

может это потому что вланы в даун:

switch# sh int vlan 10
Vlan10 is down (Administratively down), line protocol is down, autostate enabled
  Hardware is EtherSVI, address is  4c00.82d2.ee01
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  Last clearing of "show interface" counters never

switch# sh int vlan 100
Vlan100 is down (VLAN is down), line protocol is down, autostate enabled
  Hardware is EtherSVI, address is  4c00.82d2.ee01
  Internet Address is 10.10.0.254/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  Last clearing of "show interface" counters never

 

Share this post


Link to post
Share on other sites

вроде нашел решение, по крайней мере пинговать циска стала все свои интерфейсы.

 

switch(config)# int vlan 100
switch(config-if)# no auto
switch(config-if)# end

 

switch# sh int vlan 100
Vlan100 is up, line protocol is up, autostate disabled
  Hardware is EtherSVI, address is  4c00.82d2.ee01
  Internet Address is 10.10.0.254/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  Last clearing of "show interface" counters never

 

switch# sh ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

0.0.0.0/0, ubest/mbest: 1/0
    *via 10.10.10.1, [1/0], 00:02:04, static
10.10.0.0/24, ubest/mbest: 1/0, attached
    *via 10.10.0.254, Vlan100, [0/0], 00:01:43, direct
10.10.0.254/32, ubest/mbest: 1/0, attached
    *via 10.10.0.254, Vlan100, [0/0], 00:01:43, local
10.10.10.0/24, ubest/mbest: 1/0, attached
    *via 10.10.10.254, Vlan10, [0/0], 00:02:05, direct
10.10.10.254/32, ubest/mbest: 1/0, attached
    *via 10.10.10.254, Vlan10, [0/0], 00:02:05, local

 

Share this post


Link to post
Share on other sites

NX-OS в отличии от IOS не создаёт vlan при создании SVI . Vlan  обязательно надо делать вручную 

 

Vlan 10

Int vlan 10

no shut

 

 

 

Edited by EvgeniySerb

Share this post


Link to post
Share on other sites
21 час назад, Cramac сказал:

!Command: show running-config
!Time: Mon Sep 23 09:04:48 2019

version 6.0(2)U2(4)

 

староват софт у вас, стоит обновиться до 7.0(3)I7

Share this post


Link to post
Share on other sites
22 часа назад, Cramac сказал:

boot kickstart bootflash:/n3000-uk9-kickstart.6.0.2.U2.4.bin
boot system bootflash:/n3000-uk9.6.0.2.U2.4.bin

видимо всё же 3к
А что может быть не так с 5000??

Share this post


Link to post
Share on other sites
1 час назад, fork сказал:

 

староват софт у вас, стоит обновиться до 7.0(3)I7

Последняя версия которую можно туда смело ставить: nxos.9.3.1.bin

Share this post


Link to post
Share on other sites
22 минуты назад, AAS сказал:

Последняя версия которую можно туда смело ставить: nxos.9.3.1.bin

а на 3132 пробовали уже 9.3.1 накатывать? там где у Вас L3 агрегация

Share this post


Link to post
Share on other sites

Есть такая вероятность близкая к 100%. С 6 на 7 версию надо правильно сделать. 

RTFM 

Share this post


Link to post
Share on other sites
4 часа назад, Cramac сказал:

оно просто обновляется? не сделаю его кирпичом?

Кирпичем не сделаете, но вероятность поездки и установки образа с флешки имеется.

Share this post


Link to post
Share on other sites

Спасибо. Посмотрю, но и на текущей вроде работает то что мне надо

Share this post


Link to post
Share on other sites
В 23.09.2019 в 14:45, Cramac сказал:

switch(config)# int vlan 100

switch(config-if)# no auto

switch(config-if)# end

А что значит no auto ?

Share this post


Link to post
Share on other sites

как помню, на нексусах маршрутизация включается 

feature interface vlan

 

а потом уже создаются сами int vlan

int vlan 20

ip address 20.20.20.0 255.255.255.0 

 

типа того должно быть.

Share this post


Link to post
Share on other sites
12 минут назад, RN3DCX сказал:

А что значит no auto ?

вот

switch# sh int vlan 100
Vlan100 is up, line protocol is up, autostate disabled
  Hardware is EtherSVI, address is  4c00.82d2.ee01
  Internet Address is 10.10.0.254/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  Last clearing of "show interface" counters never

отключает autostate

с включенным, интерфейс влана не поднимался...

Share this post


Link to post
Share on other sites

попробуй так (на нексусах и ios-xr по другому настраивается)

 

conf t

feature ospf и дальше как на обычных цисках

 

а статический роутинг добавляется как на обычных цисках

ip route 30.30.30.0 255.255.255.0 10.10.10.1

Share this post


Link to post
Share on other sites
22 часа назад, fork сказал:

а на 3132 пробовали уже 9.3.1 накатывать? там где у Вас L3 агрегация

пока еще нет, на "рабочей лошади" не хочется пробовать... жду "лабораторный" образец. :)
А вот "уровень доступа" на 3064 уже попробовали зашить на 9.3.1 - полет нормальный.

Edited by AAS

Share this post


Link to post
Share on other sites
1 час назад, AAS сказал:

пока еще нет, на "рабочей лошади" не хочется пробовать...

какой софт стоит на 3132?

Share this post


Link to post
Share on other sites

может еще подскажите по такому, перекинул на него все линки с своих китайцев, из всех, один сфп не показывает что его вставил в свичт, еще один показывает что есть сфп но линк не поднимает.

Хотя в китайцах работает эти модули

Share this post


Link to post
Share on other sites

трансиверы какие?

пробовали?

(config)# service unsupported-transceiver

Edited by fork

Share this post


Link to post
Share on other sites

да, только после этой команды пошли все работать, из неработающих

opticin 

и 

upnet на 40км

 

при этом другие оптицин работают.

 

во вложении сфп которые не пошли

IMG_7472.jpg

IMG_7473.jpg

Share this post


Link to post
Share on other sites

opticin, вроде, не махровый ноунейм, должен работать

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now