Jump to content
Калькуляторы

MikroTik CSR112 добавление vlan группой

Приветствую. 
Купили новую железку CSR112-8G-4S и встал вопрос настройки вланов. 
Задача стоит в том, чтобы прописать транком на портах около тысячи vlan`ов, преимущественно с использованием встроенного switch-чипа (Switch > VLAN,  для чего то же он там стоит)). 
Использовать vlan-filtering в bridge не вариант, хоть и там вполне нормально реализована возможность вписывать вланы диапазонами (например 1100-1300). 
По мануалам все предельно понятно как прописывать вланы, но за раз можно прописать лишь один Vlan-id.
Я считаю, что прописывать 1000 vlan по отдельности это глупость. 
Подскажите как по правильному это реализовать и без тысячи строчек конфига?)
 

Share this post


Link to post
Share on other sites

На первом руками, на остальных - копировать простыню в терминал. Есть скриптовый язык/API, написать нужное займет примерно столько же времени, сколько руками наклонировать. В принципе, в Excel - сделать образец, растянуть поле ID вниз до нужного кол-ва, потом простыню в терминал скопировать.

Share this post


Link to post
Share on other sites
:for i from=1 to=1000 do={ 
   :do {/interface vlan add interface=ether1 name="vlan$i" vlan-id=$i} on-error={}
}

 

Share this post


Link to post
Share on other sites

Можно не прописывать, просто прогнать сквозняком, выдернув из всего потока нужный влан для управления :) Что то типа аналога команды у длинка vlan_trunk :)

Edited by Ace63

Share this post


Link to post
Share on other sites

Имеется CRS112 как у автора.

Сейчас вланы (на одном порту транк, на одном и транк и антег, на остальных антег) настроены через switch - vlan.

Используется свитч-чип, потому что 700 мбит трафика софтово с 400мгц он точно не потянет.

Вопрос собственно в том, если настроить вланы через bridge - vlan filtering и применять к каждому порту бриджа hardware offload, будет ли это так же работать через свитч чип?

Вопрос возник потому что надо будет настраивать ещё некое количество таких свитчей, а через бридж как-то оно нагляднее.

Или всё же будет работать через процессор?

Edited by Trueno

Share this post


Link to post
Share on other sites

@jffulcrum благодарю.

А на всяком старье типа 2011 это даст какое то улучшение?

В отличие от классического варианта по бриджу для каждого влан-айди и засовывания туда нужных интерфейсов?

Share this post


Link to post
Share on other sites

@jffulcrum

я в случае про 2011 и не говорю про 700 мбит ))

там есть такие что по 150-200 мбит гоняют

и куча бриджов создана, чтобы каждый бридж обьединял нужный влан и порт

загрузка проца под 70-80 процентов бывает

вот и подумал, не поможет ли это ему

хотя понятно дело, что это полное старьё.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now