Jump to content
Калькуляторы

Делегация IPv6 на следующий маршрутизатор

Подскажите как настроить раздачу IPv6 адресов микротиком после маршрутизатора провайдера. 
Схема следующая: Calix T073G-2 (шлюз) => MikroTik (в DMZ) => Компы.
Сейчас каликс получает от провайдера IPv6 адрес, префикс, днс и адрес шлюза. Необходимо что-бы микротик мог раздавать IPv6.

Share this post


Link to post
Share on other sites

Если Каликс настроен с головы так, что анонсирует сеть (advertise) - то делать вообще ничего не нужно, микротик сам получит адрес и швырнет оповещения дальше. Проблемы будут только с DNS, надо или RADDNS ретрансляцию делать, или DHCPv6 сервер. Если же Каликс ничего не анонсирует, а делает NAT64 - хоть что делайте, публичного IPv6 вам за ним не получить.

Share this post


Link to post
Share on other sites

Каликс анонсирует через SLAAC, если я правильно понимаю. Например если подключить комп к каликсу то он получит ipv6, dns и шлюз, а вот микротик почему то не получает адрес

Share this post


Link to post
Share on other sites

Прикрепите конфиг с микрота. Зачем он вам вообще, кстати, нужен для IPv6? Воткнуть за Каликсом свитч и компы.

Share this post


Link to post
Share on other sites
2 hours ago, vitaliy91 said:

Сейчас каликс получает от провайдера IPv6 адрес, префикс, днс и адрес шлюза. Необходимо что-бы микротик мог раздавать IPv6.

"Делегация" это про другое, это не сильно простой процесс.

Первый роутер должен по DHCPv6 у оператора запросить префикс именно для делегирования. SLAAC тут не причем, это про другое.

Операторский роутер должен взять из своей БД префикс и передать его первому роутеру, одновременно с установкой маршрута в сторону абонента. Это будет ДРУГАЯ сеть, отличная от линковочной.

И ее размер может быть условно любым, например /56.

Теперь первый роутер должен по каким-то своим, настроеным админом или гвоздями прибитым индусским программистом, правилам, порезать эту сетку на сетки поменьше, одну например назначить на линк в сторону LAN, остальные держать "в уме", чтобы роутер номер 2, мог повторить процесс, аналогично, только в паре роутер1 и роутер2.

 

Это если система "полный автомат", т.е. сферически в вакууме и маловероятный в реальности вариант.

 

Вариант попроще:

провайдер вам руками "делегирует" подсеть /56. Вы ее руками нарезаете внутри на нужное число /64 и руками настраиваете.

Share this post


Link to post
Share on other sites

@ShyLion Провайдер отдаёт подсеть /64

Как микротику получить префикс от операторского роутера?

Edited by vitaliy91

Share this post


Link to post
Share on other sites
1 час назад, vitaliy91 сказал:

@ShyLion Провайдер отдаёт подсеть /64

Как микротику получить префикс от операторского роутера?

 

Настроить на микротике DHCPv6 клиента.

Провайдер то точно даёт кроме /64 SLAAC по DHCPv6 префикс?

Share this post


Link to post
Share on other sites
38 minutes ago, disappointed said:

Настроить на микротике DHCPv6 клиента.

Провайдер то точно даёт кроме /64 SLAAC по DHCPv6 префикс?

Вот статус WAN операторского роутера. Микротик по DHCPv6-Client не получает ни префикс ни адрес.

1561475089782.jpg

Share this post


Link to post
Share on other sites

Если кратко - ниче работать не будет потому что вам не хватает ип6 адресов, хаха да мне тож смешно. просите у прова больше.

Если подробнее то slaac не умеет меньше 64 префикса. Т.е 112 slaac ом раздать не выйдет. В теории можно забить болт на тупой slaac и пользоватся dhcpv6 этот че хошь раздаст.... но *** этоже микротик. В микротике dhcpv6 сервер *** не умеет раздать адреса... тока префиксы. Соотвествено на каждом клиенте должен быть дхцп клиент который забирает префикс и генерит себе из него адрес. Попробуй найди такой да еще и под весь зоопарк клиентов. Микротик дхцп клиент кстати тоже этава не умеет хаха. 

Дальше о крутом ип6. Slaac работает только с клиентами... конечными, он раздаст адрес только если твой девайс не роутер. Если ты поставил ipv6.forwarding=1 все, *** slaacy. Больше он роутер ниче от него принимать не будет. Потому от прова чтобы принять префикс нужно испооьзовать дхцп клиент. Нарезать префикс на пулы и потом эти пулы раздавать слааком клиентам... но все это работает только если тебе прилетел префикс больше 64.

Share this post


Link to post
Share on other sites

Я на микротике принимал от оператора единственную /64, один адрес из этой /64 ставил на микротике на бридж локальной сетки,

добавлял рукми два статических специфичных маршрута /65 в локалку.

И отдельно анонсировал в локалку по SLAAC дополнительно всю /64. Могу путать какой то момент, но работало, за неимением возможности

получить больше одной /64 для нормальной маршрутизации.

Share this post


Link to post
Share on other sites

Чтобы он раздавал слааком нужно повесить 64 адрес на интерфейс в который раздаешь и поставить галку advert как его там и эта галка не ставится если адрес меньше. А если на пох налепить 64 ну и пусть пересекаются то он потом автоматом впмсывает маршруты... с одинаковыс префиксом. Можно было бы сделать врф но роутинга в6 в микротике как у дир300 он ниче не может. Я уже нежелю ебусь с этим в6 нервы кончаются.

 

Я уже даже проблвал префиксы резать по 128 -)))) и раздавать по дхцп. На этапе нарезки микротик виснет намертво. Поди память кончилась.

Share this post


Link to post
Share on other sites

@user71 У операторского роутера есть еще DHCPv6 Server, это тоже не поможет микротику?

Share this post


Link to post
Share on other sites

если префикс статический можно руками вписать "все как надо" а оператору сказать чтоб маршрут прописал. и у себя маршруты прописать и адреса тоже прописать 128 бит.... просто прелесть

Share this post


Link to post
Share on other sites
1 час назад, user71 сказал:

Если ты поставил ipv6.forwarding=1 все, *** slaacy. Больше он роутер ниче от него принимать не будет.

Обходится /ipv6 settings accept-router-advertisements yes

Share this post


Link to post
Share on other sites

 

20 minutes ago, jffulcrum said:

Обходится /ipv6 settings accept-router-advertisements yes

Может быть. Это как то поможет в задаче распилить динамический 64 на подсети?

Share this post


Link to post
Share on other sites

с нетерпением жду. мои идеи уже кончились. я подумываю выкинуть микротик и гонять все через линукс, половина функционала туда уже переехала если и роутинг микротик не сможет.... ну и зачем он нужен тогда.

Share this post


Link to post
Share on other sites

Коллеги, нельзя ipv4 привычки 1 в 1 переносить на ipv6.

Для ipv6 prefix delegation у провайдера должна быть настроена соответственная инфраструктура.

 

Топикстартеру: попросите у провайдера PA префикс, такие выдают операторам вагонами бесплатно.

 

А если хочется PI, то за скромные 50 евро в год вам дадут /48. Которые может анонсировать за вас провайдер если нет желания морочится с бгп.

Share this post


Link to post
Share on other sites

Вышестоящий микротик берет у he.net /48 префикс, режет на /56 и отдает /64 нижестоящим

/ipv6 dhcp-server
add interface=bridge_local name=server1
/ipv6 pool
add name=test_pool prefix=2001:470:XXXX:100::/56 prefix-length=64
/ipv6 address
add address=2001:470:YY:7c4::2 advertise=no interface=sit1
add address=2001:470:ZZ:7c4::1 interface=bridge_local
add address=2001:470:XXXX::8e7d/48 advertise=no interface=bridge_ipv6
/ipv6 nd
set [ find default=yes ] interface=bridge_local other-configuration=yes
/ipv6 route
add distance=1 dst-address=2000::/3 gateway=2001:470:YY:7c4::1

конфиг нижестоящего

/ipv6 dhcp-server
add interface=bridge name=server1
/ipv6 address
add address=::1 from-pool=test interface=bridge
/ipv6 dhcp-client
add interface=pptp-out1 pool-name=test request=prefix
/ipv6 nd
set [ find default=yes ] interface=bridge other-configuration=yes
/ipv6 route
add distance=0 dst-address=2000::/3 gateway=pptp-out1

клиенты нижестоящего (винда, аррле, андроиды) нормально получают адреса, днс, роуты

Ethernet adapter Подключение по локальной сети:

   DNS-суффикс подключения . . . . . :
   Описание. . . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Физический адрес. . . . . . . . . : 
   DHCP включен. . . . . . . . . . . : Да
   Автонастройка включена. . . . . . : Да
   IPv6-адрес. . . . . . . . . . . . : 2001:470:ZZ:7c4:10c2:563:a21e:a9eb(Основн
ой)
   Локальный IPv6-адрес канала . . . : fe80::10c2:563:a21e:a9eb%11(Основной)
   IPv4-адрес. . . . . . . . . . . . : 192.168.88.251(Основной)
   Маска подсети . . . . . . . . . . : 255.255.255.0
   Аренда получена. . . . . . . . . . : 25 июня 2019 г. 20:24:12
   Срок аренды истекает. . . . . . . . . . : 30 июня 2019 г. 20:24:12
   Основной шлюз. . . . . . . . . : fe80::ce2d:e0ff:fe76:e522%11
                                       192.168.88.1
   DHCP-сервер. . . . . . . . . . . : 192.168.88.1
   IAID DHCPv6 . . . . . . . . . . . : 246161931
   DUID клиента DHCPv6 . . . . . . . : 00-01-00-01-1A-0D-91-D2-

   DNS-серверы. . . . . . . . . . . : 2606:4700:4700::1111
                                       2606:4700:4700::1001
                                       192.168.88.1

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now