Jump to content
Калькуляторы
Только что, vurd сказал:

LDP то заработал вообще?

Да, с ним всё ок.

 

C6506#show mpls ldp neighbor
    Peer LDP Ident: 10.101.101.1:0; Local LDP Ident 10.101.101.2:0
        TCP connection: 10.101.101.1.646 - 10.101.101.2.53732
        State: Oper; Msgs sent/rcvd: 20/16; Downstream
        Up time: 00:11:47
        LDP discovery sources:
          Targeted Hello 10.101.101.2 -> 10.101.101.1, active
          Vlan555, Src IP addr: 10.0.0.1
        Addresses bound to peer LDP Ident:
          10.0.0.1        10.101.101.1

 

SNR-S300G-24FX#show mpls ldp neighbor
IP Address        Intf Name   Holdtime   LDP-Identifier
10.0.0.2          Vlan555     15         10.101.101.2:0
10.101.101.2      Vlan555     90         10.101.101.2:0

 

Share this post


Link to post
Share on other sites
interface GigabitEthernet1/48 (Порт смотрящий на клиента)
 mtu 1500
!
interface GigabitEthernet1/48.111
  no xconnect 10.101.101.1 111 encapsulation mpls
  xconnect 10.101.101.1 111 encapsulation mpls
!

Давайте еще вот так попробуем. я ставлю всё-таки на проблему с разными mtu по сторонам vc

Share this post


Link to post
Share on other sites

На 6500 параметр MTU для всех интерфейсов берется из глобала.

Т.е. если в глобале указано 1608 то на интерфейсе можно выставить только 1608.

Share this post


Link to post
Share on other sites
3 минуты назад, Jora_Cornev сказал:

На 6500 параметр MTU для всех интерфейсов берется из глобала.

Т.е. если в глобале указано 1608 то на интерфейсе можно выставить только 1608.

Нет.

Если между родительским и саб-интерфейсом, то да, если просто два разных интерфейса, то нет.

Я и говорю тс ставить на родительском.

Share this post


Link to post
Share on other sites

да какая разница.. если там даже метки remote не видно.. при разнице в мту оно бы написано про мисматчи в details.

Share this post


Link to post
Share on other sites
12 минут назад, vurd сказал:

Я и говорю тс ставить на родительском.

Да я бы с радостью....

6500.png

Share this post


Link to post
Share on other sites

Так. А вот такой вопрос.

 

У вас на циске

interface Loopback1
   ip address 10.101.101.2 255.255.255.255
!

а на снр написано

l2-vc 10.102.102.2 pw-id 111 pw-class transport-vlan

 

У вас тупо ошибка в адресе, соединяется в никуда.

 

И кстати на циске в ospf вот это

network 10.101.101.2 0.0.0.0 area 0

не нужно, ибо вы и так делаете 

redistribute connected

 

 

Да и вообще какой-то бардак в адресах. У вас и на снр адресом лупбека установлен адрес лупбека циски.

Share this post


Link to post
Share on other sites

@vurd Спасибо!

Всё заработало.

 

 

16 минут назад, vurd сказал:

У вас и на снр адресом лупбека установлен адрес лупбека циски.

Где вы это увидели?

 

 

 

 

Share this post


Link to post
Share on other sites
56 минут назад, Jora_Cornev сказал:

@vurd Спасибо!

Всё заработало.

 

 

Где вы это увидели?

 

 

 

 

В ваших конфигах...

Share this post


Link to post
Share on other sites

Вопрос ТП Нага, как на SNR включить debbug MPLS ?

 

Скрытый текст

SNR-S300G-24FX#debug ?
  aaa                        AAA
  anti-arpscan               Anti-arpscan
  arp                        ARP information
  bfd                        Bidirectional Forwarding Detection
  bgp                        BGP information
  captive-portal             Debug captive portal feature information
  captive-portal-cluster     Debug captive portal cluster feature information
  captive-portal-redirect    Debug captive portal redirect feature information
  chassis                    Chassis information
  cluster                    Debug cluster
  dcp                        Dynamic CPU Protection
  devsm                      DEVSM information
  dns                        DNS
  dot1x                      Dot1x
  driver                     Driver information
  dvmrp                      Distance Vector Multicast Routing Protocol (DVMRP)
  erps                       Ethernet ring protection switching
  ethernet                   Ethernet
  ethernet-oam               Ethernet in the First Mile Operation, Administration and Maintenance
  fulleaps                   FULL Ethernet Automatic Protection Switching
  gre                        Generic route encapsulation protocol
  gvrp                       GVRP
  ha                         HA debugging
  http                       http server
  igmp                       Internet Group Management Protocol
  ip                         Internet Protocol
  ipfix                      IP Flow Information eXport
  ipv6                       IPv6 information
  isis                       IS-IS information
  keepalive-gateway          keepalive-gateway system
  ldp                        Label Distribution Protocol (LDP)
  lldp                       Link Layer Discovery Protocol
  load                       LOAD information
  loopback-detection         Loopback-detection
  mac-authentication-bypass  Debug MAC authentication bypass feature information
  mim                        mac-in-mac
  mld                        Multicast Listener Discovery
  mrpp                       Multi-layer Ring Protection Protocol
  msdp                       Multicast Source Discovery Protocol(MSDP)
  nqa                        Network Quality Analyzer
  ntp                        Network time protocol
  openflow                   OPENFLOW information
  ospf                       OSPF information
  pim                        Protocol Independent Multicast (PIM)
  port-channel               Port group interface
  pppoe-ia                   PPPOE intermediate Agent
  rip                        RIP information
  savi                       Source Address Validation Improvements
  sftp                       sftp Configuration
  snmp                       Snmp information
  sntp                       Simple Network Time protocol
  spanning-tree              Mstp info
  ssh-server                 Debug ssh-server
  ssl                        Ssl
  switchport                 Set switchport character
  tacacs-server              Config tacacs+ server
  track                      Config track entry
  transceiver                Transceiver information
  trill                      TRILL commands
  uldp                       ULDP information
  ulpp                       Uplink Protection Protocol
  ulsm                       Uplink State Monitor
  urpf                       Unicast reverse path forwarding
  vepa                       VEPA configuration
  vepa-old                   Virtual Edge Port Aggregator
  vlan                       Vlan Commands
  vpls                       Virtual Private Lan Service
  vrrp                       Virtual Router Redundancy Protocol (VRRP)
  vsf                        Vsf
 

Share this post


Link to post
Share on other sites
22 hours ago, Jora_Cornev said:

Вопрос ТП Нага, как на SNR включить debbug MPLS ?

 

Добрый день. Что именно вы хотите увидеть? Сигнализация MPLS в коммутаторах SNR происходит через LDP поэтому вы можете воспользоваться debug ldp.

Share this post


Link to post
Share on other sites
В 28.05.2019 в 12:46, vurd сказал:

Interface Ethernet1/0/2
 description vlan ver mpls
 xconnect l2-vc pw-id 200 mode vlan svid 200

Интересует информация о состоянии (debbug) xconnect l2-vc

Share this post


Link to post
Share on other sites

День добрый,

 

 на днях пришлось пободаться так же с MTU между C6500 и S300, после танцев с MTU пришел к следующему:

если делать l2-vc 10.0.0.1 pw-id 4040 pw-class блаблабла

то при любом раскладе remote mtu всегда рисует 1500 (даже если на S300 MTU стоит, например, 2000), но если сделать:

l2-vc 10.0.0.1 pw-id 4040 mtu 9216
 

то взлетает без бубна:

sh mpls l2transport vc 4040 detail | i MTU
    MTU: local 9216, remote 9216
 

может кому пригодится, в моем случае снижать 9216 не вариант априори.

Share this post


Link to post
Share on other sites

Здравствуйте.

 

А почему так не хочет работать?

 

Interface Ethernet1/0/1
 speed-duplex force1g-full
 description IN
 switchport mode trunk
 switchport trunk allowed vlan 61
 xconnect vfi 61 mode vlan svid 61
!
Interface Ethernet1/0/2
 speed-duplex force1g-full
 description PC
 switchport mode access
 switchport acess vlan 61
!

VLAN 61 пришел с 1 порта, я его выкинул по вплс в сторону другого СНР, и этот же влан проключил на свободный 2 порт.

Оно заработает если xconnect с 1 порта убрать. А как без него то, он тоже нужен)

 

В табличке это так:

 

SNR-300-1#sh mac-address-table vlan 61     
Read mac address table....
Vlan Mac Address                 Type    Creator   Ports
---- --------------------------- ------- -------------------------------------
61   00-a0-d1-5b-53-55           DYNAMIC Hardware Ethernet1/0/2
SNR-300-1#

 

А где маки с 1 порта?

Хотя выше еще один свич (который к этому 1 порту подключен), и с его порта я вижу мак. Но все равно не пашет чото.

Как и вплсить и свичевать одновременно?

Share this post


Link to post
Share on other sites

Я не всосал до конца, но у вас логика неправильная. Если вам надо иметь vid l2 на одном коммутаторе, то надо порты делать членами vpls-домена, а не поднимать сам vlan локально.

 

т.е. делайте

 

int eth1/0/2

 no switchport access vlan

 xconnect vfi 61

!

int eth1/0/1

 switchport trunk allowed null

!

end

no vlan 61

wr

 

Share this post


Link to post
Share on other sites

@vurd мне надо один широковещательный домен и по вплс и свичингом.

Там где живет команда 

xconnect vfi 61 mode vlan svid 61

Автоматически инкапсулируется в dot1q, это да.

Я просто подумал, если свич не знает про влан 61 - надо его создать) тем более allowed vlan 61 на том же интерфейсе не мешает иксконнекту.

 

Ладно, как тогда?

xconnect команда должна висеть на порту, где я хочу получить метку в будущем? А если их десять?

Я ее повесил на порту 1, который смотрит "наружу", где живет 61 физически. Далее 61 пролетел по впла сдо другого снр, там я его принял, ок. Но 61 нужен еще на 2 порту этого же первого снра, но без иксконнекта.

 

 

 

61 --------- транк ---------- (1)СНР1(3)  --------вплс--------- (3)СНР2(1) -- 61

                                              (2)                                          

                                                |

                                               61

 

иксконнекты созданы соответственно на 1 порту СНР1 и 1 порту СНР2

2 порт СНР1 - просто порт, хоть транк хоть аксес..неважно. Пускай это комп. Хочу 61 на 2 порту СНРа.

Share this post


Link to post
Share on other sites

===========

UPD:

 

Разобрался.

Действительно надо вешать xconnect на все порты, где будет жить данный влан.

На хуавэе вообще не так) там саб с влл и понеслась простой свичинг хоть куда. Я по аналогии и зафигачил.

 

Если у меня езернет, то просто иксконнекчу езернет видимо.

Вопрос закрыт) Спасибо.

 

Share this post


Link to post
Share on other sites

Здесь нельзя сделать как в циске

int vlan 828

xconnect vfi 828

 

Или vlan или vpls. Если надо и то и то (из-за l3 интерфейса, например), то добро пожаловать в физическую петлю между портами. (http://vurd.name/2020/10/15/s300-vpls-irb/)

Share this post


Link to post
Share on other sites

Все ок, я разобрался как тут)

 

Вопщем первые итоги по л2впн.

Собрал лабу фулмэш:

33141334_m.jpg

 

Тут работают три snr-s300g и два роутера другого вендора.

В мплс катаются куинку вланы, которые пакуются на агрегациях. 
Перемесил ЛАГи рандомных вендоров.

Рутинг оспф, мультикаст организован средствами pim-sm внутри кольца. На агрегациях ism.

Из тюнинга только тайминги и bfd.

Кстати по таймингам камент, я на вебинаре тоже писал, у разных вендоров разные дефолтные тайминги для работы LDP. В связи с чем наблюдал расколбас ldp-нейборов. Благо на снр есть дебаг, обнаружилось быстро.

Приключений особых не было. Заработало сразу. И мплс и вплс.

 

Вопщем главное это тайминги и мту наверно. Если настроить то пашет как атомный реактор. Мне понравилось.

 

Жаль конечно что траффик-инжиниринга нет. Но и на том спасибо.

Share this post


Link to post
Share on other sites

UPD:

 

В схеме выше собран ПИМ-см, доступ внизу работает по мплс л2вс.

Т.к. это лаба, я инет и ИПТВ забрал с разных портов у верхнего СНР-1.

Потом переключил все в один транк и забыл. Включаю стенд - ПИМ не работает.

 

Конфиг верхнего СНР-1, порт в который льет мультикаст во влане 100.

 

Interface Ethernet1/0/28
 speed-duplex force1g-full
 description IN_MACST
 switchport discard packet untag
 switchport mode trunk
 switchport trunk allowed vlan 100 

 

Потом я с этого же порта зафигачил влан для доступа по влл. Стало так:

Доступ работает, все ок во влане 3112.

 

Interface Ethernet1/0/28
 speed-duplex force1g-full
 description IN_MACST
 switchport discard packet untag
 switchport mode trunk
 switchport trunk allowed vlan 100 
 xconnect l2-vc pw-id 3112 mode vlan svid 3112 

 

А ПИМ помер)

Почему?

АРП в 100 живой, источники пингуются.

 

Убираю икс-коннекты - ПИМ взлеает. Не понял связи.

Share this post


Link to post
Share on other sites

@vurd Походу это мой случай что ли. С петлей то.

Фига колхоз(

 

Это расход порта, расход производительности на лишнюю коммутацию, и наверно еще что-нибудь плохое...

Я правильно понял что L3 интерфейс не будет работать на порту где мплс/вплс?

Share this post


Link to post
Share on other sites

@semop К сожалению, на одном порте при текущей архитектуре ПО нельзя использовать PIM/IGMP и L2VPN. Только с петлевой схемой.

Share this post


Link to post
Share on other sites

@Aleksey Sonkin понял, спасибо

А с чем еще столкнуться можно?

В вебинаре весьма поверхностно все было. Просто основы. Соединить комп-комп. Но так же не бывает)

Share this post


Link to post
Share on other sites

@semop если будут проблемы - пишите в чат или задавайте вопрос здесь, навскидку других подобных ситуаций не припомню. Дизайн сети у всех разный и, соответственно, нюансы тоже.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this