Jump to content
Калькуляторы

Вопрос по Cisco Catalyst

Столкнулся с такой проблемой.

Есть такой каталист 3750:

vlan 30
!
interface Port-channel1
 description L1-NET
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan ...,30,...
 switchport mode trunk
!
interface FastEthernet1/0/24
 switchport access vlan 30
!
interface Vlan30
 ip address 10.1.144.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp

Ранее в порт 24 была подключена небольшая сетка, все работало.

Потом я переключил сетку на другой коммутатор, а vlan 30 пробросил до каталиста.

И все сломалось.

Если выполнить sh int vlan 30, то показывает "Vlan30 is up, line protocol is down", IP-адрес 10.1.144.1 не пингуется.

Если в порт 24 что-нибудь подключить (чтобы на порту был линк и line protocol is up), то все работает.

Вроде бы такого быть не должно? Или я что-то не учел.

Share this post


Link to post
Share on other sites

Надо чтоб vlan 30 был подан на какой-нибудь активный порт иначе он будет down, так как никуда не подан.

Share this post


Link to post
Share on other sites

Хоть один из членов портченела в апе? Сам портченел в апе?

Share this post


Link to post
Share on other sites
show vlan id 30

Покажите

Share this post


Link to post
Share on other sites
#sh vlan id 30

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
30   OFFICE                           active    Fa1/0/24, Po1

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
30   enet  100030     1500  -      -      -        -    -        0      0   

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

 

Share this post


Link to post
Share on other sites

По выводу должно работать. Это похоже баг какой-то.

Share this post


Link to post
Share on other sites

Не исключено.

Сейчас вытащил патчкорд из порта 24 и SVI не упал.

Share this post


Link to post
Share on other sites

Попробуй 

conf t

int vlan 30

no shu

 

ну и ещё  посмотри sh mac address-table vlan 30

Share this post


Link to post
Share on other sites

stp то отключен?

show spanning-tree vlan 30

 

Share this post


Link to post
Share on other sites
В 07.05.2019 в 17:26, stalker86 сказал:

Попробуй 

conf t

int vlan 30

no shu

 

ну и ещё  посмотри sh mac address-table vlan 30

 Бессмысленно. Vlan up, протокол даун. Если с вланами всё в порядке, то на аплинках маки этого влан будут, а на погасшем аксессе - понятно нет. Почему 3750 решил что протокол даун ? Возможно потому, что влан не транзитный, и упирается в акцесс единственный, погашенный. Можно конечно пробросить в транке этот влан куда-нибудь  еще, где линк есть, то я думаю - всё заработает. Костыль, но для понимания логики кискоделов пригодится.

Share this post


Link to post
Share on other sites
В ‎07‎.‎05‎.‎2019 в 15:31, zhenya` сказал:

stp то отключен?

Отключен.

Но даже будь он включен, разве на это может повлиять неактивный (неподключенный) порт?

 

1 минуту назад, YuryD сказал:

Можно конечно пробросить в транке этот влан куда-нибудь  еще, где линк есть, то я думаю - всё заработает.

Он был проброшен в po1, но не работал.

Видимо какой-то специфичный баг.

Share this post


Link to post
Share on other sites
3 минуты назад, alibek сказал:

Отключен.

Но даже будь он включен, разве на это может повлиять неактивный (неподключенный) порт?

 

Он был проброшен в po1, но не работал.

Видимо какой-то специфичный баг.

 В общем-то 3750 у меня еще уже немного осталось, но таких извращенных конфигов не делал. Максимум - управляющий влан, который работает всегда, даже если в аксессе ни одного порта нету. Потихоньку эти хабазины убираю, жрут как не в себя, и габаритны.  Возможно конечно и баг софта, но для меня уже неактуально. 29серия лучше.

Share this post


Link to post
Share on other sites

Как вариант, можно autostate закостылить. Должно работать.

Share this post


Link to post
Share on other sites

Я же конфиг в первом посте приводил, VLAN 30 в po1 есть.

#sh int po1 trunk 

Port        Mode             Encapsulation  Status        Native vlan
Po1         on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po1         10,20,30,60,100,103,203,209,300,390,399,900-902

Port        Vlans allowed and active in management domain
Po1         10,20,30,60,100,103,203,209,300,390,399,900-902

Port        Vlans in spanning tree forwarding state and not pruned
Po1         10,20,30,60,100,103,203,209,300,390,399,900-902

 

Share this post


Link to post
Share on other sites

ну меня больше интересовал раздел 

Vlans allowed and active

чем конфиг, 

в момент наблюдения проблемы посмотрите этот же вывод

Share this post


Link to post
Share on other sites

Я не вижу оснований, почему список allowed и active может отличаться.

Все VLAN заведены статикой, никакого GVRP или какой-либо экзотики нет.

Скорее всего это был глюк, надеюсь разовый.

Share this post


Link to post
Share on other sites
3 часа назад, alibek сказал:

Я не вижу оснований, почему список allowed и active может отличаться.

Все VLAN заведены статикой, никакого GVRP или какой-либо экзотики нет.

Скорее всего это был глюк, надеюсь разовый.

pruning, например - экзотика?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this