Jump to content
Калькуляторы

Cisco 7600 service-policy out

Есть Cisco7600 c RSP720 все установленные модули с DFC (6708).

 

Есть необходимость повесить на один из SVI политику на output.

Политика простая:


 

policy-map Customer1-OUT

  class Customer1-OUT
    police cir 3145728000 bc 31250000 pir 3145728000 be 31250000 conform-action transmit exceed-action drop  violate-action drop

!

interface Vlan501

ip address ...

service-policy output Customer1-OUT

!

interface TenGigabitEthernet1/3
 description
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 501
 switchport mode trunk

 

Но возникает проблема. Политика не работает. Такое впечатление, что ограничение на каждом модуле свое. Как сделать, чтобы ограничение в 3ГБ/с было общее?

 

   class-map: Customer1-OUT (match-all)
      Match: access-group name Customer1-OUT
      police :
        3145728000 bps 31250000 limit 31250000 extended limit
      Earl in slot 1 :
        214663925855 bytes
        5 minute offered rate 750205904 bps
        aggregate-forwarded 214663925855 bytes action: transmit
        exceeded 0 bytes action: drop
        aggregate-forward 723111200 bps exceed 0 bps
      Earl in slot 2 :
        239894739668 bytes
        5 minute offered rate 868090112 bps
        aggregate-forwarded 239894739668 bytes action: transmit
        exceeded 0 bytes action: drop
        aggregate-forward 827445824 bps exceed 0 bps
      Earl in slot 3 :
        108234961755 bytes
        5 minute offered rate 380137264 bps
        aggregate-forwarded 108234961755 bytes action: transmit
        exceeded 0 bytes action: drop
        aggregate-forward 391241680 bps exceed 0 bps
      Earl in slot 4 :

        323278294815 bytes
        5 minute offered rate 1129390680 bps
        aggregate-forwarded 323278294815 bytes action: transmit
        exceeded 0 bytes action: drop
        aggregate-forward 1278673224 bps exceed 0 bps
      Earl in slot 5 :
        0 bytes
        5 minute offered rate 0 bps
        aggregate-forwarded 0 bytes action: transmit
        exceeded 0 bytes action: drop
        aggregate-forward 0 bps exceed 0 bps

 

 

Share this post


Link to post
Share on other sites

mls qos vlan-based ?

Share this post


Link to post
Share on other sites

и с ним и без него пробовал. результат одинаковый - превышение лимита.

Share this post


Link to post
Share on other sites

Обновили IOS до 12.2(33)SRE15a, проблема осталась.

Share this post


Link to post
Share on other sites

а где у вас class-map для Customer1-OUT ? либо нарисуйте, либо в policy используйте "class class-default".

Share this post


Link to post
Share on other sites

class-map match-all Customer1-OUT
  match access-group name Customer1-OUT
!
ip access-list extended Customer1-OUT
 permit ip any 192.168.1.0 0.0.0.255
 permit ip any 192.168.2.0 0.0.0.255

 

Share this post


Link to post
Share on other sites

Хмм... А можно посмотреть на

show mls qos

show mls qos ip vlan501

?

 

nevermind. судя по этому:

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/12-2SX/configuration/guide/book/qos.pdf с.43-18

 

Each PFC or DFC polices independently, which might affect QoS features being applied to traffic that is distributed across the PFC and any DFCs.

 

Share this post


Link to post
Share on other sites

interface Vlan501
 ip address ............
 rate-limit output 3145728000 31250000 31250000 conform-action transmit exceed-action drop
..
..
end
 

Share this post


Link to post
Share on other sites
В ‎17‎.‎05‎.‎2019 в 17:13, z18 сказал:

Хмм... А можно посмотреть на

show mls qos

show mls qos ip vlan501

?

 

nevermind. судя по этому:

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/12-2SX/configuration/guide/book/qos.pdf с.43-18

 

Each PFC or DFC polices independently, which might affect QoS features being applied to traffic that is distributed across the PFC and any DFCs.

 

Global Values:
  QoS is enabled globally
  Policy marking depends on port_trust
  mls qos rewrite ip dscp disabled on slots: None
  mls qos recirc  untrust disabled on slots: None
  QoS serial policing mode disabled globally
  Input mode for GRE Tunnel is Pipe mode
  Input mode for MPLS is Pipe mode
  Vlan or Portchannel(Multi-Earl) policies supported: Yes
  Egress policies supported: Yes
  Police acl redirected packets enabled: No
  Marking statistics enabled: Yes
sh mls qos ip vlan 501
   [In] Policy map is    [Out] Policy map is Customer1-OUT
 QoS Summary [IPv4]:      (* - shared aggregates, Mod - switch module)

      Int Mod Dir  Class-map DSCP  Agg  Trust Fl   AgForward-By   AgPoliced-By
                                   Id         Id
-------------------------------------------------------------------------------
    Vl501  1 Out Customer1-OUT    0   16     --  0    29537297597              0
    Vl501  2 Out Customer1-OUT   0   16     --  0    57344584540              0
    Vl501  2 Out Customer1-OUT    0   17     --  0   195259968255              0
    Vl501  3 Out Customer1-OUT    0   16     --  0   308513254424              0
    Vl501  3 Out Customer1-OUT    0   17     --  0   263481036570              0
    Vl501  4 Out Customer1-OUT    0   16     --  0   218714499210              0
    Vl501  4 Out Customer1-OUT   0   17     --  0   211811260594              0
    Vl501  5 Out Customer1-OUT    0   16     --  0      791747314              0
    Vl501  5 Out Customer1-OUT    0   17     --  0       88397011              0
    Vl501  6 Out Customer1-OUT    0   16     --  0       95088484              0
    Vl501  6 Out Customer1-OUT    0   17     --  0    38124978410              0
    Vl501  7 Out Customer1-OUT    0   16     --  0    82685509500              0
    Vl501  7 Out Customer1-OUT    0   17     --  0         546038              0
    Vl501  8 Out Customer1-OUT    0   16     --  0   453210071113              0
    Vl501  8 Out Customer1-OUT    0   17     --  0   137205278307              0
    Vl501  9 Out Customer1-OUT    0   16     --  0    17818263068              0

Есть вот такой кусок в документации

Each PFC or DFC polices independently, which might affect QoS features being applied to traffic that is distributed across the PFC and any DFCs. Examples of these QoS feature are:

–Policers applied to a port channel interface.

–Policers applied to a switched virtual interface.

–Egress policers applied to either a Layer 3 interface or an SVI. Note that PFC QoS performs egress policing decisions at the ingress interface, on the PFC or ingress DFC.

Policers affected by this restriction deliver an aggregate rate that is the sum of all the independent policing rates. 

Последняя фраза не говорит ли что они суммируются? Да и Vlan or Portchannel(Multi-Earl) policies supported: Yes намекает на возможность или я ошибаюсь?

 

Share this post


Link to post
Share on other sites
5 hours ago, joesm said:

Последняя фраза не говорит ли что они суммируются? Да и Vlan or Portchannel(Multi-Earl) policies supported: Yes намекает на возможность или я ошибаюсь?

Они суммируются, но не в том смысле в котором вам надо: когда создается полисер, он выгружется в asic'и в pfc и всех dfc, и после этого они работают независимо (в этом и есть смысл dfc), т.е. создав полисер на гигабит, максимальная скорость будет 1(если в портах супервизора есть svi) + N (кол-во dfc где есть нужный вам svi) гигабит.

Чтобы сделать то, что вам нужно надо:

1) либо сделать так, чтобы svi не выходил за пределы одной карты (одного dfc)

2) повынимать DFC из карт (продать, деньги пропить ;), тогда они будут пользоваться CFC и решение будет принимать PFC. (правда CFC поддерживает не все карты)

 

вроде так.

Share this post


Link to post
Share on other sites

Было такое подозрение. Придется перенести клиента на другую железку.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now