Jump to content
Калькуляторы

Quagga помогите победить конфиг

Всем привет. Молю о помощи.

Имеется сеть на микротиках, возникла необходимость поднять OSPF на одном из серверов. По совету интернета поставил quagga, но что то не задалось у меня с ней и нужная подсеть не анонсируется. Помогите сделать правильный конфиг? Текущий конфиг микротика соседа и самого сервера по спойлером.

 

Конфиг микротика

Скрытый текст

/routing ospf instance
set [ find default=yes ] disabled=no distribute-default=never !domain-id !domain-tag in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 !mpls-te-area !mpls-te-router-id name=default out-filter=ospf-out redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no \
    redistribute-rip=no redistribute-static=no router-id=10.30.30.1 !routing-table !use-dn
/routing ospf area
set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
add area-id=0.0.0.1 disabled=no instance=default name=SAT.AREA type=default
/routing ospf interface
add authentication=simple authentication-key=AUTH_KEY authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=PPtP.SAT1 \
    network-type=point-to-point passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=simple authentication-key=AUTH_KEY authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=PPtP.SAT2 \
    network-type=point-to-point passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=simple authentication-key=AUTH_KEY authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=PPtP.SAT3 \
    network-type=point-to-point passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=simple authentication-key=AUTH_KEY authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=PPtP.SAT4 network-type=\
    point-to-point passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=md5 authentication-key=AUTH_KEY authentication-key-id=2 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=VID_528 network-type=\
    broadcast passive=no priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf network
add area=SAT.AREA disabled=no network=10.24.50.0/24
add area=backbone disabled=no network=10.24.115.0/24
add area=backbone disabled=no network=10.30.30.1/32
add area=backbone disabled=no network=10.10.10.0/24

 

 

Конфиг сети сервера

Скрытый текст

cat /etc/netplan/50-cloud-init.yaml
network:
version: 2
renderer: networkd
ethernets:
 eth0:
  addresses: [X.X.X.X/30,10.10.10.10/24,10.24.50.8/24]
  dhcp4: false
  gateway4: X.X.X.X
  nameservers:
   addresses:  
    - 8.8.8.8
    - 8.8.4.4

 

 

Конфиг который пытаюсь скормить quagge

Скрытый текст

interface eth0
description backbone
ip address 10.10.10.10/24
ip address 10.24.50.8/24
ip ospf authentication 10.24.50.8
ip ospf authentication-key AUTH_KEY
ip ospf message-digest-key 1 md5 AUTH_KEY
!
interface eth1
description backbone
!
interface lo
!
router ospf
ospf router-id 10.30.30.10
network 10.10.10.0/24 area 0.0.0.0
network 10.25.50.0/24 area 0.0.0.1
network 10.25.115.0/24 area 0.0.0.1
area 0.0.0.0 authentication message-digest
area 0.0.0.1 authentication
!
line vty

 

Сеть 10.10.10.0/24 нормально анонсируется в сеть микротика, сеть 10.24.50.0/24 никак не могу запустить в оспф

Edited by kolizey

Share this post


Link to post
Share on other sites
conf t
router ospf
redistribute connected
end
wr

 

Share this post


Link to post
Share on other sites
2 часа назад, vurd сказал:

conf t
router ospf
redistribute connected
end
wr

 

К сожалению не помогло (

Share this post


Link to post
Share on other sites
6 часов назад, kolizey сказал:

!
router ospf
ospf router-id 10.30.30.10
network 10.10.10.0/24 area 0.0.0.0
network 10._____25______.50.0/24 area 0.0.0.1
network 10.25.115.0/24 area 0.0.0.1
area 0.0.0.0 authentication message-digest
area 0.0.0.1 authentication
!
line vty

 

в  ospf секции опечатка? или в конфиге так же?

Edited by guеst

Share this post


Link to post
Share on other sites
1 час назад, guеst сказал:

в  ospf секции опечатка? или в конфиге так же?

 

Да нет там опечаток, 10.24.50.0/24, это тут я накосячил

Микротик соседство с им видит, но маршрута не прилетает (

Edited by kolizey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this