Jump to content
Калькуляторы

Пробросить 8 канальных интервалов точка точка

Здравствуйте Уважаемые форумчане

 

Мне необходимо, на оборудовании, что лежит под рукой 

Cisco 3725 и 2610  с модулями  VWIC-2MFT-E1-DI

построить прямой канал E1 из 8 КИ голосовых

и прозрачно передать 16КИ (так как мультиплексор поддерживает только 1ВСК сигнализацию).

 

Попросту говоря соединить две ЦАТС через оборудование cisco.

 

Проблема в том что interface Serial0/0:0 и interface Serial0/0.1 поднимается и падает.

Прошу помощи. 

 

 

 

Cisco2610_E1_BOBV#sh run
Building configuration...

Current configuration : 839 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2610_E1_BOBV
!

!
ip subnet-zero
!
!
call rsvp-sync
!
!
controller E1 0/0
 framing NO-CRC4
 clock source internal
 channel-group 0 timeslots 1-8
!
controller E1 0/1
!
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
 half-duplex
!
interface Serial0/0:0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0:0.1 point-to-point
 ip address 209.165.200.252 255.255.255.224
 frame-relay interface-dlci 100
!
router eigrp 1
 network 192.168.0.0
 network 209.165.200.0
 auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.2
no ip http server
!
!
dial-peer cor custom
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Cisco2610_E1_BOBV#
 

 

 

 

 

Router#sh run
Building configuration...

Current configuration : 1406 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash flash:c3725-advipservicesk9-mz.124-15.T1.bin
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
network-clock-participate wic 0
no network-clock-participate wic 1
network-clock-select 1 E1 0/0
ip cef
!
!
multilink bundle-name authenticated
voice-card 1
 no dspfarm
!
!
archive
 log config
  hidekeys
!
!
controller E1 0/0
 framing NO-CRC4
 channel-group 0 timeslots 1-8
!
controller E1 0/1
!
controller E1 0/2
!
controller E1 0/3
!
controller E1 1/0
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0:0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0:0.1 point-to-point
 ip address 209.165.200.253 255.255.255.224
 frame-relay interface-dlci 100
!
interface FastEthernet0/1
 bandwidth inherit
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 192.168.0.0
 network 209.165.200.0
 auto-summary
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip route 192.168.1.0 255.255.255.252 192.168.0.1
!
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!

!
webvpn cef
!
end

Router#

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Ingfa_1981, доброго времени суток.

 

 

 

Если совсем коротко, то без специальных модулей, прозрачно пробросить E1 по IP между CISCO в Вашем случае не получится.

 

Возможно, применить следующую схему: [АТС] <=E1=> CISCO <-IP связь (VoIP SIP или H.323) <=E1=> [АТС]

 

 

Главная особенность, что бы в обоих маршрутизаторах имелись DSP процессоры (платы, необходимы для оцифровки голоса E1 <=> VoIP).

 

Между АТС и CISCO (с обеих сторон) необходимо настроить соединение потоков E1 (после коммутации физического подключения):

 

  1. Настроить синхронизацию потока (определить, кто является ведущей и ведомой стороной), не путайте с режимами работы сигнализации.
  1. Выбрать приемлемую для АТС сигнализацию потока (с каждой из сторон, может быть разной) - устаревший вариант CAS или относительно современный ISDN PRI (DSS-1 или QSIG).
  1. При использовании ISDN PRI, назначить, кто является ведущей и ведомой стороной в отношении сигнализации.
  1. Связать CISCO по IP сети, используя протоколы VoIP - SIP или H.323.
  1. Создать план нумерации встречных вызовов на обоих маршрутизаторах (у АТС должна быть разная нумерация).

 

Если интересно, в пределах форума мы можем рассмотреть каждый отдельный пункт.

 

Надеюсь чем-то помог Вам.

 

 

 

Покажите, что выводит sh controller E1 0/0.
Покажите, что выводит sh isdn status.

Edited by SUrov_IBM

Share this post


Link to post
Share on other sites
8 hours ago, SUrov_IBM said:

Если совсем коротко, то без специальных модулей, прозрачно пробросить E1 по IP между CISCO в Вашем случае не получится.

Спасибо за помощь. Возникает вопрос без каких именно модулей вы имели ввиду не получиться прозрачно пробросить E1 по IP ?

 

Если без модулей DSP то скорее всего они установлены. (прикрепляю данные об оборудовании  к сообщению)

 

 

 

cisco_2610_оборудование.txt

cisco_3725_оборудование.txt

sh_2610.txt

sh_3725.txt

схема.jpg

Edited by ingfa_1981

Share this post


Link to post
Share on other sites
11 часов назад, SUrov_IBM сказал:

Главная особенность, что бы в обоих маршрутизаторах имелись DSP процессоры (платы, необходимы для оцифровки голоса E1 <=> VoIP).

Что за ересь? Голос в E1 уже оцифрован.

Share this post


Link to post
Share on other sites

Скажите, является ли использование железа, давно просящегося в музей, обязательным? Потому как можно тупо прозрачно пробросить E1 от одной АТС до другой вот такой железкой: https://www.zelax.ru/products/gateways-voip-tdmop/sfp-gateway-tdmop-mm-101/ по одной на каждой стороне. И не париться с плясками вокруг сигнализации, отдав эту прерогативу АТС. Это гораздо проще и оперативнее, чем бегать по помойкам в поисках 20 лет как не выпускавшихся модулей и перебирать прошиви 25-летней давности в поисках работоспособной конфигурации.

Share this post


Link to post
Share on other sites
29 minutes ago, taf_321 said:

Скажите, является ли использование железа, давно просящегося в музей, обязательным? Потому как можно тупо прозрачно пробросить E1 от одной АТС до другой вот такой железкой: https://www.zelax.ru/products/gateways-voip-tdmop/sfp-gateway-tdmop-mm-101/ по одной на каждой стороне. И не париться с плясками вокруг сигнализации, отдав эту прерогативу АТС. Это гораздо проще и оперативнее, чем бегать по помойкам в поисках 20 лет как не выпускавшихся модулей и перебирать прошиви 25-летней давности в поисках работоспособной конфигурации.

Да является, это железо должно проработать как минимум 2 года, по причине очень долго длящихся закупок на некоторых предприятиях. Данный вариант является палочкой выручалочкой на некоторое время.

Share this post


Link to post
Share on other sites
18 минут назад, ingfa_1981 сказал:

Да является, это железо должно проработать как минимум 2 года, по причине очень долго длящихся закупок на некоторых предприятиях. Данный вариант является палочкой выручалочкой на некоторое время.

Есть серьезные подозрения, что ничего не получится. SIP и H.323 не смогут вам обеспечить передачу требуемой сигнализации. Возможно это можно было бы сделать через IAX, но указанные железки про него не знают и уже не узнают.

Share this post


Link to post
Share on other sites
3 часа назад, taf_321 сказал:

Что за ересь? Голос в E1 уже оцифрован.

Наверно имелось ввиду транскодирование E1 <=> VoIP

Share this post


Link to post
Share on other sites
15 часов назад, taf_321 сказал:

Что за ересь? Голос в E1 уже оцифрован.

Taf_321, здравствуйте.

 

Разумеется, что поток (T1 или E1) передаёт голосовые каналы в цифре, но маршрутизаторам линейки CISCO необходимо наличие DSP процессора в «цифра - цифра» преобразовании PCM из потока в кодек G.xxx VoIP (RTP).

 

Более того, если CISCO (например линейка 28xx) просто занимается TDM Switching, между двумя потоками T1-T1 или E1-E1, ей потребуется наличие DSP процессора на момент установки вызова (потом будет чистый TDM Switching), а если это будут разные потоки T1 – E1, то DSP будет задействован для перехода PCM из одного типа потока в другой.

 

Такая у CISCO идеология, маршрутизатор не похож на АТС, в которую TS влетел, а с другой стороны вылетел в неизменном виде, если «цифра - цифра» по обоим плечам.

Edited by SUrov_IBM

Share this post


Link to post
Share on other sites
15 часов назад, ingfa_1981 сказал:
В 21.03.2019 в 00:24, SUrov_IBM сказал:

Если совсем коротко, то без специальных модулей, прозрачно пробросить E1 по IP между CISCO в Вашем случае не получится.

Спасибо за помощь. Возникает вопрос без каких именно модулей вы имели ввиду не получиться прозрачно пробросить E1 по IP ?

Ingfa_1981, здравствуйте.

 

Модули CISCO, позволяющие пробросить «чистый»  поток T1 или E1 по IP транспорту называются NM-CEM-4TE1. Они применяются в маршрутизаторах серии 28xx и не требуют наличие DSP процессора на борту маршрутизатора (в отличие от преобразования T1/E1<=> VoIP).

 

Пример - https://www.avito.ru/moskva/tovary_dlya_kompyutera/cisco_nm-cem-4te1_835129002

Share this post


Link to post
Share on other sites
В 20.03.2019 в 11:05, ingfa_1981 сказал:

(так как мультиплексор поддерживает только 1ВСК сигнализацию)

Что касается схемы [АТС]<=R1.5(E1)=>CISCO<=IP(VoIP)=>CISCO<=R1.5(E1)=>[АТС]

Извиняюсь, что сразу не обратил внимания, на тип сигнализации Ваших АТС.

 

 

К сожалению, я не встречал упоминания сигнализации CAS R1.5 на потоковых платах E1 в маршрутизаторах CISCO,

возможно в T1 что-то подобное могло быть, но не подходит для Ваших АТС.

 

На «заре» 2000 годов, для сопряжения ТфОП и CISCO использовали конвертеры R1.5(E1)<=>PRI(E1), представляющие из себя отдельные коммутаторы.

 

Возможно применить CAS R2, если АТС поддерживает подобную сигнализацию, но это будут простые голосовые вызовы на основе плана нумерации указанного в CISCO. О какой-то дополнительной служебной информации в сигнализации или DATA по канальному интервалу уже говорить не приходится.

Share this post


Link to post
Share on other sites
В 20.03.2019 в 11:05, ingfa_1981 сказал:

Проблема в том что interface Serial0/0:0 и interface Serial0/0.1 поднимается и падает.

Насколько я понимаю, interface Serial0/0:0 и Serial0/0:0.1 являются физическими модулями в маршрутизаторах

и Вы пытаетесь как-то построить с помощью них TDM коммутацию?

 

К сожалению, CISCO так не умеет. Serial интерфейс для голоса и данных в сети TDM , появляется в маршрутизаторе

CISCO только при использовании сигнализации ISDN (PRI DSS-1 или QSIG).

Share this post


Link to post
Share on other sites
11 hours ago, SUrov_IBM said:

К сожалению, CISCO так не умеет.

на 3725/2610 исходную задачу не решить.

 

Из сверхбюджетного решения: старушки Cisco МС3810 умеют делать проброс тайм-слотов (наличие DSP обязательно). Но найти 3810 уже сложно.

Из свежебюджетного (но не Cisco) - Astarta

 

Share this post


Link to post
Share on other sites

А 

4 minutes ago, AN111 said:

на 3725/2610 исходную задачу не решить.

 

Из сверхбюджетного решения: старушки Cisco МС3810 умеют делать проброс тайм-слотов (наличие DSP обязательно). Но найти 3810 уже сложно.

Из свежебюджетного (но не Cisco) - Astarta

VWIC-2MFT-g703 помогут решить проблему с прозрачным пробросом потока E1? Хотя их все равно нет

4 minutes ago, AN111 said:

 

 

Share this post


Link to post
Share on other sites
3 часа назад, ingfa_1981 сказал:

VWIC-2MFT-g703 помогут решить проблему с прозрачным пробросом потока E1? Хотя их все равно нет

С одного порта E1 в другой и никакого Ethernet'а

Share this post


Link to post
Share on other sites

Насколько я понимаю, TDMoIP на кошках сделать нельзя.

 

Share this post


Link to post
Share on other sites

Циско в настоящее время непригодное решение для TDMoIP. И сигнализация там только ISDN-PRI/BRI. Если Вам надо сделать проброс, смотрите в сторону решений от Zelax (не реклама!). Не советую поделки, типа Арлана. Столкнетесь с проблемами при наличии джиттеров. Зелаксы можно найти бюджетные б/у. Важно только соблюсти одинаковость моделей и прошивок с двух сторон, иначе работа потока окажется непредсказуемой или вообще не заработает.

Share this post


Link to post
Share on other sites
15 часов назад, AN111 сказал:

старушки Cisco МС3810 умеют делать проброс тайм-слотов (наличие DSP обязательно).

AN111, здравствуйте.


Если не сложно, можете поделиться ссылочкой на документацию или конфигурацией (если сохранилась) касательно проброса TS средствами МС3810 через IP среду?


P.S. Заранее благодарю Вас за информацию.

Share this post


Link to post
Share on other sites
On 3/23/2019 at 2:39 AM, SUrov_IBM said:

Если не сложно, можете поделиться ссылочкой на документацию или конфигурацией (если сохранилась) касательно проброса TS средствами МС3810 через IP среду?

Фича transparent Common Channel Signaling (CCS)

 На сайте циски вероятно уже затерто, нашел здесь http://doc.sumy.ua/os/cisco/ios12.0/120newft/120t/120t2/ccsfm.htm

 

Примерный конфиг во вложении.

Железо, IOS:

 -----

System image file is "flash:mc3810-a2isv5-mz.123-18a.bin"
 cisco MC3810-V3 (MPC860P) processor (revision 18.04) with 61440K/4096K bytes of memory.
 MC3810 SCB board (v01.B0)
1 Multiflex E1(slot 3) RJ11(v03.A0)
1 2-DSP(slot5) High Performance Compression Module(v01.A0)

mc3810_tccs.conf

Share this post


Link to post
Share on other sites
On 3/22/2019 at 1:55 AM, SUrov_IBM said:

Насколько я понимаю, interface Serial0/0:0 и Serial0/0:0.1 являются физическими модулями в маршрутизаторах

и Вы пытаетесь как-то построить с помощью них TDM коммутацию?

 

К сожалению, CISCO так не умеет. Serial интерфейс для голоса и данных в сети TDM , появляется в маршрутизаторе

CISCO только при использовании сигнализации ISDN (PRI DSS-1 или QSIG).

Возможно ли подсказать конфигурацию, для передачи данных, без привязки к какой либо сигнализации, на этих модулях VWIC-2MFT-E1-DI

Edited by ingfa_1981

Share this post


Link to post
Share on other sites
14 часов назад, ingfa_1981 сказал:

Возможно ли подсказать конфигурацию, для передачи данных, без привязки к какой либо сигнализации, на этих модулях VWIC-2MFT-E1-DI

 

Ingfa_1981, здравствуйте.

 

 

К сожалению, как писал выше Taf_321, модуль VWIC-2MFT-E1-DI не поможет в решении Вашей задачи.

 

Функционал данного модуля заключается в том, что бы "откусить" часть TS (канальных интервалов) от вошедшего в порт 0 потока и направить их на второй собственный порт 1, а оставшуюся часть TS отдать внутрь маршрутизатора, для последующей обработки.

Поэтому модуль VWIC-2MFT-E1-DI, может переключать TS, но в пределах самого себя (т.е. одного маршрутизатора) игнорируя сигнализацию.

 

Единственные известные мне модули в CISCO, способные передать структурированный (G.704) или не структурированный (G.703) поток через IP сеть - NM-CEM-4TE1 с обеих сторон TDMoIP.

 

Все остальные модули, по сути, являются преобразователем цифрового сигнала потока для внутренней шины маршрутизатора CISCO, а последующей обработкой сигнализации занимается IOS.

 

Проще говоря, TS в потоке вошёл в маршрутизатор и перестал быть «потоковым» в понимании телефониста, он может либо пройти TDM Switching и уйти в другой поток или быть преобразован в VoIP (где нет понятия TS) на основе информации о вызове поступившем из сигнализации. В обоих случаях IOS должна понимать, как строить вызов на основе доступной ей сигнализации CAS или CCS (в потоке T1/E1), SIP или H.323 и др.(в VoIP).

 

CISCO не мультиплексор, а маршрутизатор. Коммутация каналов может осуществиться только в пределах одного маршрутизатора (TDM Switching) при поддерживаемом типе сигнализации.

 

 

P.S. Маршрутизаторы CISCO созданы в других конструктивных реалиях и к сожалению не способны понимать системы сигнализации с декадным кодом или частотным «импульсным челноком» в потоке E1.

Edited by SUrov_IBM

Share this post


Link to post
Share on other sites

Ingfa_1981,

 

Подскажите, а что собственно проключается в указанных канальных интервалах (сигнализация CAS 1ВСК)?

 

Можно попробовать отказаться от самой схемы с потоком в случае если это голос, а ЦАТС поддерживают соединение по E&M.

И попробовать собрать схему АТС<=E&M=>CISCO<=VoIP=>CISCO<=E&M=>ЦАТС, но есть большая вероятность, что опять упрёмся в сигнализацию ЦАТС (поскольку понимание стандарта E&M у разных производителей очень расплывчатое).

Edited by SUrov_IBM

Share this post


Link to post
Share on other sites
9 hours ago, SUrov_IBM said:

Ingfa_1981,

 

Подскажите, а что собственно проключается в указанных канальных интервалах (сигнализация CAS 1ВСК)?

 

Можно попробовать отказаться от самой схемы с потоком в случае если это голос, а ЦАТС поддерживают соединение по E&M.

И попробовать собрать схему АТС<=E&M=>CISCO<=VoIP=>CISCO<=E&M=>ЦАТС, но есть большая вероятность, что опять упрёмся в сигнализацию ЦАТС (поскольку понимание стандарта E&M у разных производителей очень расплывчатое).

 

С двух сторон будет установлен http://www.selsoft.ru/2012-11-06-05-41-54/--115/-11527-27-ethernet-15-.html мультиплексор фирмы "Сельсофт" у него вход E1 выход fxo, с другой стороны вход E1 выход fxs. Так как сейчас работает релейка с 16E1, но так как  она все время глючит, решили переделать схему на гигабитный wifi который работает без сбоев. Но оборудование еще не закупили. 

Share this post


Link to post
Share on other sites
49 minutes ago, ingfa_1981 said:

С двух сторон будет установлен http://www.selsoft.ru/2012-11-06-05-41-54/--115/-11527-27-ethernet-15-.html мультиплексор фирмы "Сельсофт" у него вход E1 выход fxo, с другой стороны вход E1 выход fxs. Так как сейчас работает релейка с 16E1, но так как  она все время глючит, решили переделать схему на гигабитный wifi который работает без сбоев. Но оборудование еще не закупили. 

Тогда вам нужно решение TDMoIP.

 

Либо если у вас всё же из мукса в сторону АТС fxo/fxs, тогда нужно оборудование которое заменить мукс и переделает всё в VoIP.

Можно реализовать хоть на Cisco (но думаю будет дороже), либо на шлюзах SNR (для 16 каналов вам потребуется по 2 пары каждого fxo/fxs)

 

Share this post


Link to post
Share on other sites
12 minutes ago, Telesis said:

Тогда вам нужно решение TDMoIP.

 

Либо если у вас всё же из мукса в сторону АТС fxo/fxs, тогда нужно оборудование которое заменить мукс и переделает всё в VoIP.

Можно реализовать хоть на Cisco (но думаю будет дороже), либо на шлюзах SNR (для 16 каналов вам потребуется по 2 пары каждого fxo/fxs)

 

А шлюзы SNR могут работать друг с другом напрямую, и имеется ли в них функция выбора нужного канала, а не перебор первого свободного? Какая пара к SNR-VG-6080 c FXO портами? 

Edited by ingfa_1981

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this