Перейти к содержимому
Калькуляторы

Cisco ASR 1002 как брас с pppoe и NAT

Всем привет.

Форумчане, помогите пожалуйста с настройкой NAT для pppoe сессий.

Для теста сделал некоторые настройки, но трансляция не работает:

Вот кусок конфига:

Spoiler

ip dhcp pool Smart_ST_NAT
 network 15.16.44.0 255.255.255.0
 dns-server xx.xx.xx.xx

.

.

.

interface TenGigabitEthernet0/1/0.844  //по этому влану приходят pppoe запросы
 description test router bras
 encapsulation dot1Q 844
 ip nat inside
 pppoe enable group smart-test
 pppoe max-sessions 1000

.

.

.

.

 interface Virtual-Template1
 mtu 1492
 ip unnumbered Loopback0
 ip access-group 191 in
 ip nat outside
 peer default ip address dhcp-pool Smart_ST
 ppp authentication chap ms-chap ms-chap-v2
 ppp ipcp dns xx.xx.xx.xx

.

.

ip nat pool Smart_ST_NAT_OUT yy.yy.yy.0  yy.yy.yy.255 (диапазон белых ip )prefix-length 24
ip nat inside source list 100 pool Smart_ST_NAT_OUT overload
ip forward-protocol nd

.

.

access-list 100 permit ip 15.16.44.0 0.0.0.255 any

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

interface TenGigabitEthernet0/1/0.844 - тут nat inside не нужен....

interface Virtual-Template1 - тут нужен nat inside, а не outside

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
13 minutes ago, StSphinx said:

interface TenGigabitEthernet0/1/0.844 - тут nat inside не нужен....

interface Virtual-Template1 - тут нужен nat inside, а не outside

Спасибо.

А куда вешать outside?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, Phantom Lord сказал:

Спасибо.

А куда вешать outside?

На туда, где у вас public IP в который вы будете транслировать private IP.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 minute ago, StSphinx said:

На туда, где у вас public IP в который вы будете транслировать private IP.

У меня 2 шт cisco asr 1002

на первой BGP, вторая (на которой делаем тест nat ) имеет дефолт рут на первую

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 минуту назад, Phantom Lord сказал:

У меня 2 шт cisco asr 1002

на первой BGP, вторая (на которой делаем тест nat ) имеет дефолт рут на первую

 

Какое отношение все это имеет к настройкам NAT трансляций?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 minute ago, StSphinx said:

Какое отношение все это имеет к настройкам NAT трансляций?

К вопросу о outside

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 минуту назад, Phantom Lord сказал:

К вопросу о outside

На коробке, где вы настраиваете NAT трансляции, должен быть интерфейс с public IP. 

Если у вас NAT будет на другой коробке, вот там и настраивайте. Вообще, каша у вас какая-то в голове, простите.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 hour ago, StSphinx said:

На коробке, где вы настраиваете NAT трансляции, должен быть интерфейс с public IP. 

Если у вас NAT будет на другой коробке, вот там и настраивайте. Вообще, каша у вас какая-то в голове, простите.

Благодарю. Все заработало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
19 часов назад, StSphinx сказал:

На коробке, где вы настраиваете NAT трансляции, должен быть интерфейс с public IP. 

Если у вас NAT будет на другой коробке, вот там и настраивайте. Вообще, каша у вас какая-то в голове, простите.

Не должен но в принципе верно, должен быть интерфейс откуда пакетики улетают после трансляции.... посмотреть sh ip ro 0.0.0.0.0 например, и туда вешать аутсайд

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
3 часа назад, myst сказал:

Не должен но в принципе верно, должен быть интерфейс откуда пакетики улетают после трансляции.... посмотреть sh ip ro 0.0.0.0.0 например, и туда вешать аутсайд

 

Согласен, ошибся. Давно дело с NAT на Cisco дел не имел.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите, а что за записи в таблице НАТ-трансляций с 0м портом:

c7204_core#sh ip nat tr | i 172.21.43.1:
gre 188.130.171.34:0      172.21.43.1:0         91.208.134.75:0       91.208.134.75:0
...

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас