Jump to content
Калькуляторы

VLAN средствами Switchchip в CRS 109

Доброго времени суток форумчане. 

Возник вопрос по релизации VLAN по средствам switchchip.

Задача следующая

ether1 смотри на провайдера и подымается PPPoE

ether3 VLAN 200 в режиме access

ether4 VLAN 222 в режиме access

ether5-ether8 и sfp1 это trunk порты в которые будут воткнуты коммутаторы которые дальше уходят по сети и куда нужно догнать VLAN 200 и 222

Изучив форум и маны получился следуюзий конфиг.

/interface bridge
add name=bridge1 protocol-mode=none
/interface vlan
add interface=bridge1 name=VLAN200_LAN vlan-id=200
add interface=bridge1 name=VLAN222_VIDEO vlan-id=222
/interface ethernet switch
set forward-unknown-vlan=no
/interface bridge port
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=sfp1
/interface ethernet switch egress-vlan-translation
add new-customer-vid=0 ports=ether3,ether4
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=200 ports=ether3
add new-customer-vid=222 ports=ether4
/interface ethernet switch vlan
add ports=ether5,ether6,ether7,ether8,sfp1,ether3,switch1-cpu vlan-id=200
add ports=ether5,ether6,ether7,ether8,sfp1,ether4,switch1-cpu vlan-id=222
/ip address
add address=192.168.200.1/24 interface=VLAN200_LAN network=192.168.200.0
add address=192.168.222.1/24 interface=VLAN222_VIDEO network=192.168.222.0

 

Верно ли решение? смущает только то, что при запуске данного конфига... вылетает из winbox после команды "/interface ethernet switch set forward-unknown-vlan=no" и её приходиться вбивать в самом конце.

Share this post


Link to post
Share on other sites
5 hours ago, BAHbKA said:

вылетает из winbox после команды "/interface ethernet switch set forward-unknown-vlan=no" и её приходиться вбивать в самом конце.

Так вроде логично, что сначала надо известные вланы прописать, а потом неизвестные запретить ?

 

В wiki пример для CRS видели ? Там пишут, что надо все транковые порты в egress прописать, а аксесс порты не надо,

достаточно в ingress.

 

Edited by McSea

Share this post


Link to post
Share on other sites
8 часов назад, McSea сказал:

В wiki пример для CRS видели ?

 

 

Там слишком сложно

 

 

8 часов назад, McSea сказал:

Там пишут, что надо все транковые порты в egress прописать, а аксесс порты не надо,

достаточно в ingress.

 

 

т.е. вот это

/interface ethernet switch egress-vlan-translation
add new-customer-vid=0 ports=ether3,ether4

 

лишнее?

Share this post


Link to post
Share on other sites

Всё бы хорошо, но как назначить IP адрес на такой VLAN через свитччип? и DHCP сервер?

Edited by BAHbKA

Share this post


Link to post
Share on other sites
21 hours ago, BAHbKA said:

Всё бы хорошо, но как назначить IP адрес на такой VLAN через свитччип? и DHCP сервер?

 

У вас это сделано в конфиге из первого поста.  Возможно еще тегирование на switch1-cpu надо делать, у меня под рукой свитчей нет проверить (на роутерах явно тегирование/растегирование не делается, просто vlan-ы и порты прописываются).

Share this post


Link to post
Share on other sites
8 часов назад, McSea сказал:

У вас это сделано в конфиге из первого поста.  Возможно еще тегирование на switch1-cpu надо делать, у меня под рукой свитчей нет проверить (на роутерах явно тегирование/растегирование не делается, просто vlan-ы и порты прописываются).

 

Это полечил, работает.

 

А теперь клиенты wi-fi сети которые через CAPSMan адреса не получают... а вот если клиент подключается к точке которая выполняет функции CAPSMan то всё работает. т.е. на удалённые точки в CAPS Не прилетает DHCP 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this