Jump to content
Калькуляторы

RBGroove не принимает настройки по DHCP

Ищу альтернативу Ubiquiti PicoStation M2HP — нужна недорогая, хорошая и компактная уличная точка доступа с omni-антенной.

Пока не нашел, но взял на пробу пару RBGrooveGA-52HPacn с антенной.

Вчера этот джедайский меч приехал.

По дефолту eth1 и wlan1 объединены в мост, я обнулил конфигурацию и настроил клиентское wifi-подключение.

Беспроводное подключение устанавливается, однако IP-адрес устройство не получает.

Если вручную задать IP-адрес на интерфейсе wlan1, то трафик ходит.

Если IP-адрес убрать и включить DHCP, то ничего не происходит, у DHCP Client статус waiting, в логах пусто.

Share this post


Link to post
Share on other sites

Напишите более подробно что  как настраиваете, вы интернет по кабелю получаете, или через радиоинтерфейс?

Share this post


Link to post
Share on other sites

Куда уж подробнее.

Устройство подключается к офисной беспроводной сети - чтобы обновить и настроить.

Но не принимает настройки по DHCP.

Share this post


Link to post
Share on other sites

Что-то тоже было подобное, цеплялся клиентом к сети "прозрачным мостом", не получает адрес т устройства за ним не получают, настроил в режиме роутера, адрес получает сам через dhcp раздаёт.

Share this post


Link to post
Share on other sites

Так у меня не мост и раздавать не надо.

Мне нужно, чтобы сам Groove подключился и получил адрес.

Share this post


Link to post
Share on other sites
7 часов назад, alibek сказал:

Мне нужно, чтобы сам Groove подключился и получил адрес.

а dhcp-client там настроен????

Share this post


Link to post
Share on other sites

Ну так беспроводной интерфейс же не активен, когда соединения по радио нет.

 

Нужно создать бридж, в него добавить wlan адаптер. На бридж повесить DHCP Client, все будет работать.

Share this post


Link to post
Share on other sites
1 час назад, Saab95 сказал:

Ну так беспроводной интерфейс же не активен, когда соединения по радио нет.

Это к чему? Какое это имеет отношение к моей ситуации?

У меня соединение по радио есть.

 

1 час назад, Saab95 сказал:

Нужно создать бридж, в него добавить wlan адаптер. На бридж повесить DHCP Client, все будет работать.

Оригинально, mikrotik-way.

Почему-то несколько десятков устройств WISP умеют, а Микротику нужно в псевдобридж оборачивать.

Какая-то нездоровая фиксация на обертках и туннелях.

Share this post


Link to post
Share on other sites

Если у вас DHCP Client на беспроводном интерфейсе, то когда соединения нет - он не активен.

Если у вас DHCP Client на беспроводном интерфейсе, то когда соединение обрывается, то IP адрес на устройстве пропадает. Что вызывает обрыв всех открытых соединений.

 

Если DHCP Client создан на бридже, то при обрыве и быстром повторном подключении к сети, соединения не обрываются.

 

Сейчас взял микротик, такой же как у вас, настроил DHCP клиента на wlan, и он прекрасно получает IP адрес, настроил на бридже - так же все прекрасно получает. Почему у вас он не получает? Может дело вовсе не в микротике?

Share this post


Link to post
Share on other sites
25 минут назад, Saab95 сказал:

Может дело вовсе не в микротике?

В чем, например?

Share this post


Link to post
Share on other sites

Вы когда устройство сбросили, отменили начальную конфигурацию? Там, по умолчанию, сетевой порт работает в связке с мастер портом wlan. И если в таких условиях повесить DHCP Client работать как раз и не будет.

 

Что бы заработало нужно сделать следующее:

 

1. Сбросить устройство, отменив начальную конфигурацию, а лучше написать в консоли system reset-configuration no-defaults=yes, т.к. после отмены на кнопку R иногда отменяются не все настройки.

2. Создать бридж, в него добавить адаптер wlan.

3. На бридж повесить DHCP Client.

 

Далее при подключении к беспроводной сети устройство получит адрес.

Share this post


Link to post
Share on other sites
3 минуты назад, Saab95 сказал:

Вы когда устройство сбросили, отменили начальную конфигурацию?

Смешно, да.

А если попробовать перечитать мой начальный текст?

Повторю еще раз, по слогам.

 

На устройстве делался сброс на пустую конфигурацию, не дефолтную.

После чего на wlan1 настраивалось подключение радио (подключилось успешно) и затем к нему добавлялся dhcp-клиент (неуспешно).

При этом если на wlan1 прописать IP-адреса статикой, то все работает, трафик ходит.

Таким образом я обновил ПО, но и на последней версии поведение такое же.

При этом таким образом я настраивал уже не один десяток устройств, описанная проблема только с Микротиком.

 

7 минут назад, Saab95 сказал:

а лучше написать в консоли system reset-configuration no-defaults=yes, т.к. после отмены на кнопку R иногда отменяются не все настройки.

А три раза оббежать вокруг устройства и пропеть «кукареку» в направлении солнца не надо?

Ну мало ли, вдруг без этого иногда не работает dhcp-клиент.

Share this post


Link to post
Share on other sites

Тогда смотрите логи микротика по DHCP, что там происходит и на что он ругается.

Share this post


Link to post
Share on other sites

В логах никакой активности.

Более того, даже если в Firewall добавить правило без условий и с действием log (то есть логгировать все пакеты), то в логах на input периодически приходят igmp и широковещательные запросы, а на output ничего (то есть Микротик не отправляет широковещательные запросы на получение IP-адреса).

Share this post


Link to post
Share on other sites
В ‎03‎.‎02‎.‎2019 в 21:17, Saab95 сказал:

Нужно создать бридж, в него добавить wlan адаптер. На бридж повесить DHCP Client, все будет работать.

Кстати, забыл написать.

Не работает.

Висит в статусе searching (не waiting) без каких-либо изменений.

 

Share this post


Link to post
Share on other sites
3 минуты назад, alibek сказал:

Кстати, забыл написать.

Не работает.

Висит в статусе searching (не waiting) без каких-либо изменений.

В mode у вас что выбрано?

Share this post


Link to post
Share on other sites

Где именно mode?

В wlan1 выбран протокол 802.11, полоса 2G-b/g.

По WiFi соединение устанавливается и если на интерфейсе задать IP-адреса вручную, то трафик ходит.

 

Чудное устройство.

 

В очередной раз сделал полный сброс.

Настроил подключение на wlan1.

В ip - firewall - filter добавил действие log в цепочку output (то есть логгировать все исходящие запросы).

Включаю dhcp-клиент на wlan1 - в логах пусто. То есть даже DHCPDISCOVER не уходит.

Удаляю dhcp-клиент, добавляю на интерфейс IP-адрес (статикой). Пингую шлюз — пингуется, в логах вижу исходящие icmp-пакеты.

Удаляю IP-адрес, снова добавляю DHCP-клиент — в логах тишина.

 

Может быть для DHCP-клиента нужна отдельная лицензия? На точке правда Level 4, но вдруг.

Share this post


Link to post
Share on other sites
9 минут назад, alibek сказал:

Где именно mode?

В wlan1 выбран протокол 802.11, полоса 2G-b/g.

По WiFi соединение устанавливается и если на интерфейсе задать IP-адреса вручную, то трафик ходит.

Там где выбирается ap bridge, station, etc.

Share this post


Link to post
Share on other sites

А, station. Настройки скопировал из Scan - Connect.

Пробовал station wds и station bridge — то же самое.

Share this post


Link to post
Share on other sites
4 минуты назад, alibek сказал:

А, station. Настройки скопировал из Scan - Connect.

Пробовал station wds и station bridge — то же самое.

Пробуйте все режимы, у микротик свои причуды. :) Я точно не помню, давно было, но подобная вашей конфигурация заработала только со стэйшен псевдобридж.

Share this post


Link to post
Share on other sites

Пробую, где-то линк по радио не устанавливается, где-то устанавливается, но DHCP не работает.

Но вообще я считал, что если IP-трафик ходит (при назначении IP статикой), то и нижележащий транспорт работает.

 

Сейчас уже от безысходности попробовал Quick Set, что в режиме CPE, что в режиме WISP.

IP-адреса по DHCP не назначаются.

И дело не в беспроводной сети, к которой я подключаюсь — во-первых это не первое устройство, а во-вторых микротик вообще не отправляет исходящие широковещательные пакеты.

Share this post


Link to post
Share on other sites

Перепробовал все.

station wds и station bridge — линк по радио не устанавливается.

station и station pseudobridge — линк по радио устанавливается, DHCP-клиент не работает, IP статикой работает.

DHCP-клиент пробовал задавать как на wlan1, так и на bridge1 — глухо, Микротик даже не пытается запросить IP-адреса (ни discover, ни request).

 

Если wlan1 и ether1 объединить в мост и ether1 включить в другое устройство (то есть использовать RBGroove как беспроводной адаптер), то по прежнему ничего не работает.

Я подключал его в RB3011, настраивал логгирование исходящих пакетов.

По логам вижу, что широковещательные запросы уходят наружу, но ответов не поступает.

Видимо в RBGroove ненастоящий мост и он DHCP блокирует.

 

Если на RB3011 задать IP-адреса статикой, то связь работает — то есть статика через мост на RBGroove проходит.

Share this post


Link to post
Share on other sites

В разделе System в меню Logging нужно нажать +, выбрать Topics - DHCP и Ok. После чего в логи начнет попадать расширенный дебаг запросов. Там и смотрите что приходит.

Можно сниффером посмотреть, какие данные приходят, и какие ответы на них идут.

 

Микротик к какому оборудованию по радио подключается? Уже, наверное, пробовали, подключать его к другому микротику в качестве точки доступа?

 

39 минут назад, alibek сказал:

Если wlan1 и ether1 объединить в мост и ether1 включить в другое устройство (то есть использовать RBGroove как беспроводной адаптер), то по прежнему ничего не работает. 

А подключить кабелем к точке доступа, раздающей адреса, не пробовали?

Share this post


Link to post
Share on other sites
20 минут назад, Saab95 сказал:

Уже, наверное, пробовали, подключать его к другому микротику в качестве точки доступа?

Зачем? Мне нужно подключиться к офисной беспроводной сети, чтобы обновить ПО и подключиться удаленно с рабочего ПК.

21 минуту назад, Saab95 сказал:

А подключить кабелем к точке доступа, раздающей адреса, не пробовали?

Зачем? Мне нужно подключиться к офисной беспроводной сети, чтобы обновить ПО и подключиться удаленно с рабочего ПК.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this