Jump to content
Калькуляторы

Некорректно работает prerouting через ВПН для списка адресов

Настроил правило чтобы на определенные адреса из списка трафик шел через ВПН, делал как в данном руководстве описано
https://alexell.ru/blog/windows-internet/mikrotik-obhod-blokirovki-telegram.html#comment-1133
У меня почему-то работает криво, такое ощущение что на список адресов идет сначала без ВПН а потом через ВПН. Объясню чтобы было понятно, я даже заново сконфигурировал роутер и отключил вообще все правила фаервола:
в роутлист есть маршрут с routing mark OverVPN. В mangle создано правило для Src. Address как описано в статье. Когда я убираю из Advanced Dst.Address List список rkn то весь трафик идет через VPN и все заблокированные сайты открываются, но когда я указываю там список, заблокированные сайты не открываются (выдает данный сайт заблокирован как без ВПН) для интереса я добавил в список сайт проверки ип адреса, когда захожу на него показывает что я зашел через ВПН. 
Почему без списка все работает корректно, трафик идет через ВПН, а со списком как будто сначала прогоняется без ВПН и только потом через ВПН?

Share this post


Link to post
Share on other sites

Конфиг http://bit.ly/2Ry54i7 (routing mark OverVPN прописана в pptp-out1), все правила фаервола отключены.

Вдобавок пробовал добавить такие правила, аналогичная ситуация,сайт блокируется провайдером, другие сайты перенаправляет.
/ip dns static add address=195.82.146.214 name=rutracker.org ttl=0s
/ip route add distance=1 dst-address=195.82.146.214 gateway=pptp-out1

Share this post


Link to post
Share on other sites

Я не стал читать данный мануал по ссылке, но вангую для того чтобы не было " идет сначала без ВПН а потом через ВПН " должно быть прописано два маршрута

- один с роутинг марком

- второй такой же только без роутинг марка, но с дистанс больше чем на основном канале интернет

/ip route
add distance=1 gateway=pptp-out1 routing-mark=block
add distance=4 gateway=pptp-out1

 

Маршрут через интернет канал у меня имеет дистанс 1

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this