Перейти к содержимому
Калькуляторы

Настройка Multicast, pim-sm

Добрый день, коллеги. 

От провайдера получаем по L2  два влана с мультикастом. Эти вланы необходимо зарулить на телевизионную станцию, которая в свою очередь будет преобразовывать мультик в аналог и вещать на простые телевизоры. Проблема в том, что на станцию нельзя зарулить два влана в транке, она понимает только один влан без тэга. То есть если мы подключаем станцию в access порт,  то  станция это понимает и спокойно работает - преобразовывает мультик в аналог, все ок. Если подключаем в trunk порт (с двумя вланами), то уже не работает. В общем станция понимает только один влан и без тэга, такие у нее особенности.   Следовательно, нужно преобразовать два влана в один. и пустить его на станцию.

Два влана, которые дает провайдер: vlan 2, vlan 3, адресации в них нет, просто мультикаст.

 

Оборудование: провайдер (0) что у него не знаю --- > мы (1) eltex MES3116 ---> (2) cisco 3750 ---> станция.

 

Вроде бы можно такое провернуть с помощью протокола PIM, но сколько ни бьюсь, не могу сообразить как. 

Нужна ваша помощь, может кто-то с таким уже сталкивался?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Такое совершенно точно можно сделать с помощью петли из патчкорда.

Лишь бы такой же петли не было у вашего провайдера, иначе закольцуется.

Или теги менять на входе от провайдера. Вариантов можно много придумать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
31 минуту назад, TheUser сказал:

Такое совершенно точно можно сделать с помощью петли из патчкорда.

Лишь бы такой же петли не было у вашего провайдера, иначе закольцуется.

Или теги менять на входе от провайдера. Вариантов можно много придумать.

Спасибо за ответ!

Тэги менять -  вы имеете ввиду q-n-q? 

Петля из патч-корда это как?

Какие еще варианты можно придумать, поделитесь, пожалуйста

Изменено пользователем Korj-admin

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вообще это делается именно через маршрутизацию. Покажите что вы настроили для работы pim. Поищем ошибку. Наверное, не указаны rp.

В качестве схемы через жопу, можно попробовать поискать инфу по слову MVR или ISM. Вполне возможно, что ваш элтекс умеет брать из двух вланов и класть в третий.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 часа назад, Korj-admin сказал:

Вроде бы можно такое провернуть с помощью протокола PIM, но сколько ни бьюсь, не могу сообразить как. 

Нахер пим, просто: http://netlab.dhis.org/wiki/ru:software:freebsd:igmpproxy_on_netgraph

вместо одного ван сделаешь два.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
14 часов назад, vurd сказал:

Вообще это делается именно через маршрутизацию. Покажите что вы настроили для работы pim. Поищем ошибку. Наверное, не указаны rp.

В качестве схемы через жопу, можно попробовать поискать инфу по слову MVR или ISM. Вполне возможно, что ваш элтекс умеет брать из двух вланов и класть в третий.

 

У нас есть еще один мультикаст от ростелекома, тоже по протоколу pim, но там все гораздо понятней было, ростелеком сам дал rp, мы прописали до нее маршруты и указали на интерфейсах ip pim sparse mode.

Здесь же нам дают два влана  и как действовать тут, не понимаю. Наш элтекс pim не умеет, на нем лишь прописала прием двух вланов и отдачу их вниз в транке. На циске вот все касательно мультикаста. Но конфиг какой-то нелогичный получается, а как правильно, не знаю.

 

ip routing
!
!
ip multicast-routing distributed

!

vlan 2
!
vlan 3

!

vlan 666
 name TV
!
interface Loopback6
 ip address 6.6.6.6 255.255.255.255
!

interface GigabitEthernet1/0/1
 description --up to eltex--
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,3
 switchport mode trunk
!

interface GigabitEthernet1/0/2
 description --down to tv-station--
 switchport access vlan 666
 switchport mode access
!

interface Vlan666
 no ip address
 ip pim passive

!

ip pim rp-address 6.6.6.6 99
!
access-list 99 permit 239.2.7.0 0.0.0.255
!
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

int vlan 2

 ip address

 ip pim sparse

!

int vlan 3

 ip address

 ip pim sparse

!

ip (m)route TO_SOURCES_IN_VLAN_2 

ip (m)route TO_SOURCES_IN_VLAN_3

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
12 минут назад, vurd сказал:

int vlan 2

 ip address

 ip pim sparse

в interface vlan у меня можно прописать только ip pim passive, другой команды нет.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тут есть несколько вариантов.

 

Как уже предлагали - перемычки, я бы именно так сделал как самое простое.

 

Второе MVR. Тоже штука простая но не знаю есть ли MVR на указанном железе.

 

PIM. С PIM нужно учесть вот что:

В качестве RP можно указать свой же девайс.

Кроме того, обязательно нужно учесть работу RPF-check. Поток будет маршрутизироваться ТОЛЬКО если маршрутизатор имеет маршрут до IP источника мультикаст группы.

Самое простое тут - навесить на  vlan 2, vlan 3 ip адрес из подсетки, из которой раздаются потоки. Если же подсеток много, то до каждой придётся маршрут прописывать.

 

В общем если не лень с пимом возиться то вперед, а с перемычками просто и железно, никаких SRC IP и маршрутов.

 

Даже могу скинуть ссылку на свои же рукописи, по которым запустил стримы с кучей операторов)

https://kb.msk-ix.ru/ix/faq/#tv_faq

Там общие моменты но смысл тот же.

 

 

 

 

 

 

 

 

 

Изменено пользователем 704114

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот так примерно рабочий конфиг выглядит.


ip routing
!
ip multicast-routing distributed
!
interface Loopback6
 ip address 6.6.6.6 255.255.255.255
!
 interface GigabitEthernet1/0/1
 description --up to eltex--
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,3
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 description --down to tv-station--
 switchport access vlan 666
 switchport mode access
!
interface Vlan2
 ip address 10.2.0.1/24
 ip pim sparse-mode
!
interface Vlan3
 ip address 10.3.0.1/24
 ip pim sparse-mode
!
interface Vlan666
 ip address 10.4.0.1/24
 ip pim sparse-mode

! xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy - подсеть с мультикастами
ip mroute xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy static 10.2.0.1
ip mroute xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy static 10.3.0.1
!и т д
!либо ip mroute вообще не нужно если на vlan2 и vlan3 навесить ip из подсети с источниками мультикастов
!
ip pim rp-address 6.6.6.6 99
!
access-list 99 permit 239.2.7.0 0.0.0.255
!и другие диапазоны групп если имеются
!

и на eltex на всякий случай igmp snooping выключить во vlan2 и vlan3.
И еще нужно убедиться, что оператор подает потоки во vlan2 и vlan3 постоянно. Без необходимости отсылки joins к нему.
Если joins всё же требуются то еще строчек подскажу.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

!либо ip mroute вообще не нужно если на vlan2 и vlan3 навесить ip из подсети с источниками мультикастов
Ну если там плоская сеть, то да. иначе нужен маршрут. В целом так наверное даже лучше написано, т.к. адрес фейковый и роут в интерфейс по сути.

 

10 часов назад, Korj-admin сказал:

в interface vlan у меня можно прописать только ip pim passive, другой команды нет.

 

Пим пассив должен быть в сторону клиентов. А в сторону апстримов или просто ip pim, или ip pim sparse-mode. Не знаю как на элтексе, наверное первое.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
18 часов назад, vurd сказал:

!либо ip mroute вообще не нужно если на vlan2 и vlan3 навесить ip из подсети с источниками мультикастов
Ну если там плоская сеть, то да. иначе нужен маршрут. В целом так наверное даже лучше написано, т.к. адрес фейковый и роут в интерфейс по сути.

 

Пим пассив должен быть в сторону клиентов. А в сторону апстримов или просто ip pim, или ip pim sparse-mode. Не знаю как на элтексе, наверное первое.

В interface vlan  мне можно написать только p pim passive, ни ip pim, ни ip pim sparse-mode написать нельзя, попросту нет команды. Вот просто на интерфейс порта  можно, но в интерфейс влан нет. Поэтому и не получается, нужно как-то по-другому, а как не пойму.

 

В 22.11.2018 в 16:03, 704114 сказал:

Вот так примерно рабочий конфиг выглядит.


ip routing
!
ip multicast-routing distributed
!
interface Loopback6
 ip address 6.6.6.6 255.255.255.255
!
 interface GigabitEthernet1/0/1
 description --up to eltex--
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,3
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 description --down to tv-station--
 switchport access vlan 666
 switchport mode access
!
interface Vlan2
 ip address 10.2.0.1/24
 ip pim sparse-mode
!
interface Vlan3
 ip address 10.3.0.1/24
 ip pim sparse-mode
!
interface Vlan666
 ip address 10.4.0.1/24
 ip pim sparse-mode

! xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy - подсеть с мультикастами
ip mroute xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy static 10.2.0.1
ip mroute xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy static 10.3.0.1
!и т д
!либо ip mroute вообще не нужно если на vlan2 и vlan3 навесить ip из подсети с источниками мультикастов
!
ip pim rp-address 6.6.6.6 99
!
access-list 99 permit 239.2.7.0 0.0.0.255
!и другие диапазоны групп если имеются
!

и на eltex на всякий случай igmp snooping выключить во vlan2 и vlan3.
И еще нужно убедиться, что оператор подает потоки во vlan2 и vlan3 постоянно. Без необходимости отсылки joins к нему.
Если joins всё же требуются то еще строчек подскажу.

 

 

спасибо за ответ! к сожалению, команда

 interface Vlan2
 ip pim sparse-mode 

не проходит, не принимается   ip pim sparse-mode , можно только ip pim passive.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Cisco(config-if)#ip pim ?
  bidir-neighbor-filter  PIM bidir capable peering filter
  bsr-border             Border of PIM domain
  dense-mode             Enable PIM dense-mode operation
  dr-priority            PIM router DR priority
  nbma-mode              Use Non-Broadcast Multi-Access (NBMA) mode on interface
  neighbor-filter        PIM peering filter
  passive                Enable PIM passive interface operation
  query-interval         PIM router query interval
  sparse-dense-mode      Enable PIM sparse-dense-mode operation
  sparse-mode            Enable PIM sparse-mode operation
  state-refresh          PIM DM State-Refresh configuration
  version                PIM version

Должен быть sparse-mode. Что за прошивка на кошке?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 03.12.2018 в 14:59, passer сказал:

Cisco(config-if)#ip pim ?
  bidir-neighbor-filter  PIM bidir capable peering filter
  bsr-border             Border of PIM domain
  dense-mode             Enable PIM dense-mode operation
  dr-priority            PIM router DR priority
  nbma-mode              Use Non-Broadcast Multi-Access (NBMA) mode on interface
  neighbor-filter        PIM peering filter
  passive                Enable PIM passive interface operation
  query-interval         PIM router query interval
  sparse-dense-mode      Enable PIM sparse-dense-mode operation
  sparse-mode            Enable PIM sparse-mode operation
  state-refresh          PIM DM State-Refresh configuration
  version                PIM version

Должен быть sparse-mode. Что за прошивка на кошке?

Version 12.2(53r)SE2

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тогда какая лицензия? По-моему, там 15-ый ios с RTU лицензией

P.s. Больше подробностей, больше! :-)

Изменено пользователем passer

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас