Jump to content
Калькуляторы

Cisco + Dlink

Была ли у кого-то положительная практика поднятия LACP между cisco'й и dlink'ом?

Собственно затык в чем, при поднятии LACP скорость портов не суммируется...

Share this post


Link to post
Share on other sites

@feeman Если выросли выше 1 гб\с пора думать о 10G портах. Сухая правда. 

 

Share this post


Link to post
Share on other sites
25 минут назад, feeman сказал:

LACP скорость портов не суммируется

Так и не должна вроде суммироваться :)

Надо играть с типом балансировки в настройках агрегированного порта.

 

Share this post


Link to post
Share on other sites
8 минут назад, pingz сказал:

@feeman Если выросли выше 1 гб\с пора думать о 10G портах. Сухая правда. 

 

Если метод балансировки выбран верно - то нагрузка +- поделится по портам.

Ровно 2 гига конечно вряд ли удастся вытянуть но в около 2 вполне

Share this post


Link to post
Share on other sites
41 минуту назад, feeman сказал:

Была ли у кого-то положительная практика поднятия LACP между cisco'й и dlink'ом?

Собственно затык в чем, при поднятии LACP скорость портов не суммируется...

метод балансировки смотрите, куча таких схем, всё работает как надо

 

21 минуту назад, pingz сказал:

@feeman Если выросли выше 1 гб\с пора думать о 10G портах. Сухая правда. 

 

не согласен. Заодно подумайте о пакетном буфере и потом посмотрите какой он у дешевых свичей.

Share this post


Link to post
Share on other sites
55 минут назад, feeman сказал:

Была ли у кого-то положительная практика поднятия LACP между cisco'й и dlink'ом?

Собственно затык в чем, при поднятии LACP скорость портов не суммируется...

была... не вижу никаких проблем. Обычный LACP с балансировкой по источнику\назначению. Подробности не помню, ибо давно это было. Но точно помню, что никаких особенностей не было.

Делал все по инструкции с длинкру

Share this post


Link to post
Share on other sites

Более года работает канал между D-Link DGS-3100 и Redback SE100, проблем с настройкой и балансировкой не было, суммарно в пиках упирается в потолок 1950 Mbps In / 570 Mbps Out.

 

На D-Link конфигурация:

! LINK AGGREGATION
create link_aggregation group_id 1 type lacp
config link_aggregation group_id 1 ports 1:(23-24)

 

на SE100 (не совсем cisco)

link-group LANlag-ethernet ether
 lacp active
 lacp periodic-timeout long
 bind interface ENet-LANLag local
!

port ethernet 2/3
 description ** LAN LAG Link #1
 no shutdown
 link-group LANlag-ethernet
!
port ethernet 2/4
 description ** LAN LAG Link #2
 no shutdown
 link-group LANlag-ethernet

 

т.е. ничего хитрого. Возможно Firmware на D-Link нужно обновить.

 

Share this post


Link to post
Share on other sites
59 минут назад, Желающий сказал:

была... не вижу никаких проблем.

Повезло.

 

Немного поясню. Ситуация немного усложняется, в связи с тем, что две железки админят разные люди, + еще эти железки от разных ведноров.

Моя зона ответственности это циска, в связи с этим остается надеяться что dlink настроен корректно.

 

Возвращаясь к вопросу:

Мож я конечно что-то упустил на циске?

interface Port-channel1
 switchport access vlan 717
 switchport mode access

!

interface GigabitEthernet1/0/1
 switchport access vlan 717
 switchport mode access
  channel-protocol lacp
 channel-group 1 mode passive
!
interface GigabitEthernet1/0/2
 switchport access vlan 717
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode passive

 

+ port-channel load-balance src-dst-mac

Share this post


Link to post
Share on other sites

а на порту есть эти самые разные MAK? Если и там и там один хост, то и балансировать будет нечего

Share this post


Link to post
Share on other sites

Коллега, если по этому линку обмениваются траффиком всего два физических хоста на 2 уровне, то грузится будет только один интерфейс, так как всего два мака. Это для примера.

Share this post


Link to post
Share on other sites
2 часа назад, feeman сказал:

Была ли у кого-то положительная практика поднятия LACP между cisco'й и dlink'ом?

Собственно затык в чем, при поднятии LACP скорость портов не суммируется...

Года два работает 4948+3426 каши не просит:
 

Сиська

port-channel load-balance src-dst-ip
!
interface Port-channel1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 30
 switchport mode trunk
!
interface GigabitEthernet1/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 30
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 30
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 30
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/4
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 30
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!

Длинк:
 

config link_aggregation algorithm ip_source_dest
create link_aggregation group_id 1 type lacp
config link_aggregation group_id 1 master_port 21 ports 21-24 state enable
config lacp_port 1-27 mode passive

Как правильно тут заметили, важен алгоритм, если у вас л2 соот-но по макам, если л3 - по ip

Share this post


Link to post
Share on other sites
15 минут назад, pppoetest сказал:

если л2 - по ip

может имелось в виду л3 ?

Share this post


Link to post
Share on other sites
1 час назад, pppoetest сказал:

Как правильно тут заметили, важен алгоритм

у меня получается следующая схема:

 

| ядро ASR 1000 => коммутатор dlink 3526 |  =>  | Cisco 2960G => Cisco 2960G => Cisco 7201 |

         зона ответственности оператора                              моя зона ответственности

Edited by feeman

Share this post


Link to post
Share on other sites
51 минуту назад, feeman сказал:

Мож я конечно что-то упустил на циске?


interface Port-channel1
 switchport access vlan 717
 switchport mode access

!

interface GigabitEthernet1/0/1
 switchport access vlan 717
 switchport mode access
  channel-protocol lacp
 channel-group 1 mode passive
!
interface GigabitEthernet1/0/2
 switchport access vlan 717
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode passive

 

+ port-channel load-balance src-dst-mac

channel-group 1 mode active

Share this post


Link to post
Share on other sites
1 час назад, ShyLion сказал:

а ASR с длинком и каталист с 7201 как соединены?

как соединены ASR c dlink'ом я не знаю, т.к. админ не особо охотно распространяется на эти темы.

 

длинк с каталистом соединены витой парой, по обоим сторонам порты access'ные. С моей стороны vlan 717, c другой стороны я х.з. какой влан.

каталист1 2960 соединен с каталистом2 2960 по волокну,

на каталист1 настроен на портах GI1/0/1 и GI1/0/2  LACP, далее на каталист1 через trank'овый порт GI1/0/52 все это дело улетает на каталист2.

на каталист2 на порту GI1/0/1 поднят access'ый порт с 717 вланом, который отдается уже маршрутизатору 7201.

 

Edited by feeman

Share this post


Link to post
Share on other sites

Если не знаете в каком режиме настроен lacp у соседа - включаете mode active обязательно.

Share this post


Link to post
Share on other sites

График с портов покажите уже. Баланисровка в какую сторону не работает?

Почти всегда предпочтительно ставить L3+src-dest. В 99% это обеспечивает отличное распределение. src-dest-mac это только на большом транзите l2 включать можно.

Share this post


Link to post
Share on other sites
11 минут назад, vurd сказал:

График с портов покажите уже

На ум приходит разные show-комманды.

Можете уточнить какой вывод команды показать?

Edited by feeman

Share this post


Link to post
Share on other sites
Только что, feeman сказал:

На ум приходит разные show-комманды.

Можете уточнить какую вывод команды показать?

График. График покажите. Как вы определили, что больше гигабита не получается? Из анализа загрузки канала же?

 

5bec2f43417b5_post-40635-0494471001394309798.thumb.png.1b197421719c55b5c665dfd5812d2d46.png

 

 

Share this post


Link to post
Share on other sites
Только что, vurd сказал:

Как вы определили, что больше гигабита не получается?

Да у меня еще смешнее ситуация. Скорость порта должна быть ~200 Мбит.

Из-за того, что у выше стоящего dlink 3526 с сотошными портами, пришлось городить LACP.

 

 

 

 

3 минуты назад, vurd сказал:

График покажите

Графика нет. Не стал заморачиваться и прогонял скорость через спидтест.

 

Share this post


Link to post
Share on other sites

Ваш трафик - яйца. Каналы - корзины. Сколько бы вы не взяли корзин, ваше ОДНО ЯЙЦО в них не разложить. Одна корзина будет нагружена, остальные - нет.

С вашей стороны всего один адрес

Share this post


Link to post
Share on other sites
3 часа назад, rz3dwy сказал:

а на порту есть эти самые разные MAK? Если и там и там один хост, то и балансировать будет нечего

 

3 часа назад, ShyLion сказал:

Коллега, если по этому линку обмениваются траффиком всего два физических хоста на 2 уровне, то грузится будет только один интерфейс, так как всего два мака. Это для примера

Коллеги, вы правы....

По не значению хотелось, сверхъестественного!

 

Edited by feeman

Share this post


Link to post
Share on other sites
3 минуты назад, feeman сказал:

Да у меня еще смешнее ситуация. Скорость порта должна быть ~200 Мбит.

Из-за того, что у выше стоящего dlink 3526 с сотошными портами, пришлось городить LACP.

 

 

 

 

Графика нет. Не стал заморачиваться и прогонял скорость через спидтест.

 

Спидтест дает вам одну сессию tcp. Это фикс sip:sport-dip:dport. Оно ВСЕГДА будет проходить по одному из физических портов в вашем lag.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now