Jump to content
Калькуляторы

Multi Wan с привязкой по портам

Добрый день!

В общем ситуация. 

Домашняя локальная сеть - компьютер,ноутбук, телевизоры ,  NAS Сервер.

2 интернет провайдера ISP 1 и ISP2

Необходимо настроить Микротик так, чтобы весь трафик шел через ISP 1 , кроме закачек с торрент программы NAS сервера ( или компьютера) - данный трафик должен идти через ISP 2 . 

Те необходимо чтобы трафик по определенному порту ( в моем случае TCP 16881 ) проходил только через ISP 2.

Нашел в инете иснтрукцию, почему то она не срабатывает.

Подскажите пожалуйста в чем проблемма?

 

 

# Настроим сети провайдеров:
/ip address add address=10.100.1.1/24 interface=ISP1
/ip address add address=10.200.1.1/24 interface=ISP2
# Настроим локальный интерфейс 
/ip add address=10.1.1.1/24 interface=LAN
# скроем за NAT все что выходит из локальной сети
/ip firewall nat add src-address=10.1.1.0/24 action=masquerade chain=srcnat
#Пометим каждое соединение пришедшее снаружи и адресованное нашему роутеру:
/ip firewall mangle add action=mark-connection chain=input in-interface=ISP1 new-connection-mark=cin_ISP1
/ip firewall mangle add action=mark-connection chain=input in-interface=ISP2 new-connection-mark=cin_ISP2
#что бы отвечать через те же интерфейсы, откуда пришли запросы, поставим соответствующую роутинг-марку на каждое соединение.
/ip firewall mangle add action=mark-routing chain=output connection-mark=cin_ISP1 new-routing-mark=rout_ISP1 passthrough=no
/ip firewall mangle add action=mark-routing chain=output connection-mark=cin_ISP2 new-routing-mark=rout_ISP2 passthrough=no
#добавим default gateway в каждую из промаркированных таблиц маршрутизации:
/ip route add distance=1 gateway=10.100.1.254 routing-mark=rout_ISP1 check-gateway=ping
/ip route add distance=1 gateway=10.200.1.254 routing-mark=rout_ISP2 check-gateway=ping
#failover через второго провайдера для каждого из шлюзов
/ip route add distance=2 gateway=10.200.1.254 routing-mark=rout_ISP1 
/ip route add distance=2 gateway=10.100.1.254 routing-mark=rout_ISP2 
# отправим трафик идущий к портам 80,443,110,25 на ISP1
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark="lan_out_ISP1" passthrough=no dst-port=80,443,110,25 protocol=tcp 
#а весь остальной трафик на ISP2:
/ip firewall add chain=prerouting action=mark-routing new-routing-mark="lan_out_ISP2" passthrough=no
#добавим default gateway в каждую из промаркированных для LAN трафика таблиц маршрутизации:
/ip route add distance=1 gateway=10.100.1.254 routing-mark=lan_out_ISP1 check-gateway=ping
/ip route add distance=1 gateway=10.200.1.254 routing-mark=lan_out_ISP2 check-gateway=ping
#failover через второго провайдера для каждого из шлюзов
/ip route add distance=2 gateway=10.200.1.254 routing-mark=lan_out_ISP1 
/ip route add distance=2 gateway=10.100.1.254 routing-mark=lan_out_ISP2 
Edited by Акмал

Share this post


Link to post
Share on other sites
2 hours ago, Акмал said:

Те необходимо чтобы трафик по определенному порту ( в моем случае TCP 16881 ) проходил только через ISP 2.

Если это порт, указанный в настройках клиента, с него идет раздача, а не закачка.

Закачка идет с разных портов, как они у пиров настроены, локальные порты клиент (почти)случайным образом выбирает, когда подключается к пирам.

 

 

Share this post


Link to post
Share on other sites

отправте НАС через 2 прова полностью ,

хотя я бы просто тупо доил инет с обоих провайдеров )))) раскидывая соединения, это просто  тем более если  емкость подключения одинакова по провам.

а НАС жестко через нужного прова

 

17 часов назад, Акмал сказал:

#что бы отвечать через те же интерфейсы, откуда пришли запросы, поставим соответствующую роутинг-марку на каждое соединение.

это бред и так ответит на тот интерфейс с которого пришел пакет.

 

17 часов назад, Акмал сказал:

# скроем за NAT все что выходит из локальной сети /ip firewall nat add src-address=10.1.1.0/24 action=masquerade chain=srcnat

выделенное тоже лишнее для домашней сети

 

а где правило НАТа  для 2 прова??

 

Share this post


Link to post
Share on other sites
6 часов назад, Constantin сказал:

отправте НАС через 2 прова полностью

У второго провайдера скорость высокая только ночью, днем скорость около 20 кб/сек. Поэтому нужно чтобы закачки шли именно через второго провайдера, а остальные службы ( которые потребляют мало трафика) шли через первого ( у которого лимитирован интернет трафик)

 

6 часов назад, Constantin сказал:

выделенное тоже лишнее для домашней сети

 

а где правило НАТа  для 2 прова??

Я только 5 день с микротиком вожусь, но вроде это настройка ната чисто для локальной сети адрес же локальной сети 10,1,1,0/24 

Также без настройки НАТа интернет на роутере не пашет

 

Share this post


Link to post
Share on other sites

ну чтоб трафик шел через 2 прова на нем тоже должно быть правило НАТа

 

ну идея выше правильная только на мой вкус корявая......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this