Jump to content
Калькуляторы

не открываются некоторые сайты при запущенном l2tp сервере mikrotik hap lite

Роутер выступает в роли l2tp сервера( обьеденения 2х удалленых офисов в которых точно такие же микротики выступают клиентами)+ раздача wi-fi. Статикой от провайдера на порт №1 получает интернет.

Все было настроено поверх стандартной конфигурации миротика.

Проблема в том что некоторые сайты не открываются.

конфигурация:

# oct/08/2018 00:46:54 by RouterOS 6.43.2
# software id = 25A1-UB09
#
# model = RouterBOARD 941-2nD
# serial number = 8B0E08B50D6C
/interface bridge
add admin-mac=CC:2D:E0:A6:77:37 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=\
    kioto-market.com.ua wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether2 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether3 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether4 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=910910910 \
    wpa2-pre-shared-key=123456789
/ip pool
add name=dhcp ranges=192.168.1.10-192.168.1.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface l2tp-server server
set enabled=yes
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.1.1/24 comment=defconf interface=ether2 network=\
    192.168.1.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
    ether1
/ip dhcp-server network
add address=192.168.1.0/24 comment=defconf gateway=192.168.1.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.1 name=router.lan
/ip firewall filter
add action=accept chain=input protocol=gre
add action=accept chain=input dst-port=1701 protocol=tcp
add action=accept chain=input dst-port=1723 protocol=tcp
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked disabled=yes
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid disabled=yes
add action=accept chain=input comment="defconf: accept ICMP" disabled=yes \
    protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    disabled=yes in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    disabled=yes ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    disabled=yes ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related disabled=yes
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked disabled=yes
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid disabled=yes
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new disabled=yes in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface=all-ppp
add action=netmap chain=dstnat dst-address=192.168.1.1 dst-port=8080 \
    in-interface=bridge protocol=tcp to-addresses=192.168.1.1 to-ports=8080
add action=netmap chain=dstnat dst-port=8081 protocol=tcp to-addresses=\
    192.168.88.1 to-ports=8081
add action=netmap chain=dstnat dst-port=8082 protocol=tcp to-addresses=\
    192.168.10.1 to-ports=8082
add action=netmap chain=dstnat dst-port=8090 protocol=tcp to-addresses=\
    192.168.88.250 to-ports=8090
add action=netmap chain=dstnat dst-port=554 protocol=tcp to-addresses=\
    192.168.88.250 to-ports=554
add action=netmap chain=dstnat dst-port=8291 protocol=tcp to-addresses=\
    192.168.1.1 to-ports=8291
add action=netmap chain=dstnat dst-port=80 protocol=tcp to-addresses=\
    192.168.88.250 to-ports=80
add action=netmap chain=dstnat dst-port=8000 protocol=tcp to-addresses=\
    192.168.10.252 to-ports=8000
add action=masquerade chain=srcnat dst-address=192.168.10.0/24 out-interface=\
    all-ethernet
add action=masquerade chain=srcnat dst-address=192.168.88.0/24 out-interface=\
    all-ethernet
/ip route
add distance=1 dst-address=192.168.10.0/24 gateway=10.50.0.12 pref-src=\
    10.50.0.10
add distance=1 dst-address=192.168.88.0/24 gateway=10.50.0.11 pref-src=\
    10.50.0.10
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge type=internal
add interface=ether1 type=external
/ppp secret
add local-address=10.50.0.10 name=------ password=-------- remote-address=\
    10.50.0.12 service=l2tp
add local-address=10.50.0.10 name=----- password=---------- remote-address=\
    10.50.0.11 service=l2tp
/system clock
set time-zone-name=Europe/Kiev
/system routerboard settings
set auto-upgrade=yes silent-boot=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

 

Share this post


Link to post
Share on other sites
11 часов назад, kioto-market сказал:

Все было настроено поверх стандартной конфигурации миротика.

Сударь, перспективы ваши положительно безнадежны. Освойте разок конфиг с нуля, это не атомная физика, и гораздо легче, чем разабираться, где там нагадил дефолтный конфиг.

 

11 часов назад, kioto-market сказал:

/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface=all-ppp

...

add action=masquerade chain=srcnat dst-address=192.168.10.0/24 out-interface=\
    all-ethernet
add action=masquerade chain=srcnat dst-address=192.168.88.0/24 out-interface=\
    all-ethernet

Воруй@Убивай Нать@Маскарадь. У вас даже локальный трафик NATится, хотя могла бы работать маршрутизация. Кстати, любопытно, покажите ка System - Resources

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this