Jump to content
Калькуляторы

redistribute статического маршрута по ospf (Quagga)

Имею вот такой конфиг (конфиг под сполерем), все работает, но не могу добавить маршрут в подсеть 192.168.22.0/24 и передать его всем остальным. Делаю через redistribute connected route-map, но что то видать не понимаю и делаю не так. Помогите пожалуйста :)

Скрытый текст

router ospf
 ospf router-id 10.123.3.1
 passive-interface default
 no passive-interface tap3
 no passive-interface tap4
 network 10.123.3.0/24 area 0.0.0.0
 network 10.123.4.0/24 area 0.0.0.0
 network 10.123.1.0/30 area 0.0.0.50
 network 10.123.10.0/24 area 0.0.0.50
 network 10.123.33.0/24 area 0.0.0.50
 network 10.123.40.0/24 area 0.0.0.50
!
!default-information originate
!
redistribute connected route-map krd
!
ip prefix-list rtr permit 192.168.22.0/24 le 32
ip prefix-list krd  deny any
!
route-map krd permit 100
match ip address prefix-list rtr
!
route-map krd deny 200
!
access-list vty permit 127.0.0.0/8
access-list vty deny any
!
line vty
 access-class vty
!
log file /tmp/quagga.log

 

 

Share this post


Link to post
Share on other sites
В 06.10.2018 в 10:43, zhenya` сказал:

а маршрут есть на эту сетку?

да, конечно. Если добавить руками на маршрутизаторе (на котором маршрут должен прийти по ospf), то всё работает

Share this post


Link to post
Share on other sites

тогда не понял вопроса :(

 

3 часа назад, zhenya` сказал:

я про тот пк, где вы делаете редистрибуцию.

на исходном пк (программный маршрутизатор в моём случае) конечно есть маршрут..

Share this post


Link to post
Share on other sites

пробовал redistribute static  ,  не рботает.

Статический адрес куда то нужно прописать? или поместить? Может конфиг куаги не понимает откуда ему его брать..

Share this post


Link to post
Share on other sites
13 часов назад, Hiks сказал:

пробовал redistribute static  ,  не рботает.

Статический адрес куда то нужно прописать? или поместить? Может конфиг куаги не понимает откуда ему его брать..

{telepath-mode on} если вы этим роутером хотите за анонсировать в ospf area маршрут известный этому роутеру,

то, если он является 

- диапазоном находящимся непосредственно за локальным сетевым интерфейсом (connected), надо redistribute connected

- диапазон находящейся за соседним роутером и не получаемый через какой-либо протокол динамической маршрутизации, т.е. прописанным руками (static), то вы должны redistribute static

- сети из динамических протоколов - redistribute rip | bgp ....

 

соответственно, если ваш 192.168.22.0 не динамический маршрут, то надо его добавить на вашем роутере статикой (ip route add 192.168.22.0/24 via 10.x.xx.xxx) и поместить его в ospf (redistribute static)

 

Edited by guеst

Share this post


Link to post
Share on other sites
4 часа назад, guеst сказал:

{telepath-mode on} если вы этим роутером хотите за анонсировать в ospf area маршрут известный этому роутеру,

то, если он является 

- диапазоном находящимся непосредственно за локальным сетевым интерфейсом (connected), надо redistribute connected

- диапазон находящейся за соседним роутером и не получаемый через какой-либо протокол динамической маршрутизации, т.е. прописанным руками (static), то вы должны redistribute static

- сети из динамических протоколов - redistribute rip | bgp ....

 

соответственно, если ваш 192.168.22.0 не динамический маршрут, то надо его добавить на вашем роутере статикой (ip route add 192.168.22.0/24 via 10.x.xx.xxx) и поместить его в ospf (redistribute static)

 

 

сам маршрут 192.168.22.0/24 via 10.x.xx.xxx добавлен на маршрутизаторе.

Его в Quagga  не видно. Дополнительно в Quagga как добавить?

 

В итоге сделал через redistribute kernel route-map - так работает. Только прочел, что лучше так не делать, а почему кто то может объяснить?

Edited by Hiks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this