Перейти к содержимому
Калькуляторы

RB2011 и VLAN помогите настроить

Появилась задача настроить RB2011UiAS-RM как L2-коммутатор.

Вводные следующие -

на SFP - должны ходить тегированные VLAN 10,100,128

на ETH2 запустить VLAN 10 нетегированный (обязательно нужен 1Гбит)

на ETH3 запустить VLAN 128 нетегированный (обязательно нужен 1Гбит)

 

дальше нужно 3 порта на VLAN 128 нетегированные (достаточно 100 Мбит)

и еще 3 порта на VLAN 100 нетегированные (достаточно 100 Мбит)

 

Никаких маршрутизаций и прочего не нужно, чистая коммутация по VLAN.

Разве что оставить еще порт для мониторинга и настройки самого Mikrotik.

 

Буду очень признателен за помощь или подсказки, т.к. железяка для меня новая и с Mikrotik мало знаком.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если на тике новая прошивка  -  6.41 и выше то можно воспользоваться  https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_VLAN_Filtering

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Предоставлю более развёрнутый ответ по своему опыту. Разве что я настраивал RB951 и на vlan-интерфейсы вешал IPшники.

Прошивка 6.41.7, поэтому никаких мастер-портов, используем bridge vlan.

 

#Создаем сам бридж, сразу выключаем фильтрацию vlan - говорят, что потряешь связь с микротиком, если включить фильтрацию сразу, пока ещё ничего настроено (как по мне - звучит логично).

/interface bridge
add name=bridge1 vlan-filtering=no

#Создаем необходимые вланы (Вам, может и не потребуется, т.к. Вы не вешаете ip-адреса на vlan-интерфейсы)

/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan100 vlan-id=100

add interface=bridge1 name=vlan128 vlan-id=128

#Добавляем в бридж все порты, которые используются. У access-портов указываем pvid, у trunk-портов не указываем.

/interface bridge port
add bridge=bridge1 interface=sfp
add bridge=bridge1 interface=ether2 pvid=10
add bridge=bridge1 interface=ether3 pvid=128
add bridge=bridge1 interface=ether5 pvid=128
add bridge=bridge1 interface=ether6 pvid=128

add bridge=bridge1 interface=ether7 pvid=128

add bridge=bridge1 interface=ether8 pvid=100

add bridge=bridge1 interface=ether9 pvid=100

add bridge=bridge1 interface=ether10 pvid=100

#Указываем транковые порты (sfp) и access-порты (ether2-3,5-10) и соответствующие им vlan'ы. Также транковым портом указываем bridge1 (вроде, если не указать - не будет доступа к самому роутеру).

/interface bridge vlan
add bridge=bridge1 tagged=bridge1,sfp untagged=ether2 vlan-ids=10

add bridge=bridge1 tagged=bridge1,sfp untagged=ether8,ether9,ether10 vlan-ids=100
add bridge=bridge1 tagged=bridge1,sfp untagged=ether3,ether5,ether6,ether7 vlan-ids=128

# Задаем ip-адреса на vlan-интерфейсы (как говорил - Вам это может быть не нужно)

/ip address
add address=10.0.10.1/24 interface=vlan10 network=10.0.10.0
add address=10.0.100.1/24 interface=vlan100 network=10.0.100.0

add address=10.0.128.1/24 interface=vlan128 network=10.0.128.0

#Включаем фильтрацию vlan

/interface bridge
add name=bridge1 vlan-filtering=yes

 

В Вашем запросе указано 6 портов 100 мбит, но в rb2011 их всего 5 (верно?), поэтому для vlan128 используется один порт 1000 мбит (ether5) вместо 100 мбит.

 

Конфиг переписывал руками исходя из своего, но у меня и vlan-ов меньше, и sfp-порта нет, и транк-порта два. Но, надеюсь, нигде не ошибся.

Если есть какой косяк --- Гуру, поправьте меня.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас