Jump to content
Калькуляторы

OSPF между Mikrotik и SNR

Добрый день. Решил нарезать сеть на вланы, а на вланы повесить подсети /24, как на приложенном файле. Чтобы не прописывать всю маршрутизацию статикой, решил включить OSPF. Но то ли я не до конца понимаю работу OSPF, то ли мультикаст не работает как надо, то ли ещё что-то.

Конфиг микротика:

/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 redistribute-static=as-type-1 router-id=192.168.16.1
/routing ospf network
add area=backbone network=172.16.0.0/24

Конфиг SNR2995

router ospf
 ospf router-id 192.168.16.4
 network 172.16.1.0/24 area 0.0.0.0
 redistribute connected
!

192.168.16.0/22 - управляющий влан. На 4550 все порты в транке. Ради эксперимента соединил микротик и 2995 напрямую - без разницы. Если вручную прописать маршруты - всё работает. Если задавать area по умолчанию на SNR, он ей прописывает id 0, а на микротике backbone area id - 0.0.0.0, поэтому прописал такую же на SNR. IGMP Snooping включал-выключал - тоже никакого эффекта.

Версия SNR:

  SoftWare Package Version 7.5.3.2(R0004.0088)
  BootRom Version 7.5.21
  HardWare Version 1.0.1
Версия RouterOS: 6.42.6

L3 агрегация.png

Edited by televid
Забыл указать версии прошивок

Share this post


Link to post
Share on other sites

Что не работает то? Соседство поднимается? Что дебаг говорит?

Share this post


Link to post
Share on other sites

@televid В /routing ospf interface  как я понял пусто? 

 

Дай вывод

routing ospf neighbor print 

 

Не знаю как на SNR настраивается OSPF, но не хватает анонса сетей 172.16.1.0/24 и 172.16.2.0/24

 

Share this post


Link to post
Share on other sites

а то что разные интерфейсы в оспф включены - ничего?
network=172.16.0.0/24 на микротике, значит будет включен осфп на интерфейсе vlan10
а network 172.16.1.0/24 на SNR, предполагаю, включит ospf на vlan11, но никак не на vlan10
 

Share this post


Link to post
Share on other sites

@Mystray Действительно, дело было в этом. Я почему-то был уверен, что в networks надо указывать те сети, которые надо анонсировать. Спасибо.

Соседи появились.

А можно как-то сделать, чтобы OSPF ходил только в менеджмент-влане, не отсвечивая в пользовательских? Предполагаю, что достаточно изменить network на 192.168.16.0/22.

UPD. Хотя нет, если указать так, то шлюз получается тоже в менеджмент-влане.

Edited by televid

Share this post


Link to post
Share on other sites

Интерфейс в сторону клиента пассив поставьте

Share this post


Link to post
Share on other sites

Вообще считается хорошим тоном разделять служебные и абонентские (серые) сети, тогда очень легко отделять одних от других.

 

Что бы OSPF не ходит в абонентских вланах нужно правильно его настроить - то есть сделать анонс connected роутов, а в networks указать служебную серую подсеть, по которой роутеры соединяются.

Share this post


Link to post
Share on other sites
8 часов назад, Saab95 сказал:

Вообще считается хорошим тоном разделять служебные и абонентские (серые) сети, тогда очень легко отделять одних от других.

 

Что бы OSPF не ходит в абонентских вланах нужно правильно его настроить - то есть сделать анонс connected роутов, а в networks указать служебную серую подсеть, по которой роутеры соединяются.

Правельный тоном использовать vrf, но в микротике нет его.

Share this post


Link to post
Share on other sites
8 часов назад, pingz сказал:

Правельный тоном использовать vrf, но в микротике нет его.

+100500 только хотел это написать

Share this post


Link to post
Share on other sites
В 8/22/2018 в 12:32, Saab95 сказал:

Вообще считается хорошим тоном разделять служебные и абонентские (серые) сети, тогда очень легко отделять одних от других.

 

Что бы OSPF не ходит в абонентских вланах нужно правильно его настроить - то есть сделать анонс connected роутов, а в networks указать служебную серую подсеть, по которой роутеры соединяются.

Просто оставлю это вложение здесь

Saab95-ospf.mp4

 

 

Share this post


Link to post
Share on other sites
В 24.08.2018 в 05:54, VolanD666 сказал:

Wat?

А это мы так прикалываемся над Sab_ом... На видео показано как делать нельзя :) :) 

 

В 22.08.2018 в 21:10, pingz сказал:

Правельный тоном использовать vrf, но в микротике нет его.

Да вроде VRF в микротике появился... Я правда не использую его уже с 2013 года но...

Share this post


Link to post
Share on other sites

@zoro хорошо

Писать буду как джуниперовод :Д

 

Представь дефолтная таблица inet.0

Когда я создаю vrf у меня создаётся таблица inet.vrf и она не как не общается с inet.0

Так же все процессы ospf, bgp и и.т.д живут в своих таблицах т.е. сколько vrf столько и процессов и таблиц маршрутизации.

 

В микротике есть только мейн, и ты уже в этом мейне маркируешь роуты и т.д., все процессы работают с мейном. Да там есть маркировка и т.д., но охота выключить конекшен трекинг(погугли как он работает)

 

Вопрос, зачем писать то в чем ты не разбираешься?

 

З.ы. я не гуру микротиков и джунов. Но у всех есть свои правила игра, за свои деньги. Место для микротиков есть, но есть свои ограничения.

З.з.ы. мы говорили про "хороший тон" хотя ты знаешь саб этим не славится

Share this post


Link to post
Share on other sites
В 25.08.2018 в 15:42, zoro сказал:

А это мы так прикалываемся над Sab_ом... На видео показано как делать нельзя :) :) 

 

Да вроде VRF в микротике появился... Я правда не использую его уже с 2013 года но...

VRF в микроте ненастоящий. Они вроде планировали сделать настоящий VRF в 7ой версии, так что, надеюсь наши правнуки увидят его, когда сделают 7ую версию

Share this post


Link to post
Share on other sites

я не настраивал VRF на микротике, и с ним с 2013 года не работаю.. Только Cisco, Huawei... и VRF каждый день использую, но там MPLS...

 Посмотрел описание- есть и заявлено что работает.... Если по факту как вы пишите- Это да писец...

Share this post


Link to post
Share on other sites

На самом деле как заявлено - так он и работает. Нужно просто понимать, что делался он на базе PBR, когда в Linux еще не появились полноценные Network Namespace - которые вкупе с veth-устройствами вполне могут быть аналогом VRF-Lite и VASI-интерфейсов(если говорить терминологией Cisco). Текущая реализация накладывает некоторые серьезные ограничения - например IP-адреса самого маршрутизатора будут доступны в КАЖДОМ VRF, а также в глобальной таблице маршрутизации.

Share this post


Link to post
Share on other sites

А где это заявлено? В том то и проблема, что я наткнулся случайно. Думал что это работает как у циски, например

Share this post


Link to post
Share on other sites

https://wiki.mikrotik.com/wiki/Manual:Virtual_Routing_and_Forwarding
 

Quote

Technically VRFs are based on policy routing

А дальше читаем статью - https://wiki.mikrotik.com/wiki/Manual:IP/Route#Routing_table_lookup
 

Quote

If there is no routing cache entry for this packet, it is created by running routing decision:

check that packet has to be locally delivered (destination address is address of the router)

 

И да, это касается ВСЕХ адресов роутера. Собственно такое же поведение, как и в чистом Linux, если глянуть на выхлоп команды ip rule в консоли

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now