Jump to content
Калькуляторы

Что не так с hotspot? Невозможно подключиться по радиолинку

Изначалльно было так:

Главный роутер RB2011
5 порт - провайдер
Остальные порты в бридже, на нём ip = 10.1/23

В 10 порт (POE) включена точка доступа Nanostation M2 в режиме AP,
помимо клиентов к ней подключена в режиме Station другая M2.
Ко второй М2 подключен коммутатор, в который воткнуты 2 wAP.

10порт ---- М2 АР <---радиолинк---> М2 Station ---коммутатор - 2х wAP

Всё работает без замечаний.
Понадобилась аутентификация для клиентов по смс и телефону.

Что сделали:
создали ещё однин bridge - bridge-hotspot назначили ему ip 108.1/22
И в него воткнули 10 порт, 7 порт и sfp, на которых висели точки доступа.

И возникла проблема с подключением к wAP. Страница хотспота открывается нереально медленно, аутентификация тормозит - до конца не дождался.

НО, если подойти к М2, которая в режиме AP и подключиться к ней, то страница аутентификации открывается без проблем.

Как только, 10 порт переключаешь в старый бридж - к вапам без проблем подключаешься и присутствует инет.

На вапах создан бридж, на него повесил dhcpclient, апи выдаётся из той сетки в бридж которой подключён. В бридже wlan и Ethernet.

Вапы получили апи 108.57 и 108.163


Увидел различие в бриджах, почему-то на bridge (10.1) mtu 1458, bridge-hotspot mtu = 1500
Может как-то 10 порт себя странно ведет, он же в другом свич чипе?

Ещё, c wAP шлюз не пингуется, т.к. блокируется правилами firewall созданные hotspot,
хотя arp ping 20-30 мс. Я пробовал добавлять ip адреса wAP в ip hotspot walled-garden ip
Но проблему не решило.

Моих знаний не хватает, чтобы понять где собака порылась.
Куда посмотреть, что б определиться со странностями по скорости?

 

Картинки М2 прилагаю.

 

Конфиг 2011

Скрытый текст

# aug/17/2018 11:47:11 by RouterOS 6.42.6
# software id = PIMV-GRKH
#
# model = 2011UiAS
# serial number = 77AD07193E9E
/interface bridge
add admin-mac=64:D1:54:2F:68:77 auto-mac=no name=Bridge-Local
add name=bridge-hotspot
/interface ethernet
set [ find default-name=ether1 ] name=LAN1
set [ find default-name=ether2 ] name=LAN2
set [ find default-name=ether3 ] name=LAN3
set [ find default-name=ether4 ] name=LAN4
set [ find default-name=ether6 ] comment="admin's router" name=LAN6
set [ find default-name=ether7 ] comment="AP Restoran" name=LAN7
set [ find default-name=ether8 ] name=LAN8
set [ find default-name=ether9 ] name=LAN9
set [ find default-name=ether10 ] comment="AP Bereg-1 ip=10.22 Ma\
    ster  AP <-> Client AP 10.21 <-> 2x wAP (k3_white and k6_black)" name=\
    LAN10
set [ find default-name=ether5 ] comment="static 1.1.1.210/30 gw 209" \
    name=WAN1-eth5 speed=1Gbps
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
add dns-name=wf.wifly.net hotspot-address=192.168.108.1 login-by=\
    http-chap,http-pap name=hsprof1 radius-interim-update=5m use-radius=yes
/ip pool
add name=dhcp_pool1 ranges=192.168.10.30-192.168.11.254
add name=hs-pool-18 ranges=192.168.108.2-192.168.111.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=Bridge-Local name=dhcp1
add address-pool=hs-pool-18 disabled=no interface=bridge-hotspot lease-time=\
    1h name=dhcp2
/ip hotspot
add address-pool=hs-pool-18 disabled=no interface=bridge-hotspot \
    keepalive-timeout=5m name=hotspot1 profile=hsprof1
/snmp community
set [ find default=yes ] addresses=0.0.0.0/0
/interface bridge port
add bridge=Bridge-Local interface=LAN1
add bridge=Bridge-Local interface=LAN2
add bridge=Bridge-Local interface=LAN3
add bridge=Bridge-Local interface=LAN4
add bridge=Bridge-Local interface=LAN6
add bridge=Bridge-Local interface=LAN8
add bridge=Bridge-Local interface=LAN9
add bridge=bridge-hotspot interface=LAN7
add bridge=Bridge-Local interface=LAN10
add bridge=bridge-hotspot interface=sfp1
/interface l2tp-server server
set authentication=mschap1,mschap2
/ip address
add address=192.168.10.1/23 comment="[LAN 10.0/23]  [AP Bereg-1 - 1.241] " \
    interface=Bridge-Local network=192.168.10.0
add address=1.1.1.210/30 interface=WAN1-eth5 network=1.1.1.208
add address=192.168.108.1/22 interface=bridge-hotspot network=192.168.108.0
/ip dhcp-server lease
add address=192.168.111.7 client-id=1:0:e:c6:a7:1f:b4 comment=My_notebook \
    mac-address=00:0E:C6:A7:1F:B4 server=dhcp2
add address=192.168.108.2 comment="cam 10.2 -> 108.2" mac-address=\
    4C:BD:8F:CA:7A:59 server=dhcp2
add address=192.168.108.5 comment="cam 10.5 -> 108.5" mac-address=\
    4C:BD:8F:CA:7A:C9 server=dhcp2
add address=192.168.108.7 comment="cam 10.7 -> 108.7" mac-address=\
    4C:BD:8F:FA:EB:E9 server=dhcp2
add address=192.168.108.8 comment="10.21 station" disabled=yes mac-address=\
    DC:9F:DB:0D:51:BF server=dhcp2
add address=192.168.108.9 comment="10.22 AP" disabled=yes mac-address=\
    DC:9F:DB:0D:53:5F server=dhcp2
/ip dhcp-server network
add address=192.168.10.0/23 dns-server=192.168.10.1 gateway=192.168.10.1
add address=192.168.108.0/22 comment="hotspot network" dns-server=\
    192.168.108.1 gateway=192.168.108.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall address-list
add address=192.168.111.7 list=FROM_ACCESS
add address=192.168.108.1 list=DST_ACCESS
add address=192.168.10.0/23 list=DST_ACCESS
add address=192.168.10.0/23 list=FROM_ACCESS
add address=192.168.108.2 list=DST_ACCESS
add address=192.168.108.2 list=FROM_ACCESS
add address=192.168.10.20 list=DST_ACCESS
add address=192.168.10.20 list=FROM_ACCESS
add address=192.168.108.5 list=DST_ACCESS
add address=192.168.108.7 list=DST_ACCESS
add address=192.168.108.5 list=FROM_ACCESS
add address=192.168.108.57 disabled=yes list=DST_ACCESS
add address=192.168.108.57 disabled=yes list=FROM_ACCESS
add address=192.168.111.7 list=DST_ACCESS
/ip firewall filter
add action=accept chain=forward comment="accept video from cams" \
    dst-address-list=DST_ACCESS src-address-list=FROM_ACCESS
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=drop chain=input dst-port=53 in-interface=WAN1-eth5 protocol=udp
add action=reject chain=input dst-port=53 in-interface=WAN1-eth5 protocol=udp \
    reject-with=icmp-network-unreachable
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=netmap chain=dstnat dst-port=8000 in-interface=WAN1-eth5 protocol=\
    tcp to-addresses=192.168.10.20 to-ports=8000
add action=netmap chain=dstnat dst-port=554 in-interface=WAN1-eth5 protocol=\
    tcp to-addresses=192.168.10.20 to-ports=554
add action=masquerade chain=srcnat out-interface=WAN1-eth5
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    src-address=192.168.108.0/22
/ip hotspot user
add name=admin
/ip hotspot walled-garden
add comment="place hotspot rules here" disabled=yes
add dst-host=login.wifly.net server=hotspot1
add dst-host=wf.wifly.net server=hotspot1
/ip hotspot walled-garden ip
add action=accept disabled=yes dst-address=192.168.108.1 !dst-address-list \
    !dst-port !protocol server=hotspot1 src-address=192.168.108.163 \
    !src-address-list
add action=accept disabled=yes dst-address=192.168.111.7 !dst-address-list \
    !dst-port !protocol server=hotspot1 src-address=192.168.111.52 \
    !src-address-list
add action=accept disabled=yes dst-address=192.168.108.1 !dst-address-list \
    !dst-port !protocol server=hotspot1 src-address=192.168.111.7 \
    !src-address-list
add action=accept disabled=yes dst-address=192.168.108.57 !dst-address-list \
    !dst-port !protocol server=hotspot1 src-address=192.168.111.7 \
    !src-address-list
/ip route
add distance=1 gateway=1.1.1.209
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=8081
set ssh port=2223
set api disabled=yes
set api-ssl disabled=yes
/ip upnp
set enabled=yes
/lcd
set backlight-timeout=10m default-screen=stats enabled=no time-interval=hour \
    touch-screen=disabled
/lcd pin
set pin-number=1221
/lcd interface pages
set 0 interfaces=sfp1,LAN1,*3,LAN3,LAN4,*6,*7,LAN7,LAN8,LAN9,LAN10
/radius
add address=2.2.2.2 secret=xxxxxx service=hotspot
add address=3.3.3.3 secret=xxxxxx service=hotspot
add address=4.4.4.4 secret=xxxxxx service=hotspot
/system clock
set time-zone-name=Europe/Moscow
/system identity
set name=Main
/system ntp client
set enabled=yes primary-ntp=192.36.143.130 secondary-ntp=88.147.254.234
/system routerboard settings
set silent-boot=no

 

 

Конфиг wAP

Скрытый текст

# aug/17/2018 11:40:10 by RouterOS 6.42.6
# software id = XPDR-GFGD
#
# model = RouterBOARD wAP 2nD r2
# serial number = 6D82088C5F26
/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name=Key \
    supplicant-identity="" wpa-pre-shared-key=12345678 wpa2-pre-shared-key=\
    12345678
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=2437 \
    mode=ap-bridge radio-name=AP_K3 security-profile=Key ssid=BEREG-3 \
    tx-power=22 tx-power-mode=all-rates-fixed wireless-protocol=802.11 \
    wmm-support=enabled wps-mode=disabled
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 hw=no interface=ether1
add bridge=bridge1 interface=wlan1
/ip address
add address=192.168.10.24/23 disabled=yes interface=bridge1 network=\
    192.168.10.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=8081
set ssh port=2223
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Moscow
/system identity
set name=AP_K3_White
/system routerboard settings
set silent-boot=no

 

 

station.png

ap.png

Edited by vbsev

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this