Jump to content
Калькуляторы

SNR-S2985G-8T настройка Q-in-Q (selective) или Tunnel

Добрый день! Подскажите пожалуйста по следующей задаче: необходимо через 1 влан провайдера пропустить несколько клиентских вланов...На текущий момент провайдер не в состоянии поднять самостоятельно Q-in-Q. планируется связать 2 коммутатора SNR-S2985G-8T  через vlan trunk провайдера (vlan 111). Пробрасываем несколько вланов (1,5-100), один из которых vlan 1 (native управление свитчами). схему прилагаем. 

 

Сторона с подключенными клиентами:

!
vlan 1;5-100
!
Interface Ethernet1/0/1
 switchport access vlan 5
!
Interface Ethernet1/0/2
 switchport access vlan 6
!
Interface Ethernet1/0/3
 switchport access vlan 15
!
Interface Ethernet1/0/4
!
Interface Ethernet1/0/5
 switchport access vlan 100
!
Interface Ethernet1/0/6
 switchport mode trunk
 switchport trunk allowed vlan 1;5-100
!
Interface Ethernet1/0/7
 description Loop_to_Eth1/0/6
 dot1q-tunnel enable
 switchport access vlan 111
!
Interface Ethernet1/0/8
 dot1q-tunnel tpid 0x9100
 switchport mode trunk
 switchport trunk allowed vlan 1;5-100
!
Interface Ethernet1/0/9
!
Interface Ethernet1/0/10
!
interface Vlan1
 description SW_Management
 ip address 192.168.1.15 255.255.255.0
!
ip default-gateway 192.168.1.1
!
ntp enable
ntp server 192.168.1.1
 

Сторона подключенная к SNR-2990-48T:

!
vlan 1;5-100
!
Interface Ethernet1/0/1
!
Interface Ethernet1/0/2
!
Interface Ethernet1/0/3
!
Interface Ethernet1/0/4
!
Interface Ethernet1/0/5
!
Interface Ethernet1/0/6
 switchport mode trunk
 switchport trunk allowed vlan 1;5-100
!
Interface Ethernet1/0/7
 description Loop_to_Eth1/0/6
 dot1q-tunnel enable
 switchport access vlan 111
!
Interface Ethernet1/0/8
 dot1q-tunnel tpid 0x9100
 switchport mode trunk
 switchport trunk allowed vlan 1;5-100
!
Interface Ethernet1/0/9
 switchport mode trunk
 switchport trunk allowed vlan 1;5-100
!
Interface Ethernet1/0/10
!
interface Vlan1
 description SW_Management
 ip address 192.168.1.16 255.255.255.0
!
ip default-gateway 192.168.1.1
!
ntp enable
ntp server 192.168.1.1
!

 

Проверяли как с петлей так и без нее...SNR-S2985G-8T пингуют друг-друга, шлюз 192.168.1.1 виден а туннель не работает. Подскажите какая ошибка допущена

 

q-in-q.jpg

Edited by AM_Diagnost

Share this post


Link to post
Share on other sites

Может, провайдер не пропускает фреймы 0x9100?

Дамп не пробовали снимать?

У вас 111 vlan не создан:

 vlan 1;5-100 

MTU размером 1504, кстати, провайдер пропускает?

 

Share this post


Link to post
Share on other sites

про влан 111 заметил тоже, добавление ни к чему не привело...Пробовал имитировать сеть провайдера включая обе стороны в каталист 2950 с транком на портах 111....и переводя MTU в 1600 (на каталисте)...

я запутался полностью. Забыл уточнить что клиентскую сторону перевел на обоих коммутаторах в порт 7 (RJ45 где поднят туннель)

Результат пока нулевой

 

коммутаторы пингуют друг друга, шлюз не пингуется 

 

P.S. : шлюз пингуется в одном случае, если создаю 2 порта с описанием вланов (транковые)...в один включаю клиентскую часть а другой заворачиваю петлей в туннель (на первом коммутаторе)

 

Edited by AM_Diagnost

Share this post


Link to post
Share on other sites

Схема заработала при определенных изменениях: 

hostname R1
!
!
mtu 1600
!
!
vlan 1;111;5-100
!
Interface Ethernet1/0/1   ### Подключен к транковому свитчу
 dot1q-tunnel enable
 switchport access vlan 111
!
Interface Ethernet1/0/2   ### Подключен к транспортной сети
 dot1q-tunnel tpid 0x9100
 switchport mode trunk
!
Interface Ethernet1/0/3
 switchport mode trunk
 switchport trunk allowed vlan 1;5-100
!
Interface Ethernet1/0/4
 switchport mode trunk
 switchport trunk allowed vlan 1;5-100
!
Interface Ethernet1/0/5
!
Interface Ethernet1/0/6
!
Interface Ethernet1/0/7
!
Interface Ethernet1/0/8
!
Interface Ethernet1/0/9
!
Interface Ethernet1/0/10
!
interface Vlan1
 description SW_Management
 ip address 192.168.1.15 255.255.255.0
!
ip default-gateway 192.168.1.1
!
ntp enable
ntp server 192.168.1.1
!
!
no login
!
captive-portal
!
end
 

 

hostname R2
!
mtu 1600
!
!
vlan 1;5-100;111
!
Interface Ethernet1/0/1   ### Туннель завернут в порт Ethernet1/0/3
 dot1q-tunnel enable
 switchport access vlan 111
!
Interface Ethernet1/0/2   ### Подключен к транспортной сети
 dot1q-tunnel tpid 0x9100
 switchport mode trunk
!
Interface Ethernet1/0/3   ### Транк завернут на получение с порта Ethernet1/0/1
 switchport mode trunk
!
Interface Ethernet1/0/4   ### Клиент в сети Vlan 5
 switchport access vlan 5
!
Interface Ethernet1/0/5
!
Interface Ethernet1/0/6
!
Interface Ethernet1/0/7
!
Interface Ethernet1/0/8
!
Interface Ethernet1/0/9
!
Interface Ethernet1/0/10
!
interface Vlan1
 description SW_Management
 ip address 192.168.1.16 255.255.255.0
!
ip default-gateway 192.168.1.1
!
ntp enable
ntp server 192.168.1.1
!
!
no login
!
captive-portal
!
end

Edited by AM_Diagnost

Share this post


Link to post
Share on other sites

Дополнение: в транспортной сети MTU поднят до 1600.

Пакеты не стабильные пинги пропадают.

Возможно из-за величины mtu на туннельных коммутаторах??? Подскажите как получить стабильность!

 

#s ver
  SNR-S2985G-8T Device, Compiled on Mar 06 10:22:11 2018
  sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
  CPU Mac f8:f0:82:77:a0:9f
  Vlan MAC f8:f0:82:77:a0:9e
  SoftWare Version 7.0.3.5(R0241.0223)
  BootRom Version 7.2.33
  HardWare Version 1.1.2
  CPLD Version N/A
  Serial No.:SW070911H528001690
  Copyright (C) 2018 NAG LLC
  All rights reserved
  Last reboot is cold reset.
  Uptime is 0 weeks, 0 days, 1 hours, 7 minutes
 

Share this post


Link to post
Share on other sites

SNR-S2985G-8T#s ver
  SNR-S2985G-8T Device, Compiled on Jul 23 14:50:52 2018
  sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
  CPU Mac f8:f0:82:77:a0:9f
  Vlan MAC f8:f0:82:77:a0:9e
  SoftWare Version 7.0.3.5(R0241.0264)
  BootRom Version 7.2.33
  HardWare Version 1.1.2
  CPLD Version N/A
  Serial No.:SW070911H528001690
  Copyright (C) 2018 NAG LLC
  All rights reserved
  Last reboot is warm reset.
  Uptime is 0 weeks, 0 days, 0 hours, 1 minutes

 

Обновил прошивку, даже пробовал вместо транспортной сети просто втыкать патчкорд. Результат нулевой, интернет и сеть вроде есть но пинги страшно сыпятся и прерываются. ПОМОГИТЕ!

 

 

R2#                                                                                               s loop
Loopback Detection Global Information
Transmit Interval    : 5s(loopback mode), 3s(no loopback mode)
Control Recover Time : 0
Loopback Detection Port Information
PortName            Loopback Detection            Control Mode   Is Controlled  Happen times
Ethernet1/0/1       Enable                        Block          No             0
Ethernet1/0/2       Enable                        Block          No             0
Ethernet1/0/3       Disable                       No             No             0
Ethernet1/0/4       Disable                       No             No             0
Ethernet1/0/5       Disable                       No             No             0
Ethernet1/0/6       Disable                       No             No             0
Ethernet1/0/7       Disable                       No             No             0
Ethernet1/0/8       Disable                       No             No             0
Ethernet1/0/9       Disable                       No             No             0
Ethernet1/0/10      Disable                       No             No             0
R2#%Jan 01 04:52:53 2006 Port Ethernet1/0/1 vlan 111 is a loopback device......как избавиться от петли влана 111

Edited by AM_Diagnost
не могу добавить ответ

Share this post


Link to post
Share on other sites
19 минут назад, AM_Diagnost сказал:

но пинги страшно сыпятся и прерываются. ПОМОГИТЕ!

Может, вы петлю бродкастовую замутили? Посмотрите на счетчики пакетов на интерфейсах, утилизацию CPU коммутаторов и т.д

Share this post


Link to post
Share on other sites

ребята,спасибо за помощь! Реально была петля. но дело в том, что на всех форумах пишут что для снятия тэгов требуется второй коммутатор или физическая петля с транкового порта в аццессовый. Как установил второй коммутатор вместо петли всё заработало. Как оставить петлю на принимающем коммутаторе, чтобы избежать сообщений типа %Jan 01 09:20:24 2006 Port Ethernet1/0/1 vlan 111 is a loopback device.

 

Про физические петли брал пример со статьи : http://www.hilik.org.ua/экономная-схема-построения-qinq/

Там стоится на циско и применяются команды спаннинг три. Может есть аналоги для SNR?

 

Порт Gi1/0/2:

interface GigabitEthernet1/0/2
description QinQLoopTrunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 11-13
switchport mode trunk
duplex full


Порт Gi1/0/3:

interface GigabitEthernet1/0/3
description Q-IN-Q 
switchport access vlan 10
switchport mode dot1q-tunnel
switchport nonegotiate
no mdix auto
no cdp enable
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!

 

 

Спасибо за помощь!

Share this post


Link to post
Share on other sites

Сможет кто подсказать как растэгировать пакеты не используя второй коммутатор (клиентский)?

Share this post


Link to post
Share on other sites

SNR в моих руках относительно недавно и поэтому в процессе конфигурации всплывают некоторые нюансы, отличительные от Cisco sistems.

Например: туннель по вышеописанной схеме заработал замечательно (с учетом того что стоят дополнительно клиентские коммутаторы).

пара SNR, образующая туннель пингует друг друга, но не видит шлюз расположенный у клиента...Т.е. управляющий влан не доступен, нет доступа из сети клиента к коммутаторам (с обоих сторон)...Остальные адреса влана доступны.

Видимо придется строить selectiv q-in-q, т.к. технология туннеля в SNR не совершенна, что приводит либо к отсутствию доступа к коммутаторам в туннеле, либо к появлению петель.

 

Буду признателен вам за любой совет! Спасибо!

Share this post


Link to post
Share on other sites

Добрый день. 

Снять\добавить 2 тега на одном порту нельзя, поэтому, если нужно получить на входе\выходе нетегированный трафик, нужно использовать петлю из-за 2х портов, либо добавлять тэг на другом устройстве.

На портах в режиме trunk по-умолчанию разрешен vlan 1 в качестве native, что в схеме с использованием петли теоретически может привести к петле коммутации,  т.к. нетегированный трафик в QinQ принимается во vlan 111. Рекомендую либо создать и разрешить "пустой" vlan на таких портах, либо применить команду "switchport discard packet untag".

В вашей схеме не совсем ясно, клиент подключенный к какому порту должен иметь доступ к коммутатору. Судя по приложенной ранее конфигурации, в сторону клиентов не выдан VLAN 1. Или клиент, подключенный к коммутатору 1, должен управлять коммутатором 2?

Share this post


Link to post
Share on other sites
On 8/20/2018 at 12:00 PM, Ivan Tarasenko said:

Добрый день. 

Снять\добавить 2 тега на одном порту нельзя

А вот есть какое-то разумное объяснение этому? В плане почему бы не сделать такое и выделиться среди серой массы. Ведь это всего лишь нужно программисту чуточку поработать. Ну с моей колокольни по крайней мере.

Share this post


Link to post
Share on other sites

Поскольку это будет работать на скорости порта - это должно уметь железо, а не программа.

Не умеет, наверное.

Share this post


Link to post
Share on other sites

Там ASICи или FPGU работают в любом случае, работают по программе. Аксес листы матчить, CoS, виланы и прочее им ничто не мешает же.

Share this post


Link to post
Share on other sites

@ShyLion, используется ASIC, который предоставляет ограниченную функциональность. Программно расширить функционал можно лишь средствами CPU.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now