Jump to content
Калькуляторы

dmvpn + eigrp static neighbor

Всем привет, подскажите, как настроить в eigrp neighbor статично в связке с dmvpn? или в dmvpn так не делают?

Share this post


Link to post
Share on other sites

А зачем? Или же там есть два разных провайдера и надо сделать статику через одного их них?

Share this post


Link to post
Share on other sites
1 минуту назад, kapydan сказал:

А зачем? Или же там есть два разных провайдера и надо сделать статику через одного их них?

не, я просто сталкивался с тем что провайдер блочил все рассылки динамических протоколов и я прописывал в секции eigrp указание соседа через нужный интерфейс, а в dmvpn нужного интерфейса нет, так как он его поднимает автоматически, видно я сам ответил)

Share this post


Link to post
Share on other sites

и еще такой вопрос

построена сеть dmvpn между 4-мя хостами, поверх eigrp, когда прописываю через route map принимать сети удаленных и отправлять только свою, то в итоге hub пингует всех, а остальные сеть хаба нет

 

т.е. если так, то spoke не пингает сеть 172.18.120.0/30

Цитата


ip prefix-list PL-EIGRP-OUT seq 1 permit 172.18.120.0/30

 

а вот так работает

 

Цитата

ip prefix-list PL-EIGRP-OUT seq 1 permit 172.18.120.0/30
ip prefix-list PL-EIGRP-OUT seq 2 permit 10.147.199.0/30
ip prefix-list PL-EIGRP-OUT seq 3 permit 10.147.199.4/30
ip prefix-list PL-EIGRP-OUT seq 4 permit 10.147.199.8/30

 

 

HUB

interface Tunnel1
 bandwidth 102400
 ip address 10.0.10.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip nhrp holdtime 400
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet1/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface Tunnel2
 bandwidth 2048
 ip address 10.0.20.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp network-id 2
 ip nhrp holdtime 400
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet2/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface FastEthernet0/1
 description LAN
 ip address 172.18.120.1 255.255.255.252
 ip nat inside
 speed auto
 duplex auto
!
interface GigabitEthernet1/0
 ip address 192.168.103.2 255.255.255.248
 ip nat outside
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 192.168.105.2 255.255.255.248
 ip nat outside
 negotiation auto
!
!
router eigrp 54
 distribute-list route-map RM-EIGRP-OUT out
 distribute-list route-map RM-EIGRP-IN in
 network 10.0.10.0 0.0.0.255
 network 10.0.20.0 0.0.0.255
 network 172.18.120.0 0.0.0.3
 passive-interface default
 no passive-interface Tunnel1
 no passive-interface Tunnel2
 no passive-interface FastEthernet0/1
!
!
!
ip prefix-list PL-EIGRP-IN seq 1 permit 10.147.199.0/30
ip prefix-list PL-EIGRP-IN seq 2 permit 10.147.199.4/30
ip prefix-list PL-EIGRP-IN seq 3 permit 10.147.199.8/30
!
ip prefix-list PL-EIGRP-OUT seq 1 permit 172.18.120.0/30
ip prefix-list PL-EIGRP-OUT seq 2 permit 10.147.199.0/30
ip prefix-list PL-EIGRP-OUT seq 3 permit 10.147.199.4/30
ip prefix-list PL-EIGRP-OUT seq 4 permit 10.147.199.8/30
!
route-map RM-EIGRP-OUT permit 10
 match ip address prefix-list PL-EIGRP-OUT
!
route-map RM-EIGRP-IN permit 10
 match ip address prefix-list PL-EIGRP-IN

SPOKE-1

interface Tunnel1
 bandwidth 102400
 ip address 10.0.10.2 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp map 10.0.10.1 192.168.103.2
 ip nhrp map multicast 192.168.103.2
 ip nhrp network-id 1
 ip nhrp holdtime 400
 ip nhrp nhs 10.0.10.1
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet1/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface Tunnel2
 bandwidth 2048
 ip address 10.0.20.2 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp map 10.0.20.1 192.168.105.2
 ip nhrp map multicast 192.168.105.2
 ip nhrp network-id 2
 ip nhrp holdtime 400
 ip nhrp nhs 10.0.20.1
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet2/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface FastEthernet0/0
 description SERVER
 ip address 10.147.199.1 255.255.255.252
 duplex full
!
interface GigabitEthernet1/0
 ip address 192.168.103.10 255.255.255.248
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 192.168.105.10 255.255.255.248
 negotiation auto
!
!
router eigrp 54
 distribute-list route-map RM-EIGRP-OUT out
 distribute-list route-map RM-EIGRP-IN in
 network 10.0.10.0 0.0.0.255
 network 10.0.20.0 0.0.0.255
 network 10.147.199.0 0.0.0.3
 passive-interface default
 no passive-interface Tunnel1
 no passive-interface Tunnel2
 no passive-interface FastEthernet0/0
!
ip forward-protocol nd
!
!
!
ip prefix-list PL-EIGRP-IN seq 1 permit 172.18.120.0/30
ip prefix-list PL-EIGRP-IN seq 2 permit 10.147.199.4/30
ip prefix-list PL-EIGRP-IN seq 3 permit 10.147.199.8/30
!
ip prefix-list PL-EIGRP-OUT seq 1 permit 10.147.199.0/30
!
route-map RM-EIGRP-OUT permit 10
 match ip address prefix-list PL-EIGRP-OUT
!
route-map RM-EIGRP-IN permit 10
 match ip address prefix-list PL-EIGRP-IN

SPOKE-2

interface Tunnel1
 bandwidth 102400
 ip address 10.0.10.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp map 10.0.10.1 192.168.103.2
 ip nhrp map multicast 192.168.103.2
 ip nhrp network-id 1
 ip nhrp holdtime 400
 ip nhrp nhs 10.0.10.1
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet1/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface Tunnel2
 bandwidth 2048
 ip address 10.0.20.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp map 10.0.20.1 192.168.105.2
 ip nhrp map multicast 192.168.105.2
 ip nhrp network-id 2
 ip nhrp holdtime 400
 ip nhrp nhs 10.0.20.1
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet2/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface FastEthernet0/0
 description SERVER
 ip address 10.147.199.5 255.255.255.252
 duplex full
!
interface GigabitEthernet1/0
 ip address 192.168.103.18 255.255.255.248
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 192.168.105.18 255.255.255.248
 negotiation auto
!
!
router eigrp 54
 distribute-list route-map RM-EIGRP-OUT out
 distribute-list route-map RM-EIGRP-IN in
 network 10.0.10.0 0.0.0.255
 network 10.0.20.0 0.0.0.255
 network 10.147.199.4 0.0.0.3
 passive-interface default
 no passive-interface Tunnel1
 no passive-interface Tunnel2
 no passive-interface FastEthernet0/0
!
ip forward-protocol nd
!
!
ip prefix-list PL-EIGRP-IN seq 1 permit 172.18.120.0/30
ip prefix-list PL-EIGRP-IN seq 2 permit 10.147.199.0/30
ip prefix-list PL-EIGRP-IN seq 3 permit 10.147.199.8/30
!
ip prefix-list PL-EIGRP-OUT seq 1 permit 10.147.199.4/30
!
route-map RM-EIGRP-OUT permit 10
 match ip address prefix-list PL-EIGRP-OUT
!
route-map RM-EIGRP-IN permit 10
 match ip address prefix-list PL-EIGRP-IN

SPOKE-3

interface Tunnel1
 bandwidth 102400
 ip address 10.0.10.4 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp map 10.0.10.1 192.168.103.2
 ip nhrp map multicast 192.168.103.2
 ip nhrp network-id 1
 ip nhrp holdtime 400
 ip nhrp nhs 10.0.10.1
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface Tunnel2
 bandwidth 2048
 ip address 10.0.20.4 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 54
 no ip split-horizon eigrp 54
 ip nhrp authentication nhrp-key
 ip nhrp map multicast dynamic
 ip nhrp map 10.0.20.1 192.168.105.2
 ip nhrp map multicast 192.168.105.2
 ip nhrp network-id 2
 ip nhrp holdtime 400
 ip nhrp nhs 10.0.20.1
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet1/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile P-DMVPN
!
interface GigabitEthernet0/0
 ip address 192.168.103.26 255.255.255.248
 media-type gbic
 speed 1000
 duplex full
 negotiation auto
!
interface GigabitEthernet1/0
 ip address 192.168.105.26 255.255.255.248
 negotiation auto
!
!
router eigrp 54
 distribute-list route-map RM-EIGRP-OUT out
 distribute-list route-map RM-EIGRP-IN in
 network 10.0.10.0 0.0.0.255
 network 10.0.20.0 0.0.0.255
 network 10.147.199.8 0.0.0.3
 passive-interface default
 no passive-interface Tunnel1
 no passive-interface Tunnel2
 no passive-interface Loopback0
!
ip forward-protocol nd
!
!
!
!
ip prefix-list PL-EIGRP-IN seq 1 permit 172.18.120.0/30
ip prefix-list PL-EIGRP-IN seq 2 permit 10.147.199.0/30
ip prefix-list PL-EIGRP-IN seq 3 permit 10.147.199.4/30
!
ip prefix-list PL-EIGRP-OUT seq 1 permit 10.147.199.8/30
!
route-map RM-EIGRP-OUT permit 10
 match ip address prefix-list PL-EIGRP-OUT
!
route-map RM-EIGRP-IN permit 10
 match ip address prefix-list PL-EIGRP-IN

 

 

6 минут назад, kapydan сказал:

со стороны хаба не получится по идее.

да, я заметил что создаются виртуальные интерфейсы и поэтому я думаю нет возможности указать соседа, да и вероятно смысла нет, gre пускает мультикаст

Share this post


Link to post
Share on other sites
On 8/13/2018 at 8:45 PM, fractal said:

прописываю через route map принимать сети удаленных и отправлять только свою

Так не делают, это мартышкин труд.

 

На споках делают:

router eigrp xxx
 eigrp stub connected
!

На хабе делают summary:

interface TunnelXXXX
 ip summary-address eigrp xxx 10.0.0.0 255.0.0.0
 ip summary-address eigrp xxx 192.168.0.0 255.255.0.0
 ip summary-address eigrp xxx 172.16.0.0 255.240.0.0
!

Таким образом все сильно упрощается. При этом остается возможность использовать leak-map и на хабах и на споках, для особых случаев.

 

Share this post


Link to post
Share on other sites

А почему на хабе нет возможности указать соседа? Там же не только инт, но и ИП указывается?

Share this post


Link to post
Share on other sites
5 минут назад, zhenya` сказал:

router eigrp 100
neighbor x.y.z.v tunnel10

И сразу все отвалится

Share this post


Link to post
Share on other sites
3 часа назад, fractal сказал:

И сразу все отвалится

Ну дык надо везде будет прописать. Тогда будет хорошо.

 

в целом выше были правильные идеи, читайте пост ShyLion.

Share this post


Link to post
Share on other sites
3 часа назад, zhenya` сказал:

Ну дык надо везде будет прописать. Тогда будет хорошо.

 

в целом выше были правильные идеи, читайте пост ShyLion.

вообщем нифига, везде прописал, соседство отвалилось.... по комменту "Читайте пост", все ходит через хаб, не гут, отказались от этой идее

Share this post


Link to post
Share on other sites
14 hours ago, fractal said:

по комменту "Читайте пост", все ходит через хаб, не гут, отказались от этой идее

Споки могут и друг с другом напрямую работать и опять-же с eigrp stub connected будут сливать друг-другу прямые маршруты, имея при этом запасной саммари с хаба.

Хаб, конечно, должен быть там, где максимальная концентрация общих ресурсов.

Обычно филиалам крупной конторы нечего передавать друг-другу напрямую, кроме RTP траффика телефонии.

Share this post


Link to post
Share on other sites

 eigrp stub connected помогает увеличить время сходимости и это не ломает идею фулмеша.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now