Перейти к содержимому
Калькуляторы

Проблемы с исходящим трафиком.

День добрый, каляки-маляки во вложении, ну и коротко о проблеме :)

Поступила жалоба, на низкую фактическую исходящую скорость, т.е. спидтест показывает все отлично, а ролики на ютуб или файл на фтп, с мобильного интернета улетают быстрее, чем с нашего. Начинает бодро и тут же падает до 2 мбит.

Убрал sce, шейперы на nas'е, все правила фаервола - 2мбита и все.

Воткнулся напрямую в nas, поднял pppoe (у клиентов никаких туннелей нет) - все отлично.

В общем проблема с коммутатором для серверов, тот, что 2990.

Втыкаю патчкорд с ядра напрямую в nas (пунктиром на схеме) - все здорово, абонент доволен, я в непонятках.

 

Я понимаю, что этот коммутатор не для этих нужд, но у нас трафика слёзы:

самый загруженый порт на коммутаторе это 500/100 мбит, cpu 10-12%, память свободна, таблица маков пустая. С доступом к серверам в 160 влане вообще никаких проблем, т.е. порты на ядре и 2990 исправны, патчкорд исправен.

 

Что это, блджд, было?

IMG_20180810_174949.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Для начала может быть Flow control посмотреть и выключить?

Дальше, бондинг (агрегация линков) нигде не используется? Там бывают нехорошие режимы которые приводят к доставке не в том порядке в котором отправлено, и будут убивать скорость.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 минут назад, rm_ сказал:

Для начала может быть Flow control посмотреть и выключить?

Дальше, бондинг (агрегация линков) нигде не используется? Там бывают нехорошие режимы которые приводят к доставке не в том порядке в котором отправлено, и будут убивать скорость.

флоу контрол выключен везде, бондинг не используем. Из "высоких" технологий на этом коммутаторе только MVR. Мультикаст я на время проверок тоже тушил, лучше не стало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Версия прошивки ещё какая?
и нет ли по порам ошибок/дропов?

 

ещё на всякий sh run | i mtu

 

у меня тут тоже интересная проблемка с мту нарисовалась.. отложил дебаг на после отпуска

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

QinQ на сети нигде не используется?

У меня была похожая проблема на IPoE сегменте, виновником был MTU.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня вот симптомы.. PPPoE... пара коммутаторов уехало со стенда, где игрался  с МТУ...

При том что на всём остальном пути, включая  со стороны абонента мту было 1500.. были проблемы с характерными симптомами:speedtest не догружался/рвася в рандомное время,низкие скорости и так далее. Сбросил мту в дефолт -все проблемы исчезли. Хотя повторю со стороны клиентов стояло также 1500..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 часа назад, stalker86 сказал:

Версия прошивки ещё какая?

SoftWare Version 7.0.3.5(R0102.0089)

 

4 часа назад, stalker86 сказал:

и нет ли по порам ошибок/дропов?

ни единого разрыва

4 часа назад, stalker86 сказал:

ещё на всякий sh run | i mtu

пусто, мту явно в конфиге не указан

 

 

dns:~# ping -M do -s 1500 ya.ru
PING ya.ru (87.250.250.242) 1500(1528) bytes of data.
ping: local error: Message too long, mtu=1500
 

Ну как бэ усё понятно.

 

Всем спасибо за наводку.

 

 

Изменено пользователем m9ic

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас