Перейти к содержимому
Калькуляторы

Динамическая маршрутизация поверх l3 vpn

Есть 3 точки в разных городах в каждом свой сервер, в каждом городе по два провайдера дают l3 vpn для связи этих точек,

1. на первую точку первый провайдер дает ip 10.10.10.2/30, второй провайдер дает ip 10.10.20.2/30

2. на вторую точку первый провайдер дает дает ip 10.10.10.6/30, второй провайдер дает ip 10.10.20.6/30

3. на третью точку первый провайдер дает ip 10.10.10.10/30. Второй провайдер дает 10.10.20.10/30

 

Между всеми подсетями статика:

1-я точка:

10.10.10.4 255.255.255.252 10.10.10.1

10.10.10.8 255.255.255.252 10.10.10.1

10.10.20.4 255.255.255.252 10.10.20.1

10.10.20.8 255.255.255.252 10.10.20.1

 

2-я точка:

10.10.10.0 255.255.255.252 10.10.10.5

10.10.10.8 255.255.255.252 10.10.10.5

10.10.20.0 255.255.255.252 10.10.20.5

10.10.20.8 255.255.255.252 10.10.20.5

 

3-я точка:

10.10.10.0 255.255.255.252 10.10.10.9

10.10.10.4 255.255.255.252 10.10.10.9

10.10.20.0 255.255.255.252 10.10.20.9

10.10.20.4 255.255.255.252 10.10.20.9

 

Ну и дальше через них статик роуты до серваков.

 

Может лучше сделать динамическую маршрутизацию и сделать резервирование на основе нее?

 

В организацию только пришел, роуты до серваков если ломается канал меняют руками, холодный резерв вообщем, вот и думаю либо динамику, либо через ip sla

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А оборудование - сферическое в вакууме?

Энтерпрайз обычно ставит роутеры, строит туннели и поднимает OSPF, EIGRP, RIP и т.д. у кого на что денег/фантазии хватает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 минуту назад, ShyLion сказал:

А оборудование - сферическое в вакууме?

Не понял вопроса

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Каналы прямо в серверы воткнуты? Какая ОСь? Требования к MTU? Возможности по MTU у провайдеров?

 

Виртуализация используется?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Каналы от провайдеров в коммутаторы циско, все терминируется на маршрутизаторах циско, серваки тоже в коммутаторы, цель резервирование между 2мя провайдерами предоставляющими l3vpn

Изменено пользователем fractal

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
4 minutes ago, fractal said:

все терминируется на маршрутизаторах циско

Сам ТНБ велел построить туннели и поднять EIGRP.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 часа назад, ShyLion сказал:

Сам ТНБ велел построить туннели и поднять EIGRP.

Статику на всех оставляем и строим на каждом по 4 туннеля и поверх туннелей eigrp?

 

а нельзя статику совсем убрать? и сделать все на eigrp?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

статика нужна будет только для указания куда роутить обратный конец туннеля, раз они в разных подсетях. это нормально.

т.е.


interface Tunnel001002
 ip address 10.0.0.1 255.255.255.252.0
 tunnel source 172.16.0.1
 tunnel destination 172.16.2.2
!
interface Fas0/0
 descr VPN1
 ip address 172.16.0.1 255.255.255.0
!
interface Fas0/1
 descr Servers
 ip address 10.0.1.1 255.255.255.0
!
ip route 172.16.2.0 255.255.255.252 172.16.0.2
!
router eigrp 1
 passive-interface default
 no passive interface Tunnel001002
 network 10.0.0.0 0.255.255.255
 ip eigrp stub connected
!

На другом онце зеркально по смыслу.

 

ЗЫ: Вообще все это должен знать и уметь цискун. Или у вас нету?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 минуту назад, ShyLion сказал:

статика нужна будет только для указания куда роутить обратный конец туннеля, раз они в разных подсетях. это нормально.

т.е.



interface Tunnel001002
 ip address 10.0.0.1 255.255.255.252.0
 tunnel source 172.16.0.1
 tunnel destination 172.16.2.2
!
interface Fas0/0
 descr VPN1
 ip address 172.16.0.1 255.255.255.0
!
interface Fas0/1
 descr Servers
 ip address 10.0.1.1 255.255.255.0
!
ip route 172.16.2.0 255.255.255.252 172.16.0.2
!
router eigrp 1
 passive-interface default
 no passive interface Tunnel001002
 network 10.0.0.0 0.255.255.255
 ip eigrp stub connected
!

На другом онце зеркально по смыслу.

 

ЗЫ: Вообще все это должен знать и уметь цискун. Или у вас нету?

через туннели то в курсе как настроить, думал есть опция в eigrp которая указывает что трафик в эту сеть пересылать на такой то хоп, чтобы не городить туннелей, ну в таком случае сделаю dmvpn и поверх eigrp ну или шевельну провайдера чтобы он выдал одну подсеть на все города дабы не городить статик роутов

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Чтобы не городить тунели вам надо поднять динамическую маршрутизацию между вашим роутером и PE-маршрутизаторами провайдеров.

 

Изменено пользователем CityFox

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну кстати BGP или OSPF для провайдерских сетей тоже вариант, хотя настроек и точек отказа в итоге будет на порядок больше чем четыре ip route прописать :)

Короче проблема ваша из ничего, по большому счету.

Ну и для трех узлов DMVPN тоже лишние точки отказа.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, ShyLion сказал:

Ну кстати BGP или OSPF для провайдерских сетей тоже вариант, хотя настроек и точек отказа в итоге будет на порядок больше чем четыре ip route прописать :)

Короче проблема ваша из ничего, по большому счету.

Проблемы нет,провайдер сделал одну сеть, перешли на eigrp

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

тогда это не L3VPN, а L2VPN :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, ShyLion сказал:

тогда это не L3VPN, а L2VPN :)

По бз l3,а как уже настроено у провайдера мне без разницы) главное цель достигнута

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Соседей юникастом не прописвали? Бывает что мультик не ходит в l2vpn, или ходит в одну строну. Для неподготовленных может быть сюрпризом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, ShyLion сказал:

Соседей юникастом не прописвали? Бывает что мультик не ходит в l2vpn, или ходит в одну строну. Для неподготовленных может быть сюрпризом.

Я сразу прописал соседа в интерфейс в процессе eigrp

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
17 часов назад, ShyLion сказал:

Ну кстати BGP или OSPF для провайдерских сетей тоже вариант, хотя настроек и точек отказа в итоге будет на порядок больше чем четыре ip route прописать :)

Короче проблема ваша из ничего, по большому счету.

Ну и для трех узлов DMVPN тоже лишние точки отказа.

откуда при бгп "на порядок" больше точек отказа? в случае iBGP один раз настроить и забыть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 hours ago, myst said:

откуда при бгп "на порядок" больше точек отказа? в случае iBGP один раз настроить и забыть.

По сравнению со статическими роутами для концов тоннеля, любая динамика "на порядок больше" тупо потому что начинают _дополнительно_ работать всякие процессы, зависящие как от абонента так и от оператора.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 7/6/2018 в 13:42, ShyLion сказал:

По сравнению со статическими роутами для концов тоннеля, любая динамика "на порядок больше" тупо потому что начинают _дополнительно_ работать всякие процессы, зависящие как от абонента так и от оператора.

так поверх тунелей же. а там уже никаких операторов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас