Перейти к содержимому
Калькуляторы

Не монтируется iscsi на RedHat 4

Есть старый сервер с RedHat4, к которому подмонтирован по iSCSI сетевой том.

В iscsi-ls соединение есть.

В fdisk -l раздел виден:

# fdisk -l

Disk /dev/sda: 898.3 GB, 898319253504 bytes
255 heads, 63 sectors/track, 109214 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14      109214   877157032+  8e  Linux LVM

Disk /dev/sdc: 2199.0 GB, 2199023255552 bytes
255 heads, 63 sectors/track, 267349 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1      267349  2147480811   83  Linux

Disk /dev/dm-2: 2199.0 GB, 2199023255552 bytes
255 heads, 63 sectors/track, 267349 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

     Device Boot      Start         End      Blocks   Id  System
/dev/dm-2p1               1      267349  2147480811   83  Linux

Disk /dev/dm-3: 2199.0 GB, 2199020350464 bytes
255 heads, 63 sectors/track, 267348 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/dm-3 doesn't contain a valid partition table

Долгое время все работало нормально, но вчера сервер пришлось перегрузить.

После перезагрузки iscsi-том почему-то не подмонтировался.

При монтировании выдает: mount: /dev/sdc1 already mounted or /extra/net busy

(sdc1 это сам том, /extra/net это каталог, в который он монтируется)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ну так надо проверять 1) подмонтирован ли  /dev/sdc1 куда-то 2) занят ли каталог /extra/net
так что
1) смотрите mount  и "lsof | grep  /extra/net" , хотя я бы использовал вместо mount lsblk, если есть такая утилита
2) попробуйте создать новый каталог и подмонтировать /dev/sdc1 туда

Изучайте логи на предмет дополнительных ошибок
Дампите пакеты на сервере iSCSI. Он пингуется?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

/dev/sdc никуда не смонтирован.

/extra/net ничем не занят (по крайней мере в lsof его нет).

СХД доступна, пингуется, iscsi-rescan выполняется успешно, iscsi-ls показывает правильные данные.

Попытка смонтировать в другой каталог дает тот же результат (already mounted or <path> busy).

fdisk /dev/sdc запускается и показывает правильную разметку диска.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сработала такая магия:

# multipath -ll
archive (3600a0980005fb6250000061a57df5e3a)
[size=2048 GB][features="0"][hwhandler="0"]
\_ round-robin 0 [prio=1][enabled]
 \_ 7:0:0:100 sdc 8:32 [active][ready]
\_ round-robin 0 [enabled]
 \_ 5:0:0:100 sdb 8:16 [active][faulty]

# multipath -F

# multipath -ll

# mount -a

(то есть я просто сделал сброс multipath-маршрутов)

 

Все конечно заработало, но все же хотелось бы понять, в чем тут дело, и исключить эту проблему в будущем.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
37 minutes ago, alibek said:

/dev/sdc никуда не смонтирован.

А спрашивали про /dev/sdc1.

Ну а вообще в таких случаях первым делом надо смотреть dmesg.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
3 минуты назад, rm_ сказал:

А спрашивали про /dev/sdc1.

Само собой. И отвечал я про то же.

Я сомневаюсь, что можно примонтировать именно /dev/sdc.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас