Jump to content
Калькуляторы

Периодически появляется петля на микротике, в результате падают PPPoE интерфейсы.

Форумчане. Доброго времени суток вам. Дней десять назад началась интересная трабла. У меня в сети есть одно место(чердак), где установлен   mikrotik rb2011uias-rm, который подключается к интернету и раздаёт оного.  На раздаче задействовано всего три ehernet порта. Работал он прекрасно, это был мой лучший канал интернета. Как вдруг он стал самым худшим – в в логах периодически стало появляться  сообщение - bridge port received packet with own address as source address probably  loop.  Появлялось оно нечасто, а раз в несколько часов, могло и час пройти, а могло и девять, но тем не менее проблема возвращалась, интерфейсы падали иногда на время до двух минут, конечно вызывая во мне ярость. Не долго думая решил заменить  mikrotik rb2011uias-rm, на новый mikrotik rb951ui-2hnd. На нём стояла новая прошивка  v 6.42.2, сразу же расскажу, что при настройке произошли некоторые проблемы. В частности, после удаления начальной конфигурации и настойки с нуля,  я не обнаружил привычного мастер порта и пришлось объединить все интерфейсы в бридж. Настроил с горем пополам, вроде бы заработало и тут упс, проявилась, старая трабла вновь и с той же непредсказуемой периодичностью. Краткая конфигурация интерфейсов: 1 порт WAN, к нему подключается интернет, он не включён в бридж; 2 порт включён в бридж, но на нём нет клиентов; 3 порт включён в бридж, на нём сидит один клиент, у него роутор; 4 порт включён в бридж, к нему подключена точка доступа Ubiquiti NanoStation Loco M2, к которой подключено три клиента; 5 порт включён в бридж, к нему подключена точка доступа  Ubiquiti PowerBeam M2-400, которая раздаёт мостом интернет далее на 20 клиентов.

Как мы видим на скриншоте, часто указывается проблемный интерфейс с маком  e4:8d:8c:ae:3c:f1, это пятый порт рутированный, затем чаще стало появляться сообщение о проблеме интерфейса с маком e4:8d:8c:ae:3c:ee, это второй неиспользуемый интерфейс (я кстати откл. его, но это не помогло). 

                Уважаемые, как думаете в чём может быть проблема? Не может дело быть в новой прошивке? Может быть её даунгрейдить на старую версию, где ещё были мастер порты? У всех пользователей оборудование настроено в режиме роутор, кроме одного пользователя, у него да стоит мыльница на пять портов, но он сидит на 4 порту, где вроде проблем не наблюдалось. Жду ваших предположений.

 loop2.thumb.jpg.53a3a401d1f38f98b82d603f6d3bcce8.jpg

Загруженные изображения

  •  
  •  
 

loop2.jpg

358 kb · Готово

  •  
  •  

 

loop3.jpg

loop4.jpg

Share this post


Link to post
Share on other sites

 Учитывая то, по  логике, что вы кроме прошивки сменили и девайс то  железо в возникновении глюка винить нечего.... Попробуйте на этой прошивке  на бридже прописать Admin  Mac Address ...  Можно и изменить  на нем последние два знака, например  e4:8d:8c:ae:3c:a9  ....

  У меня такое было  полгода назад... Устранил именно пропиской Admin  Mac Address  ...

/interface bridge
set admin-mac=e4:8d:8c:ae:3c:a9 auto-mac=no mtu=1500 name=bridge1 protocol-mode=none

 

Edited by uraso

Share this post


Link to post
Share on other sites
1 час назад, uraso сказал:

У меня такое было  полгода назад... Устранил именно пропиской Admin  Mac Address  ...

/interface bridge
add admin-mac=e4:8d:8c:ae:3c:a9 auto-mac=no mtu=1500 name=bridge1 protocol-mode=none

Тоже мучаюсь такой проблемой, не понятные петли возникают....

Решил попробовать прописать как вы сказали, но поменять мак на существующим бридже  Нужна другая команда /interface bridge set admin-mac=D4:хх:хх:02:F2:хх name=bridge1 auto-mac=no 

хочу заметить последняя опция "auto-mac=no" важна, так как если ее не добавить мак не изменится

Мак установил, посмотрим что будет... 

Edited by HarDik

Share this post


Link to post
Share on other sites

Настраивал мост на двух SXTsq Lite5. Из настроек только бридж из wlan и lan. К lan подключен ноутбук. При переходе ноута в спящий режим тут же в логе появлялась запись о петле. 

Share this post


Link to post
Share on other sites

 

 /interface bridge

set   numbers=0  admin-mac=e4:8d:8c:ae:3c:a9 auto-mac=no mtu=1500 name=bridge1  

 

Или просто  сделайте это через винбокс:  Bridge -> mac addres - скопируйте настоящий , измените, и вставьте в  Admin  Mac Address  и сохраните...

 

Share this post


Link to post
Share on other sites

И не забыть auto-mac=no , иначе смысла в опции не убдет...

Share this post


Link to post
Share on other sites

А зачем всё засовывать в бридж я понимаю лень это двигатель прогресса. Почему нельзя собрать много бриджей на виланах и сигментировать сеть? 

Да конфиг будет большой, но найти проблему будет в разы быстрей. 

Share this post


Link to post
Share on other sites

Короче слушайте братаны! Сейчас я пригляделся в конфиг, а там значит на 3 порту мак e4:8d:8c:21:4d:fb, а на бридже тоже e4:8d:8c:21:4d:fb. Может в этом и есть вся херня? Сейчас буду менять!

Share this post


Link to post
Share on other sites
15 минут назад, LEOLINER сказал:

а там значит на 3 порту мак e4:8d:8c:21:4d:fb, а на бридже тоже e4:8d:8c:21:4d:fb. Может в этом и есть вся херня? Сейчас буду менять!

Все нормально, так и должно быть, мост берет MAC с одного из портов (designated).

 

А источник вашей проблемы с 90% вероятностью - 

В ‎02‎.‎06‎.‎2018 в 19:54, LEOLINER сказал:

 Ubiquiti PowerBeam M2-400

В последнее время прямо поток заявок, и везде одно и тоже - девайсы Ubiquity и "bridge port received packet with own address as source address probably  loop". Похоже, в каких-то прошивках там стал "протекать" внутренний коммутатор. Решение везде было одно - над точками проделывается reset, update, reprovision 

Edited by jffulcrum

Share this post


Link to post
Share on other sites
9 часов назад, jffulcrum сказал:

А источник вашей проблемы с 90% вероятностью - 

В 02.06.2018 в 19:54, LEOLINER сказал:

 Ubiquiti PowerBeam M2-400

Вполне может быть и эта проблема.... Я помню еще то, что Admin Mac Address   выставлял не только на главном  микротике, но и на остальных , промежуточных RB, которые распределяли  трафик по базовым станциям. Пробуйте последовательно , с анализом результатов, все методы  устранения неисправности. И обязательно отпишитесь в конце.

Share this post


Link to post
Share on other sites

+ что это из за powerbeam... Установил админ мак, не помогло..

Имею powerbeam m5-400 и проскакивает несколько раз в сутки петля на одном из бриджей... у меня были мысли по поводу проблемы сj стороны бимов, но уверенность на было..

Видимо все так это они....

Может просто какая версия прошивки глючная??

Самое отвратное что узел удаленный, что исключает простой сброс и т.д.

Edited by HarDik

Share this post


Link to post
Share on other sites
5 часов назад, HarDik сказал:

узел удаленный, что исключает простой сброс и т.д.

По SSH на точку с роутера, дальше set-default , потом upgrade (хотя я бы лучше локальное обновление делал) , потом set-inform . Надеюсь, резервацию DHCP для точки предшественники сделать догадались.

Share this post


Link to post
Share on other sites
В 03.06.2018 в 13:58, HarDik сказал:

И не забыть auto-mac=no , иначе смысла в опции не убдет...

Всё конец! Всё сделал по вашим советам, уже как сутки без петель, работает нормально как и прежде. Всё таки дело было не в PowerBeam, хотя у них постоянно бывают глюки, я считаю что PowerBeam это самая глючная железяка из всего семейства Ubiquiti. Вот у меня в сети четыре PowerBeam, и один из них постоянно процессор 100 % загружен, перезагрузка решает проблему, но не надолго. может прошивку обновить? Ладно, всем спасибо кто оказал содействие.

Share this post


Link to post
Share on other sites
21 час назад, LEOLINER сказал:

может прошивку обновить?

что сейчас прошито?

Share this post


Link to post
Share on other sites

На микротиках "bridge port received packet with own address as source address probably loop" иногда возникает, если включен DHCP клиент. При первичной настройке надо всегда сбрасывать дефолтные настройки.

Share this post


Link to post
Share on other sites

Только сбрасывать их надо через командную строку или пункт меню, где указывается сброс без начальной конфигурации. Нажатие R при первом включении не всегда удаляет все настройки, часто как раз DHCP Client и остается.

Share this post


Link to post
Share on other sites

ТС я понять не могу зачем тебе бриджи для PPPoE? ИМХО бред вместо 3-4 PPPoE серверов на микротике собирать говно бридж и вешать один pppoe сервер(ну наверное так меньше настроек? Пусть всё говно лазит через CPU и так слабый.

Перед Микротиком должен стоять свич(любой за 10-15к), чтобы через ацл пропускать только pppoe пакеты микротик так делать не умеет. 

 

Если тебе нужно L2 связанность между абонентами собирай в отельном вилане всё это котлеты отдельно, мухи отдельно . 

Share this post


Link to post
Share on other sites

При PPPoE и так будет связанность между абонентами, если трафик не блокировать. Если на доступе тоже микротик - то порезать все лишнее можно на нем. В последних прошивках если на бридже нет правил - то данные проходят раза в 2 быстрей.

Share this post


Link to post
Share on other sites
9 часов назад, Saab95 сказал:

Если на доступе тоже микротик - то порезать все лишнее можно на нем.

Пример?

Share this post


Link to post
Share on other sites

Фильтры бриджа, если про PPPoE разговор.

 

/interface bridge filter
add action=accept chain=forward in-bridge=bridge1 in-interface=ether1 mac-protocol=pppoe-discovery out-bridge=bridge1
add action=accept chain=forward in-bridge=bridge1 in-interface=ether1 mac-protocol=pppoe out-bridge=bridge1
add action=drop chain=forward in-bridge=bridge1 in-interface=ether1 out-bridge=bridge1

 

Share this post


Link to post
Share on other sites
Цитата

/interface bridge filter
add action=accept chain=forward in-bridge=bridge1 in-interface=ether1 mac-protocol=pppoe-discovery out-bridge=bridge1
add action=accept chain=forward in-bridge=bridge1 in-interface=ether1 mac-protocol=pppoe out-bridge=bridge1
add action=drop chain=forward in-bridge=bridge1 in-interface=ether1 out-bridge=bridge1

Ок, только не делать этого на самой АП - это ее если и не убьет то покалечит изрядно по производительности.

 

ТС`у-сегментируйте сеть и уберите пожалуй бриджи и повесьте pppoe-server на отдельные vlan (мы используем, например схему vlan на базу). Из личного, старайтесь не использовать бриджи от слова совсем. В данный момент мы мягко говоря стараемся переделать сеть из схемы vlan управления (с кучей бриджей и как следствие незабываемый траблшутинг в случае петель) на управление по IPv6 c ограничениями доступа. Получается криво из-за недоделок в прошивках Mikrotik.

 

Share this post


Link to post
Share on other sites

Что вы подразумеваете под АП? Если имеете в виду AP - точка доступа! То скажу вам, что PPPoE сервера у меня стоят на отдельных коробочках - RB-750,RB951ui-2hnd, RB-2011. А в качестве AP используется ubiquiti bullet, rocket. У меня по воздуху всего 23 клиента, а остальные 60 клиентов - это ЛВС на витой паре. И да у меня ничего не сегментированно, все в одной куче. В сети стоят неуправляеммые свичи, но работает нормально. Но что бы избежать дальнейших проблем, вскоре хочу немного, всех разделить на отдельные подсети.

Share this post


Link to post
Share on other sites

Вы можете на убнт запаковывать данные абонентов во влан, которые уже прокидывать до микротика. Тут дело даже не в сегментации, а в мусоре, который постоянно идет по сети, если он попадает в радиоканал, то уже занимает некоторый ресурс, а если это мусор мелкими пакетами вида ARP от локалки на 60 клиентов, это уже порядка 100-200кбит временами, а то и больше.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now