Jump to content
Калькуляторы

помогите настроить VLAN на микротике х86 и SNR-S2985G-24T

Есть микротик с входящим интерфейсом wan (dhcp-client) и исходящим (ethernet 8). На 8 порту нужно два dhcp-server. Один в VLAN 1 (всем), второй только для VLAN ID 100. 

Вот как я сделал:

/interface bridge
add name=bridge-lan
/interface vlan
add interface=bridge-lan name=Vlan-100 use-service-tag=yes vlan-id=100
/ip pool
add name=dhcp_pool0 ranges=10.10.1.2-10.10.1.254
add name=dhcp_pool1 ranges=10.10.2.2-10.10.2.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge-lan name=dhcp1
add address-pool=dhcp_pool1 disabled=no interface=Vlan-100 name=dhcp2
/interface bridge port
add bridge=bridge-lan interface=ether8
add bridge=bridge-lan interface=Vlan-100
/ip address
add address=10.10.1.1/24 interface=bridge-lan network=10.10.1.0
add address=10.10.2.1/24 interface=Vlan-100 network=10.10.2.0
/ip dhcp-server network
add address=10.10.1.0/24 gateway=10.10.1.1
add address=10.10.2.0/24 gateway=10.10.2.1

 

В 8-ой порт микротика воткнут коммутатор SNR-S2985G-24T. Первый порт тарнк. Третий порт VLAN ID 100. 
!
vlan 1;100
!
Interface Ethernet1/0/1
 switchport mode trunk
 switchport trunk allowed vlan 1;100
!
Interface Ethernet1/0/2
!
Interface Ethernet1/0/3
 switchport access vlan 100
!
Interface Ethernet1/0/4
!
Interface Ethernet1/0/5
!
Interface Ethernet1/0/6
!
Interface Ethernet1/0/7
!
Interface Ethernet1/0/8
!
Interface Ethernet1/0/9
!
Interface Ethernet1/0/10
!
Interface Ethernet1/0/11
!
Interface Ethernet1/0/12
!
Interface Ethernet1/0/13
!
Interface Ethernet1/0/14
!
Interface Ethernet1/0/15
!
Interface Ethernet1/0/16
!
Interface Ethernet1/0/17
!
Interface Ethernet1/0/18
!
Interface Ethernet1/0/19
!
Interface Ethernet1/0/20
!
Interface Ethernet1/0/21
!
Interface Ethernet1/0/22
!
Interface Ethernet1/0/23
!
Interface Ethernet1/0/24
!
Interface Ethernet1/0/25
!
Interface Ethernet1/0/26
!
Interface Ethernet1/0/27
!
Interface Ethernet1/0/28

 

На всех  портах кроме 1 и 3  компьютер получает адрес с первого dhcp (для всех) как и положено. 

На 3-ем порту не получает ни чего.

Что делаю не так?

 

Share this post


Link to post
Share on other sites
1 час назад, Ильяс сказал:

Что делаю не так?

Практически все. Вы вообще хоть что-то читали, прежде чем это вылепить? Зачем в bridge-lan запихнули ether8 и Vlan-100? Почему Vlan-100 создан над bridge-lan, а не над ether8?

 

P.S>Лучше от vlan 1 уйти (хотя в вашем текущем варианте и не обязательно).

Share this post


Link to post
Share on other sites
59 минут назад, DRiVen сказал:
1 час назад, Ильяс сказал:

Что делаю не так?

Практически все. Вы вообще хоть что-то читали, прежде чем это вылепить? Зачем в bridge-lan запихнули ether8 и Vlan-100? Почему Vlan-100 создан над bridge-lan, а не над ether8?

 

P.S>Лучше от vlan 1 уйти (хотя в вашем текущем варианте и не обязательно).

Изначально я делал вообще без бриджа. VLAN-100  создал на ether8:

/interface vlan
add interface=ether8 name=vlan100 use-service-tag=yes vlan-id=100
/ip pool
add name=dhcp_pool0 ranges=10.10.1.2-10.10.1.254
add name=dhcp_pool1 ranges=10.10.2.2-10.10.2.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether8 name=dhcp1
add address-pool=dhcp_pool1 disabled=no interface=vlan100 name=dhcp2
/ip address
add address=10.10.1.1/24 interface=ether8 network=10.10.1.0
add address=10.10.2.1/24 interface=vlan100 network=10.10.2.0
/ip dhcp-server network
add address=10.10.1.0/24 dns-server=8.8.8.8 gateway=10.10.1.1
add address=10.10.2.0/24 dns-server=8.8.8.8 gateway=10.10.2.1
 

 

1 час назад, DRiVen сказал:

Практически все.

Вы как решили бы такую задачу?

Share this post


Link to post
Share on other sites

В последнем приведенном варианте в настройке vlan100 установите use-service-tag=no и все заведется.

 

3 часа назад, Ильяс сказал:

Вы как решили бы такую задачу?

Да тут решать то особо нечего, используя ваш конфиг и уйдя от vlan1 можно так:

 

/interface vlan
add interface=ether8 name=vlan100 vlan-id=100
add interface=ether8 name=vlan2 vlan-id=2
/ip pool
add name=dhcp_pool0 ranges=10.10.1.2-10.10.1.254
add name=dhcp_pool1 ranges=10.10.2.2-10.10.2.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=vlan2 name=dhcp1
add address-pool=dhcp_pool1 disabled=no interface=vlan100 name=dhcp2
/ip address
add address=10.10.1.1/24 interface=vlan2 network=10.10.1.0
add address=10.10.2.1/24 interface=vlan100 network=10.10.2.0
/ip dhcp-server network
add address=10.10.1.0/24 dns-server=8.8.8.8 gateway=10.10.1.1
add address=10.10.2.0/24 dns-server=8.8.8.8 gateway=10.10.2.1 

 

На свитче:
 

vlan 2;100

!
Interface Ethernet1/0/1
 switchport mode trunk
 switchport trunk allowed vlan 2;100


на всех портах (кроме 1 и 3 естественно)

switchport access vlan 2

 

Share this post


Link to post
Share on other sites
В 07.03.2018 в 18:42, DRiVen сказал:

В последнем приведенном варианте в настройке vlan100 установите use-service-tag=no и все заведется.

Спасибо за помощь. 

Снял галочку use-service-tag и все заработало.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this