Jump to content
Калькуляторы

(SOLVED) Интересный прикол с коммутаторами SNR S2965-8T

Жил я спокойно до этого дня - юзал сотни свичей SNR S2960-24G.

И вот приехали к нам свичи  SNR S2965-8T

Прошил на самую свежую прошивку дек 2017 - на стенде залил аналогичный шаблон конфига - потетсил нужные фичи - все ок - пустил в продакшн.

И вот как раз как я уехал - позвонила мне наша служба поддержки - что вот ставят они в новые дома свичи и у людей ничего не работает.

Приехал я в родную обитель - перепроверил все что можно - явных граблей нет.

Собрал снова стенд. Долго колупался - пока не нашел закономерность - проблема возникает только тога - когда первый в цепочке стоит SNR S2965-8T - а к нему через транк порт подключаю любой другой свич - в случае подключения клиента в этот второй свич клиент не получает адреса от DHCP.Анализ логов DHCP и dhcpdump на сервере показал  -что запрос прилетает  - уходит ответ (DHCPDISCOVER -  DHCPOFFER),   а подтверждения нету  (DHCPREQUEST - DHCPACK)

 

log DHCP server:


 

Feb 17 17:31:09 dhcp dhcpd: DHCPDISCOVER from 08:00:27:fd:c3:b2 via 10.194.22.1
Feb 17 17:31:10 dhcp dhcpd: DHCPOFFER on 10.194.22.64 to 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:31:14 dhcp dhcpd: DHCPDISCOVER from 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:31:14 dhcp dhcpd: DHCPOFFER on 10.194.22.64 to 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:31:22 dhcp dhcpd: DHCPDISCOVER from 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:31:22 dhcp dhcpd: DHCPOFFER on 10.194.22.64 to 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:31:37 dhcp dhcpd: DHCPDISCOVER from 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:31:37 dhcp dhcpd: DHCPOFFER on 10.194.22.64 to 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:37:00 dhcp dhcpd: DHCPDISCOVER from 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1
Feb 17 17:37:01 dhcp dhcpd: DHCPOFFER on 10.194.22.64 to 08:00:27:fd:c3:b2 (computer-380692) via 10.194.22.1

 

 

При этом на первом свиче в цепочке юзеры получают

При этом меняем месиами свичи - все раотает на обоих

 

Схема простая - клиент - свич доступа - свич доступа - L3 свич агрегации (на нем DHCP Relay) - DHCP Server

(оба свича доступа в одном влане - типа влан на дом)

 - для управления отдельнй влан

- последняя прошива

 

Куда рыть - пните - ребята  - плиз

 

C035#sh ver


 

  SNR-S2965-8T Device, Compiled on Dec 27 15:57:28 2017
  sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
  CPU Mac f8:f0:82:75:b2:b6
  Vlan MAC f8:f0:82:75:b2:b5
  SoftWare Version 7.0.3.5(R0241.0211)
  BootRom Version 7.2.21
  HardWare Version 1.0.5
  CPLD Version N/A
  Serial No.:SW052610F822000032
  Copyright (C) 2017 NAG LLC
  All rights reserved
  Last reboot is cold reset.
  Uptime is 0 weeks, 1 days, 3 hours, 9 minutes

 


 

 

Вот типовой конфиг

(vlan135  - это управление)

 

 

 

service password-encryption
!
hostname C035
sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
sysContact support@nag.ru
!
username admin privilege 15 password 7 *********************
!
authentication line console login local
authentication ip access-class cli_acl in
!
!
!
!
service dhcp
!
!
ip dhcp snooping enable
ip dhcp snooping vlan 2001
 ip dhcp snooping binding enable
!
 ip dhcp snooping information enable
 ip dhcp snooping information option subscriber-id format hex
!
!
!
!
!                                                                                                                                                                                                                                            
!                                                                                                                                                                                                                                            
loopback-detection interval-time 10 3                                                                                                                                                                                                        
!                                                                                                                                                                                                                                            
loopback-detection control-recovery timeout 30                                                                                                                                                                                               
!                                                                                                                                                                                                                                            
!                                                                                                                                                                                                                                            
vlan 1;135;2001                                                                                                                                                                                                                         
!                                                                                                                                                                                                                                            
ip access-list standard cli_acl                                                                                                                                                                                                              
  permit 192.168.0.0 0.0.255.255                                                                                                                                                                                                             
  permit host-source 10.10.135.254                                                                                                                                                                                                           
  exit                                                                                                                                                                                                                                       
!                                                                                                                                                                                                                                            
Interface Ethernet1/0/1                                                                                                                                                                                                                      
 switchport access vlan 2001                                                                                                                                                                                                                 
 loopback-detection specified-vlan 2001                                                                                                                                                                                                      
 loopback-detection control block                                                                                                                                                                                                            
 ip dhcp snooping binding user-control                                                                                                                                                                                                       
 ip dhcp snooping binding user-control max-user 4                                                                                                                                                                                            
!                                                                                                                                                                                                                                            
Interface Ethernet1/0/2                                                                                                                                                                                                                      
 switchport access vlan 2001                                                                                                                                                                                                                 
 loopback-detection specified-vlan 2001                                                                                                                                                                                                      
 loopback-detection control block
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/0/3
 switchport access vlan 2001
 loopback-detection specified-vlan 2001
 loopback-detection control block
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/0/4
switchport access vlan 2001
 loopback-detection specified-vlan 2001
 loopback-detection control block
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/0/5
switchport access vlan 2001
 loopback-detection specified-vlan 2001
 loopback-detection control block
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/0/6
switchport access vlan 2001
 loopback-detection specified-vlan 2001
 loopback-detection control block
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/0/7
switchport access vlan 2001
 loopback-detection specified-vlan 2001
 loopback-detection control block
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/0/8
switchport access vlan 2001
 loopback-detection specified-vlan 2001
 loopback-detection control block
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/0/9
 switchport mode trunk
 ip dhcp snooping trust
!
Interface Ethernet1/0/10
 switchport mode trunk
 ip dhcp snooping trust
!
interface Vlan135
 ip address 10.10.135.35 255.255.255.0
!
ip default-gateway 10.10.135.254
!
ntp enable
ntp server 192.168.10.1
!
!
no login
!
!
isolate-port group g1 switchport interface Ethernet1/0/10
isolate-port group g1 switchport interface Ethernet1/0/8
isolate-port group g1 switchport interface Ethernet1/0/7
isolate-port group g1 switchport interface Ethernet1/0/6
isolate-port group g1 switchport interface Ethernet1/0/5
isolate-port group g1 switchport interface Ethernet1/0/4
isolate-port group g1 switchport interface Ethernet1/0/3
isolate-port group g1 switchport interface Ethernet1/0/2
isolate-port group g1 switchport interface Ethernet1/0/1
captive-portal
!
end

 

 

Share this post


Link to post
Share on other sites

Добрый день.

Похожая проблема была исправлена в последней версии ПО. Пожалуйста обновите прошивку до версии 7.0.3.5 (R0241.0215)

Если после обновления проблема повторится, создайте, пожалуйста, обращение в support. К обращению отдельным файлом приложите вывод "show run" с обоих коммутаторов.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now