Jump to content
Калькуляторы

Hikvision/hiwatch недоброе с ethernet портами

Друзья, всем дня!

 

Имею несколько устройств с одинаковыми симптомами:

Скачет порт:

Port up

Несколько секунд

Port down

В логах роутера

На разных обьектах, часами, может быть сутками

Прошивка актуальная. Видеорегистраторы и ip камеры

При этом замечено, если зайти на устройство браузером (похоже аналогично с пингом, не проверял во времени), то порт перестает скакать...

Кто то может встречался? 

Заранее спасибо за мысли 

Edited by Maman

Share this post


Link to post
Share on other sites

Софт какой?

Коммутаторы какие?

 

Share this post


Link to post
Share on other sites
26 минут назад, SMSI сказал:

Софт какой?

Коммутаторы какие?

DS-2CD2522FWD-IS

V5.5.0 build 170725

Микротики везде 

Share this post


Link to post
Share on other sites
16 часов назад, Maman сказал:

 

Микротики везде 

Вот.

Попробуйте нормальный коммутатор, тот же Длинк хотя бы

Share this post


Link to post
Share on other sites
1 час назад, SMSI сказал:

Вот.

Попробуйте нормальный коммутатор, тот же Длинк хотя бы

Под рукой как раз длинк есть. Ситуация аналогичная. Что делать?

Share this post


Link to post
Share on other sites

Выгорел порт, шторм в сети. Вариантов много.

Снимайте дамп трафика и изучайте.

Share this post


Link to post
Share on other sites
4 минуты назад, alibek сказал:

Выгорел порт,

На десятке новых роутеров вынутых из коробки

15 минут назад, alibek сказал:

шторм в сети

Состоящей из регистратора, камеры и lte модема

 

16 минут назад, alibek сказал:

Снимайте дамп трафика и изучайте

В дампе только mdns и igmp обмен после восстановления порта. Дальше тихо

 

21 минуту назад, alibek сказал:

Вариантов много

Каких?

Share this post


Link to post
Share on other sites
3 часа назад, Maman сказал:

На десятке новых роутеров вынутых из коробки

Причем тут роутеры? Порт мог и на камере выгореть.

3 часа назад, Maman сказал:

Состоящей из регистратора, камеры и lte модема

Если выгорел порт, то запросто.

 

Share this post


Link to post
Share on other sites
1 час назад, alibek сказал:

Причем тут роутеры? Порт мог и на камере выгореть.

 

1 час назад, alibek сказал:

Если выгорел порт, то запросто.

 

Пруф?

 

В 07.02.2018 в 15:31, Maman сказал:

Имею несколько устройств с одинаковыми симптомами:

 

В 07.02.2018 в 15:31, Maman сказал:

На разных обьектах... Видеорегистраторы и ip камеры

 

Все из коробки

Share this post


Link to post
Share on other sites

Камеры не на железке стоят?

Кабель, разъемы - экранированные или нет?

В логах камеры есть что-то?

 

Share this post


Link to post
Share on other sites

Было такое с камерами Hikvision. Помогало переключение режима NIC камеры из авто в 100Mbit. Скорее всего причиной была нонейм витая пара с"уникальными" характеристиками. 

Share this post


Link to post
Share on other sites

У меня 4 варианта: обжим плохой, кабель плохой, питание не вытягивает, камера не поддерживает 1G. Переведите порт на коммутаторе в 100Мb, как было написано выше. Не поможет - 10Мb полудуплекс. Если на 10 перестанет пропадать меняйте кабель. Если PoE - переведите порт в режим 802.3at и повысьте максимальный бюджет.  И очень осторожно вешайте конечное оборудование на гиговые порты. Далеко не все камеры или видеорегистраторы (а особенно, если им больше 4 лет) адекватно поддерживают этот режим. 

Edited by ArtyDx

Share this post


Link to post
Share on other sites
11 hours ago, ArtyDx said:

У меня 4 варианта: обжим плохой, кабель плохой, питание не вытягивает, камера не поддерживает 1G. Переведите порт на коммутаторе в 100Мb, как было написано выше. Не поможет - 10Мb полудуплекс. Если на 10 перестанет пропадать меняйте кабель. Если PoE - переведите порт в режим 802.3at и повысьте максимальный бюджет.  И очень осторожно вешайте конечное оборудование на гиговые порты. Далеко не все камеры или видеорегистраторы (а особенно, если им больше 4 лет) адекватно поддерживают этот режим. 

 

Хм... 10mb/полудуплекс на МТ в связке с Hikvision => ethernet down совсем (во всяком случае на доступных мне девайсах этих брендов).

В своем предыдущем посте я имел ввиду, что 100mb/full (half) ставить для hikvision, для MT - default (auto negotiaton).

Тем более ТС утверждает, что при заходе в веб-морду все становится норм, т.е. проверить сие несложно.

Share this post


Link to post
Share on other sites
11 hours ago, ArtyDx said:

..... И очень осторожно вешайте конечное оборудование на гиговые порты.....

 

Наверное соглашусь, так как в связке с Hikvision у меня отсутствуют МТ с гиговыми портами - стоит попробовать выставить 100-ку с обеих сторон линка.  

Share this post


Link to post
Share on other sites
В 07.02.2018 в 17:31, Maman сказал:

Скачет порт:

Port up

Несколько секунд

Port down

т.е и ping теряется в этот момент? 

Share this post


Link to post
Share on other sites
5 часов назад, DAF сказал:

Хм... 10mb/полудуплекс на МТ в связке с Hikvision => ethernet down совсем (во всяком случае на доступных мне девайсах этих брендов).

В своем предыдущем посте я имел ввиду, что 100mb/full (half) ставить для hikvision, для MT - default (auto negotiaton).

Тем более ТС утверждает, что при заходе в веб-морду все становится норм, т.е. проверить сие несложно.

Хм, у меня Hikivision DS-2CD8254F-EI. Они на 10М half работают. Но соглашусь с Вами, поспешил)

Я бы всё таки выставил режим порта не на конечном оборудовании, а на самом коммутаторе (для удобства). Но в данном случае принципиальной разницы нет) Главное, чтобы с одной стороны порт был 100М, с другой - auto. 

Добавлю к вышесказанному, что я не сталкивался с камерами с 1G в принципе. 

Share this post


Link to post
Share on other sites
1 hour ago, ArtyDx said:

.......

Добавлю к вышесказанному, что я не сталкивался с камерами с 1G в принципе. 

У меня кучка давно снятых с производства (монтировали в 2011-2012) Hikivision DS-2CD853F-E, DS-2CD863PF-E, DS-2CD863. Все с гигабитом.  :)

Share this post


Link to post
Share on other sites
24 минуты назад, DAF сказал:

У меня кучка давно снятых с производства (монтировали в 2011-2012) Hikivision DS-2CD853F-E, DS-2CD863PF-E, DS-2CD863. Все с гигабитом.  :)

Не довелось поработать с такими моделями. Не знаю зачем там гигабит) Разве что, как режим совместимости с гигабитными портами коммутатора)

Edited by ArtyDx

Share this post


Link to post
Share on other sites
1 hour ago, ArtyDx said:

Не довелось поработать с такими моделями. Не знаю зачем там гигабит) Разве что, как режим совместимости с гигабитными портами коммутатора)

 

Самому интересно стало - может NIC в SoC встроена? Или отдельная PHY.  Щас разберу, гляну.

 

Сорри, ввел в заблуждение. В DS-2CD853F-E стоит PHY rtl8201, которая 10/100 по даташиту. Но в веб-морде можно выбрать 10/100/1000/auto. С гигом это DS-2CD863PF-E, под рукой нету.

Понял в чем дело, прошивка то общая :)

Edited by DAF

Share this post


Link to post
Share on other sites

попробовать откинуть ВСЕ с роутера кроме камер. и компом подключаться другим, скорее всего просто штормит

Share this post


Link to post
Share on other sites
1 hour ago, ALL__ said:

попробовать откинуть ВСЕ с роутера кроме камер. и компом подключаться другим, скорее всего просто штормит

ТС говорит, что, что сетевое железо - Микротик. Там полно тулзы, чтобы увидеть, штормит или нет.

Share this post


Link to post
Share on other sites
В 16.02.2018 в 06:37, Stepan Alekseev сказал:

т.е и ping теряется в этот момент? 

нет

23 часа назад, DAF сказал:

Там полно тулзы, чтобы увидеть, штормит или нет.

Точно так. Нет)

Share this post


Link to post
Share on other sites
8 hours ago, Maman said:

нет

Точно так. Нет)

/tool packcet-sniffer config&start. Может проволочная акула что подскажет?

Share this post


Link to post
Share on other sites
10 часов назад, DAF сказал:
18 часов назад, Maman сказал:

нет

Точно так. Нет)

/tool packcet-sniffer config&start. Может проволочная акула что подскажет?

Откровенно, я не волоку в качественном анализе таких вещей. Если вы сможете посмотреть, я сделаю файлик 

Share this post


Link to post
Share on other sites

Лучше слать на Wireshark трансляцией. Разбирать удобнее, можно отследить откуда ноги растут.

Но если там петля - он не покажет. flow control, кстати, может отрабатывать, c dhcp встречалось - были подобные проблемы, если аренда выставлена минимально.

Интересно было бы настройки поглядеть и лог в более-менее чистом виде.

Edited by ArtyDx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now