Jump to content
Калькуляторы

Чудеса с Netwatch или я что-то не понимаю...

on down стоит скрипт:

/log warning "uplink is fail..."
/tool e-mail send to=ggg@gggggg.ru subject="uplink is FAIL on 2.3 router :(" body="uplink is FAIL"
:delay 1
:if ([/ping 8.8.8.8 count=10]<7) do={
/log error "Shuting down BGP"
/routing bgp peer set [find name=Name] disabled=yes
/log error "uplink is down, shuting down default route"
/ip route set [find dst-address=0.0.0.0/0 and gateway=111.11.11.111] disabled=yes
/log error "Delaying 2"
:delay 2
....
}

Последнее что я вижу в логе: "uplink is down, shuting down default route" и все. В действительности роут не дисейблится, никаких ошибок не отображается, дальше скрипт не выполняется.

Если же отдельно в терминале выполнить команду

/ip route set [find dst-address=0.0.0.0/0 and gateway=111.11.11.111] disabled=yes

то все срабатывает, роут выключается.

В чем может быть дело ?

 

При этом на UP аналогичная команда отлично отрабатывается в скрипте

Share this post


Link to post
Share on other sites

Похоже нашел проблему. Но это косяк в микротике.

После того как я опускаю BGP сессию маршрут BGPшный удаляется не мгновенно.

Таким образом команда, которая гасит роуты видит в свем find в том числе динамический маршрут BGP и пытается его опустить, а поскольку он динамический - выключить у нее его не получается и она вылетает без какой-либо ошибки. Добавил :delay 2 перед выключением маршрутов - все сработало... Жесть блин.

 

and static=yes

так же решило проблему.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now