Перейти к содержимому
Калькуляторы

Quagga, mpd5 ng & mtu

Есть сервер с mpd5, к которому цепляются клиенты-маршрутизаторы по l2tp с сетями за этими маршрутизаторами. Хотели поднять OSPF, чтобы ручками поменьше работы было, но получился такой эффект:

запускаем кваггу, когда линки есть, всё норм. Клиент отключатся, интерфейс ngX пропадает, и ospfd начинает считать, что там MTU 1500, клиент подключается, вновь появляется интерфейс ngX - и всё ровно тоже самое: MTU 1500 по мнению ospfd, а по факту 1450, в итоге имеем MTU mismatch.

 

Что со всем этим делать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

заменить кваггу? :)

попробовать через бридж сделать, тогда не надо слушать интерфейсы которые удаляются\создаются

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

причем тут мту мисматч? у вас через этот л2тп ходит оспф? 

или вы хотите наверх клиентов проанонсить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
3 часа назад, zhenya` сказал:

причем тут мту мисматч? у вас через этот л2тп ходит оспф? 

или вы хотите наверх клиентов проанонсить?

Именно через L2TP ходит OSPF, хочу проанонсить на свой роутер "клиентские" подсети, чтобы иметь туда прямой доступ, там всякое оборудование, а "клиентские" роутеры в том числе и за натом сидят.

 

 

Изменено пользователем nevzorofff

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
18 минут назад, zhenya` сказал:

ip ospf mtu-ignore ?

Часть клиентов - микротики, у которых эта фича не реализована.

 

Вспомнил тут, что когда-то у mpd не было темплейлов на интерфейсы и он не умел их создавать и убивать. Вбил статикой с пяток - и та же песня. Когда на интерфейсе нет линка - MTU всё равно 1500, даже если  в конфиге задан 1400. И та же самая шляпа - при запущенных линках перехапускмем кваггу - всё норм, MTU 1400 везде, OSPF работает, линк упал - квагга увидела 1500. Линк поднялся - квагга 1400 не видит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

В 03.01.2018 в 08:46, GrandPr1de сказал:

заменить кваггу? :)

попробовать через бридж сделать, тогда не надо слушать интерфейсы которые удаляются\создаются

Поставил bird, ради интереса - грабель ещё больше - то на l2tp линке то DD packet to late, после перезагрузки mpd5 - устанавливается нормальный линк. При отваливани клиента l2tp - bird выпадает в корку, и 1.6 и 2.0-devel)

 

А ещё чудо-оператор Уфанет половину пакетов l2tp натит, а другая половила прилетает с серым адресом источника. Несколько месяцев их колупал, чтобы нашли почему из-за их ната l2tp БЕЗ Ipsec не поднимается. Вчера tcpdump'ом сам нашёл.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ну тогда я за бриджы, не вижу более рабочего решения

плодите сколько нужно бриджей да и всё

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 часа назад, nevzorofff сказал:

Поставил bird, ради интереса - грабель ещё больше

Попробуйте frr, по крайней мере если не поможет - создавайте issue, что интерфейс не опрашивается на предмет MTU.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

По frr открыл аж два тикета. За МТУ не следит, и мироктик после L2TP тунеля ругается на флаги в OSPF, микротик подключенный по Ethernet - завязался по OSPF нормально.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас