Jump to content
Калькуляторы

Проблемы с вещанием IPTV на Zyxel ES-2108G

Всем привет!

Товарищи, очень бы хотелось услышать ваше мнение по поводу сложившейся в сети нашей компании проблемы.

Есть небольшая провайдерская сеть, построенная звездой. Захотелось в этой сети настроить вещание IPTV и multicast. Настроили. Вроде даже работает, да вот только не совсем. Подробнее:

Multicast приходит на Catalyst 6504 (Software (s32p3_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)ZYA3a), на котором работает PIM-SM и роутит мультикаст в VLAN 2222

Цитата

interface Vlan2222
ip address 192.168.1.145 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
ip igmp query-interval 125
ip igmp snooping querier
end

Далее этот влан уходит на районные и домовые коммутаторы:

Цитата

interface GigabitEthernet4/4
description Lenina29
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,5,10,11,22,33,43-45,55,100-402,404-435
......
switchport trunk allowed vlan add 1401,2016,2043,2095,2100,2222,3663,4000
switchport mode trunk
switchport nonegotiate
no ip address
no cdp enable
end

Преимущественно используются коммутаторы Zyxel (gs-3012, mes-3528, es-2024, mes-3500, es-2108, es-2108G)

На них включаем IGMP Snooping, IGMP Query и настраиваем MVR на абонентские порты (абоненты подключаются по рррое и на каждом коммутаторе свой vlan + port isolation)

Вот пример конфигурации одного из таких коммутаторов Zyxel Mes-3528:

Цитата

igmp-snooping  
igmp-snooping 8021p-priority 7  
igmp-snooping unknown-multicast-frame drop  
igmp-snooping filtering  
igmp-snooping filtering profile IPTV start-address 224.1.2.0 end-address 224.1.2.255  
igmp-snooping querier  
.......
interface port-channel 21   
 name Vitalik  
 qos priority 5  
 pvid 33  
 bandwidth-limit ingress 30720  
 bandwidth-limit egress 30720  
 broadcast-limit 512  
 multicast-limit 512  
 dlf-limit 512  
 igmp-snooping filtering profile IPTV  
 loopguard  
exit  
........
interface port-channel 27   
 name out  
 pvid 2  
 frame-type tagged  
 vlan-trunking  
 igmp-snooping filtering profile IPTV  
 igmp-snooping querier-mode fixed  
exit  
interface port-channel 28   
 name "in 1.226"  
 qos priority 5  
 pvid 2  
 frame-type tagged  
 vlan-trunking  
 igmp-snooping filtering profile IPTV  
 igmp-snooping querier-mode fixed  
exit  
......
mvr 2222  
 source-port 28  
 receiver-port 1-27  
 name IPTV  
 tagged 25,27-28  
 group IPTV start-address 224.1.2.0 end-address 224.1.2.255  
 8021p-priority 7  
exit   

Приходит мультикаст в порт 28 с другого такого же Zyxel Mes-3528 (настроенного подобным образом), который в свою очередь воткнут в Catalyst 6504. В Порт 21 воткнут абонентский ПК, включен VLC и показывает телевидение. Все каналы.

В порт 27 мультикаст уходит на Zyxel ES-2108G. Его конфигурация:

Цитата

igmp-snooping 8021p-priority 7  
igmp-snooping unknown-multicast-frame drop  
igmp-snooping querier  
igmp-filtering                                                                                                                                                                                                                                                                  
igmp-filtering profile IPTV start-address 224.1.2.0 end-address 224.1.2.255                                                                                                                                                                                                     
....                                                                                                                                                                                                                                                                     
interface port-channel 5                                                                                                                                                                                                                                                        
 igmp-filtering profile IPTV                                                                                                                                                                                                                                                   
 pvid 528                                                                                                                                                                                                                                                                      
 name "Test NoteBook"                                                                                                                                                                                                                                                          
 loopguard                                                                                                                                                                                                                                                                     
exit                                                                                                                                                                                                                                                                            
....
interface port-channel 8   
 igmp-filtering profile IPTV  
 pvid 528  
 name abonent  
exit  
interface port-channel 9   
 igmp-filtering profile IPTV  
 igmp-querier-mode fixed  
 pvid 2  
 frame-type tagged  
 name in  
 vlan-trunking  
exit  
....
mvr 2222  
 source-port 9  
 receiver-port 1-8  
 name IPTV  
 tagged 9  
 group IPTV start-address 224.1.2.0 end-address 224.1.2.255  
 8021p-priority 7  
exit

В ES-2108G аплинком является 9й порт. В 8й воткнута приставка STB, в 5й тестовый ноутбук с VLC. Вроде бы все настроено подобно MES-3528, но... на ES-2108G с подключенного устройства (хоть с vlc, хоть с stb) запрашиваем канал, на самом коммутаторе во вкладке multicast этого запроса нет и, соответственно, он не показывает. Через некоторое время запрашиваем снова - есть запрос. Но все равно не показывает. Запрашиваем другой канал - есть и запросы и вещание. Листаем каналы дальше. Часть работает, часть нет. Через некоторое время может прекратить вещание и тот канал, который только недавно работал. И так далее, то работает, то не работает.

 

Версия ПО ES-2108G: V3.80(ABL.2) | 06/09/2011

Версия ПО MES-3528: V3.90(BHR.5)20121121 | 11/21/2012

 

Коммутаторы ES-2108G уже не выпускаются, ПО для них не обновляется. И наш вопрос в техподдержку Zyxel остался без ответа. Но тем не менее, в нашей сети осталось еще приличное кол-во этих коммутаторов и очень хотелось бы решить эту проблему. С коммутаторами других моделей все работает исправно, а ES-2108G никак победить не можем. Возможно, кто-то из форумчан уже сталкивался с подобной проблемой или просто настраивал мультикаст на ES-2108G? Может, есть другой вариант настройки мультикаста на подобных коммутаторах в нашей сети или какие-нибудь другие варианты решения проблемы? Очень хотелось бы услышать ваше мнение. Заранее спасибо 

 

Во вложении скрины с веб-интерфейса Zyxel Mes-3528 

Screenshot_20171207_140958.png

Screenshot_20171207_141015.png

Screenshot_20171207_141035.png

Screenshot_20171207_141056.png

Edited by Margarita
UPD

Share this post


Link to post
Share on other sites

igmp querierом должна быть циска. но скорее всего проблема не в этом.

Share this post


Link to post
Share on other sites

Запросите у Zyxel прошивку на 2108. Естьу  них косяк в этой прошивке. Тоже сталкивались с этими граблями. Сделали дампы и написали в техпод - они дали пофикшенную прошивку. но в общем доступе ее почемуто нет.

Если они не дадут - стукните в ЛС, в понедельник поищу на работе, где то должна быть.

Share this post


Link to post
Share on other sites

н у так то да,

из говна и палок построить Лондон не выйдет :(

а хотелось б ы

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this