Jump to content
Калькуляторы

s2950 dhcp snooping

Тем по этому вопросу много. Но у меня почему-то не получается корректно настроить данную функцию. Суть в том, что сам коммутатор получает ip по dhcp на 10 vlan'е, когда включаю snooping, snr перестает получать ip. Мне надо запретить dhcp вещание на ethertnet портах. Вот мой текущий конфиг:

!
no service password-encryption
!
hostname Switch
sysLocation pafflootiy
sysContact pafflootiy
!
authentication logging enable
!
username admin privilege 15 password 0 XXXXXXXXXXXX
!
!
!
!
ip ftp username ftpgarant password 0 XXXXXXXXXXXX
ftp-server enable
!
ssh-server enable
!
snmp-server enable
snmp-server securityip 10.10.0.1
snmp-server community rw 0 private
!
!
!
!
!
!
!
!
vlan 1;10;101-124 
!
Interface Ethernet1/1
 switchport mode trunk
 switchport trunk allowed vlan 10;101-124 
!
Interface Ethernet1/2
 switchport access vlan 102
!
Interface Ethernet1/3
 switchport access vlan 103
!
..........................................
..........................................
..........................................
..........................................

!         
Interface Ethernet1/24
 switchport access vlan 124
!         
Interface Ethernet1/25
 switchport mode trunk
 switchport trunk allowed vlan 10;101-124 
!         
Interface Ethernet1/26
 switchport mode trunk
 switchport trunk allowed vlan 10;101-124 
!         
interface Vlan10
 ip dhcp-client enable
!         
no login  
!         
end 

Не откажите в помощи =)

Edited by pafflootiy

Share this post


Link to post
Share on other sites

pafflootiy, при включении dhcp snooping также необходимо указать доверенный порт, через который можно будет получать BOOTREPLY.

ip dhcp snooping

interface e1/X
 ip dhcp snooping trust

 

Share this post


Link to post
Share on other sites
1 час назад, Victor Tkachenko сказал:

ip dhcp snooping

В моем случае это оптопорты (25 и 26), именно так я и делал, т.е.

Interface Ethernet1/25
 switchport mode trunk
 switchport trunk allowed vlan 10;101-124
 ip dhcp snooping trust

Тем не менее, dhcp-client переставал работать на snr'ах, точнее переставал получать ip...я запутался в формулировках)))

 

1 час назад, Victor Tkachenko сказал:

pafflootiy, при включении dhcp snooping также необходимо указать доверенный порт, через который можно будет получать BOOTREPLY.


ip dhcp snooping

interface e1/X
 ip dhcp snooping trust

 

Ну хорошо. Вы меня поняли, тогда, если Вас не затруднит, приведите, пожалуйста полный конфиг коммутатора, с учетом имеющихся у меня настроек.
Спасибо!

Share this post


Link to post
Share on other sites

pafflootiy, достаточно применить минимальный конфиг:

ip dhcp snooping enable
!
Interface Ethernet1/25
 ip dhcp snooping trust
!
Interface Ethernet1/26
 ip dhcp snooping trust
!

Также возможно вам необходимо обновить ПО коммутатора. Архив с рекомендуемой версией ПО можете скачать здесь.

 

Если проблема сохранится, оставьте обращение в support. В обращении опишите схему связи коммутатора с dhcp-сервером, приложите выводы `sh ver`, `sh ven`, `sh run`, а также дамп трафика с сервера в момент запроса коммутатором реквизитов и отладку с коммутатора:

debug ip dhcp client event
debug ip dhcp client packet

 

Share this post


Link to post
Share on other sites

Victor Tkachenko В качестве dhcp-сервера стоит "латышский" маршрутизатор. После включения снупинга, начинается вот это:

Безымянный.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now