Jump to content
Калькуляторы

ospf mikrotik redistribute cisco eigrp

Почему то не работает перераспределение, микротик соединен с cisco роутером процессом ospf, также на r1 настроен eigrp включил перераспределение, но что то не работает

 

 

 

# nov/23/2017 18:06:52 by RouterOS 6.39.3
# software id = YSWC-D8EF
#
/interface bridge
add name=br_lo0 protocol-mode=none
/interface ethernet
set [ find default-name=ether4 ] advertise=\
    10M-half,10M-full,100M-half,100M-full name=ether1 speed=100Mbps
set [ find default-name=ether1 ] name=ether2
set [ find default-name=ether2 ] name=ether3
set [ find default-name=ether3 ] name=ether4
/routing ospf instance
add name=ospf_mbs redistribute-connected=as-type-1 redistribute-static=\
    as-type-1 router-id=10.54.154.14
/routing ospf area
add area-id=1.1.1.1 instance=ospf_mbs name=area_mbs
/tool user-manager customer
set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
/ip address
add address=10.54.154.2/30 interface=ether4 network=10.54.154.0
add address=10.54.154.6/30 interface=ether3 network=10.54.154.4
add address=10.54.154.14 interface=br_lo0 network=10.54.154.14
/routing ospf interface
add interface=ether4 network-type=point-to-point
/routing ospf network
add area=area_mbs network=10.54.154.0/30
/tool user-manager database
set db-path=user-manager

 

r1

 

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.54.154.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.54.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 10.54.2.1 255.255.255.252
 duplex auto
 speed auto
!
!
router eigrp 5454
 traffic-share min across-interfaces
 network 10.54.1.0 0.0.0.3
 network 10.54.2.0 0.0.0.3
 redistribute connected metric 102400 1 255 1 1500
 redistribute static metric 102400 1 255 1 1500
 redistribute ospf 5454 metric 102400 1 255 1 1500
 passive-interface default
 no passive-interface FastEthernet0/1
 no passive-interface FastEthernet1/1
!
router ospf 54
 router-id 1.1.1.1
 redistribute eigrp 5454 subnets
 passive-interface default
 no passive-interface FastEthernet0/0
 network 10.54.154.0 0.0.0.3 area 54
!

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.54.154.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.54.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 10.54.2.1 255.255.255.252
 duplex auto
 speed auto
!
!
router eigrp 5454
 traffic-share min across-interfaces
 network 10.54.1.0 0.0.0.3
 network 10.54.2.0 0.0.0.3
 redistribute connected metric 102400 1 255 1 1500
 redistribute static metric 102400 1 255 1 1500
 redistribute ospf 5454 metric 102400 1 255 1 1500
 passive-interface default
 no passive-interface FastEthernet0/1
 no passive-interface FastEthernet1/1
!
router ospf 54
 router-id 1.1.1.1
 redistribute eigrp 5454 metric 100 subnets
 passive-interface default
 no passive-interface FastEthernet0/0
 network 10.54.154.0 0.0.0.3 area 1.1.1.1
!

 

OSPF.JPG

Edited by fractal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now