Jump to content
Калькуляторы

VRRP и dhcp клиент из ниоткуда.

Сам люблю поучать всех как правильно варить микротик, но случился алес, толи я тупой, толи лыжи мои по асфальту не едут.
Дано
1) gns3 vm.
2) 2 chr 6.40.5
Картинко0nbahczuia8scufsxjbjoeijsje.png
Конфиг mt1

/interface vrrp
# received packet from 192.168.50.2 misconfigured IP addresses [192.
 68.50.254](my) != [192.168.50.252, 192.168.50.254](received)
add interface=ether2 name=vrrp1 priority=101
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.50.10-192.168.50.253
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether2 name=\
    dhcp1
/ip address
add address=192.168.50.254 interface=vrrp1 network=192.168.50.254
add address=192.168.50.1/24 interface=ether2 network=192.168.50.0
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.50.0/24 dns-server=192.168.50.254 gateway=\
    192.168.50.254
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

mt2
 

/interface vrrp
# received packet from 192.168.50.1 misconfigured IP addresses [192.168.50.252, 192.168.50.254](my) != [192.168.50.254](received)
add interface=ether2 name=vrrp1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.50.10-192.168.50.253
/ip dhcp-server
add address-pool=dhcp_pool0 delay-threshold=5s disabled=no interface=ether2 name=dhcp1
/ip address
add address=192.168.50.254 interface=vrrp1 network=192.168.50.254
add address=192.168.50.2/24 interface=ether2 network=192.168.50.0
/ip dhcp-client
add disabled=no interface=ether1
add dhcp-options=hostname,clientid interface=vrrp1
add dhcp-options=hostname,clientid disabled=no interface=vrrp1
/ip dhcp-server network
add address=192.168.50.0/24 dns-server=192.168.50.254 gateway=192.168.50.254
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

И все бы хорошо, но на обоих мт откуда то после ребута сам по себе вылезает dhcp-client и вешается на интерфейс vrrp. 
На выходе получается
 

Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  R  ether1                              ether            1500                  00:BF:BE:19:BC:00
 1  R  ether2                              ether            1500                  00:BF:BE:19:BC:01
 2  R  ether3                              ether            1500                  00:BF:BE:19:BC:02
 3  R  ether4                              ether            1500                  00:BF:BE:19:BC:03
 4  R  ether5                              ether            1500                  00:BF:BE:19:BC:04
 5  R  ;;; received packet from 192.168.50.2 misconfigured IP addresses [192.168.50.254](my) != [192.168.50.252, 192.168.50.254](received)
       vrrp1                               vrrp             1500                  00:00:5E:00:01:01

/ip dhcp-client
add disabled=no interface=ether1
add dhcp-options=hostname,clientid disabled=no interface=vrrp1

откуда то появляется dhcp клиент на интерфейсе vrrp с на обоих тиках. Это я чего то в упор не вижу или не понимаю, или "новый функционал" завезли.
Просьба поделиться мыслями. 
VRRP не устаревшая технология - персонально для Saab.

Share this post


Link to post
Share on other sites

Наверное не следует использовать самые последние прошивки вместо с устаревшими технологиями.

Share this post


Link to post
Share on other sites

Saab95 Окей, 
 

system package update print
            channel: bugfix
  installed-version: 6.39.3

Понизил на обоих роутерах. Удалил dhcp-client с vrrp интерфейса. Отправил в ребут и лабудабудаба
 

 ip dhcp-client print
Flags: X - disabled, I - invalid
 #   INTERFACE                                     USE-PEER-DNS ADD-DEFAULT-ROUTE STATUS        ADDRESS
 0   ether1                                        yes          yes               bound         192.168.88.17/24
 1   vrrp1                                         yes          yes               bound         192.168.50.253/24

Хьюстон, у нас проблема.
Итого интерфейс vrrp работает вот таким интересным образом
 

 interface vrrp print
Flags: X - disabled, I - invalid, R - running, M - master, B - backup
 #     NAME           INTERFACE           MAC-ADDRESS       VRID PRIORITY INTERVAL             VERSION V3-PROTOCOL
 0  RM ;;; received packet from 192.168.50.2 misconfigured IP addresses [192.168.50.253, 192.168.50.254](my) !=...
       vrrp1          ether2              00:00:5E:00:01:01    1      101 1s                   3       ipv4

 interface vrrp print
Flags: X - disabled, I - invalid, R - running, M - master, B - backup
 #     NAME           INTERFACE           MAC-ADDRESS       VRID PRIORITY INTERVAL             VERSION V3-PROTOCOL
 0  RM ;;; received packet from 192.168.50.1 misconfigured IP addresses [192.168.50.252, 192.168.50.254](my) !=...
       vrrp1          ether2              00:00:5E:00:01:01    1      100 1s                   3       ipv4

Я так понимаю проблема в том, что у меня микротиков мало? Или в чем?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this