Jump to content
Калькуляторы

SNR-CPE поддержка, опыт эксплуатации, регрессии, результаты тестирования, общие вопросы

В общем разобрался. В 3.3.8 QosEnable=1 (простая приоритезация) вообще не работала. =)))

А косяк в том, что я не учёл что при использовании на корне priomap нельзя в sfq юзать hash по dst ip ибо он будет всегда пуст. Поправил щас соберу 4.1.4.

Ну и таки совет выше не заниматься фигнёй и не трогать вообще шейпер без нужды. Судя по тому что вы использовали вообще не рабочий вариант он вам точно не нужен. Для успокоения можете включить codel.

Share this post


Link to post
Share on other sites

В общем разобрался. В 3.3.8 QosEnable=1 (простая приоритезация) вообще не работала. =)))

А косяк в том, что я не учёл что при использовании на корне priomap нельзя в sfq юзать hash по dst ip ибо он будет всегда пуст. Поправил щас соберу 4.1.4.

Ну и таки совет выше не заниматься фигнёй и не трогать вообще шейпер без нужды. Судя по тому что вы использовали вообще не рабочий вариант он вам точно не нужен. Для успокоения можете включить codel.

Параметр называется QoS, а вы мне о шейпере пишете. Как бы это не совсем одно и то же, хотя и связанные вещи.

Как посоветуете приоретизировать мультикаст на коробке при условии что он приходит уже покрашенным?

Или можно смело забить на это т.к. не работает?

Share this post


Link to post
Share on other sites

Ещё раз грю ни приоритезировать не шейпить пока включен PPE у вас не выйдет, что бы хоть что-то сделать нужно вынуть поток из PPE как это делает simple shaper или вовсе PPE отключить. Поэтому всё должно быть приоритезировано ещё до клиентской железки. А не ждать что вот мы щас покрасим, а там дай бог клиентская железка какая-нить из сотни тысяч разновидностей поймёт эту раскраску, поймёт правильно и ещё правильно раскидает по очередям приоритетов при этом не сдохнув от натуги.

 

И что значит не работает? =) Оно работает, но вот надо понимать когда стоит подобное юзать и чем придётся пожертвовать. На сети оператора явно не задача end user железки заниматься приоритезацией. Учитывая, что эта железка не может повлиять на то, что на неё свалиться через секунду. Т.е. в любом случае что бы такая приоритезация (при отсутствии приоритезации по пути дл конечной железки) нормально работала потребуется городить достаточно длинные очереди и оно никак не поможет если горлышко в виде FE будет забито. Так что трафик уже должен быть сварен как положено ещё до того как оно прилетит к юзеру. Слава богу в нормальных сетях так обычно и происходит.

Share this post


Link to post
Share on other sites

Так что трафик уже должен быть сварен как положено ещё до того как оно прилетит к юзеру. Слава богу в нормальных сетях так обычно и происходит.

До CPE с приоритезацией в частности мультикаста всё отлично (по вашей классификации сеть "нормальная"), вопрос только в том чтобы на самой CPE тот же мультикаст не похерился юзером при нагрузке портов внутренним трафиком, например в процессе копирования файлов из одного компа на другой и т.п.

 

Но в общем я понял Ваш посыл - если трафик обрабатывается хардварно то QoS настройки лучше не включать.

Share this post


Link to post
Share on other sites

Для того что бы не похерился юзером при нагрузке на CPE трафик подрезается на стороне оператора (т.е. если на порт валиться больше чем по этому порту физически можно пропихнуть то тут без плясок не обойтись) + надо гарантировать что бы у CPE хватило ресурсов переварить всё что валиться. На сотке с MT7620 проблемы со сломом приоритезации сделанной до CPE проблем нет. Ресурсов с запасом.

 

вопрос только в том чтобы на самой CPE тот же мультикаст не похерился юзером при нагрузке портов внутренним трафиком, например в процессе копирования файлов из одного компа на другой

 

LAN<=>LAN вообще никакой QoS работать не будет ибо там тупой свитч (тоже самое что любой 5ти портовы неуправляемый железяк). LAN<=>WLAN по сути тоже (с учётом WMM в WLAN).

Share this post


Link to post
Share on other sites
Guest dimkt

Нубские вопросы по сборке прошивки c исходниками.

Успешно включил в ядре и /iptables/extensions модули IP_SET..

Пытаюсь собрать ipset, сборочный скрипт compile MT... не компилирует(все собирается кроме ipset, там даже *.o файлы не появились)

ipset распаковал в /user/ipset, DoConfigure.sh взял из /user/iptables и он запускается, make из директории компилирует(под HTARGET сконфигурированный из DoConfigure?)

 

Может надо где-то ещё прописать этот пакет? (ясно что в RAMFS тоже)

 

P.S. ipset нужен чтобы работал скрипт mwan3 из OpenWrt + надо ещё компильнуть парсер uci(тогда qos-scripts тоже пойдут)

Там конечно адовые скрипты срабатывающие по несколько секунд, но они работают и юзабельны.

Share this post


Link to post
Share on other sites

1) с чего вы взяли что DoConfigure из iptables пойдёт для ipset?

2) с чего вы взяли что достаточно будет ещё компильнуть парсер uci которого вообще нет и что-то там заработает

3) с чего вы взяли что multiwan будет работать без переписывания логики конфигурации свитча?

 

Wive ничего общено с WRT не имеет впринципе. Логика вся другая. Вообще. Для портирования чего-то мало тупо скопировать DoConfigure.sh мало скопировать в диру и добавить в Makefile.

 

Единственное, что я могу вам посоветовать это собсно и использовать OpenWRT раз уж так хочется. Под wive проще с нуля реализовать мультиван для которого нафиг вообще никакой ipset не нужен, зато требуется другая конфигурация свитча и другая логика управления роутами в т.ч. скорее всего понадобиться адвансед роутинг в ядре включить.

 

P.S. Вопрос близко к топику отношения не имеет. Снесу в оффтоп. Никаких планов на будущее в плане мультивана или тем более таскания непойми чего из WRT у нас не имеется.

Share this post


Link to post
Share on other sites

Добрый день!

необходима распиновка COM порта SNR-CPE-W4N-SFP.

Заранее спасибо!

Share this post


Link to post
Share on other sites

День добрый, роутер SNR-CPE-W4G, кривыми рученками убил ubooot. Тперь при включении питания ничего не происходит, LAN не горит, есть ли варианты восстановления? Или только программатор? Если программатор что лить и с какого адреса?

Share this post


Link to post
Share on other sites

Добрый день

Если uboot убит то только программатором:( ,но на всякий случай попробуйте воспользоваться документацией по ссылке http://shop.nag.ru/article/vosstanovlenie-wifi-routera-snr-cpe-w4n

Share this post


Link to post
Share on other sites

Таким способом пробовал, буду пробовать программатором. Не хотел распаивать.

Share this post


Link to post
Share on other sites

Там обычный 8ми ногий spi флэш, шить можно прищепкой. Лить с нулевого адреса бут, буты все собранные есть в git по пути Uboot/products/binary. После заливки бут льём прошивку по tftp.

Share this post


Link to post
Share on other sites

День добрый, роутер SNR-CPE-W4G

 

Блин проспал. W4G ? Это кастрат на 3050? Ну тогда бут придётся собрать самому либо спрашивать на support@nag.ru Вопросы по железу на RT305x пожалуйста адресуйте туда и только туда.

Share this post


Link to post
Share on other sites

День добрый, роутер SNR-CPE-W4G

 

Блин проспал. W4G ? Это кастрат на 3050? Ну тогда бут придётся собрать самому либо спрашивать на support@nag.ru Вопросы по железу на RT305x пожалуйста адресуйте туда и только туда.

Понял, спасибо.

Share this post


Link to post
Share on other sites
Guest Tovictory

Здравствуйте!

Имеется 2 роутера SNR-CPE-W4N на чипах 3052 (один живой, другой кирпич после неудачной прошивки) и программатор PL2303HX 1446964530634193568.jpg

 

Проблема в том, что при подключении обоих роутеров к uart в консоли пусто. Настройки порта 57600, 8 1 1 и питание 5В подано на консольный порт. ТХ+RX и RX+TX подключены верно...

В чём ошибка?

Может-ли быть какая-нибудь несовместимость с этим программатором?

 

Им был оживлён TP-Link 841 ND в этот же день.

Share this post


Link to post
Share on other sites

Ну значит либо физически мертвы, либо бут мёртв и только программатор.

+3.3 на гребёнке роутера это питание приеобразователя (если кабель собран на MAX*232 или аналоге). ТУДА НИЧЕГО ПОДАВАТЬ НЕ НАДО. Т.е. с вашим конвертером к роутеру должно быть 3 проводка GND+RX+TX. Если додумались ещё и VCC ткнуть, то скорее всего либо ваш преобразователь уже труп, либо UART в роутере спалили. Есть шанс что и обошлось.

 

P.S. Я устал говорить, что все вопросы по старым девайсам на 305х адресуйте сразу на support@nag.ru Я к этому творчеству (кроме того что у меня софт стырили и поколечили) отношения не имею и на поддержку его не подписывался.

 

PP.S. Я юзал преобразователи на PL`ке, особых проблем не испытал. Но будьте аккуратны ибо спалить их самих и ими уарт в железке запросто. Гораздо более безопасная схема это MAX*232+любой USB2COM. Такая схема развязана по питанию (максимка питается от роутера, usb2com от компа).

Share this post


Link to post
Share on other sites
Guest Tovictory

Ну значит либо физически мертвы, либо бут мёртв и только программатор.

Спасибо за оперативный ответ.

Как я уже писал выше, мёртый только 1 из двух. Второй был проверен программатором для того, чтобы убедиться, что это не фича, а баг => нужен другой девайсик...

Программатор жив, т.к. после этого я его подключил в тплинк и консоль радостно наполнилась жизнью)

Share this post


Link to post
Share on other sites
Guest Tovictory

Ну значит либо физически мертвы, либо бут мёртв и только программатор.

Спасибо за оперативный ответ.

Как я уже писал выше, мёртый только 1 из двух. Второй был проверен программатором для того, чтобы убедиться, что это не фича, а баг => нужен другой девайсик...

Программатор жив, т.к. после этого я его подключил в тплинк и консоль радостно наполнилась жизнью)

А про +5В на роутер, это я попробовал, т.к. прочёл пост на первой странице, где человек таким же программатором успешно всё восстановил, но у него сразу были иероглифы, и при подключении 5В всё прошилось,.... а у меня пусто.

Share this post


Link to post
Share on other sites

Не надо путать подключение консоли через TTL UART=>RS232 (или как у вас TTL UART => USB SERIAL) конвертер и программатор. Консольный шнур ничем не поможет если бут мёртв и будет тишина. Разберитесь для начала что такое программатор под SPI флэш. А то в ваших сообщениях каша и хрен пойми что делать.

 

После того как попробовали +5 на роутер скорее всего он уже труп окончательно, т.к. на роутере там +3.3 с выхода стабилизатора. А человек писал что у него конкретный экземпляр не заработал с конвертерами на TTL с уровнями 3.3В и он собран переходник на TTL 5В (а не подключил хвост). Я всегда юзают 5В преобразователь на MAX232 + RS232 (http://www.spt.ru/victor/pictures/data-cable-max232.gif) > USB SERIAL отдальным блоком, максимку запитываю от роутера с линии 3,3В (хватает за глаза). Работаю так много лет и не разу не встречал проблем, в отличии от всяких PLок которые сразу с UART TTL в USB SERIAL преобразуют. Так что могу смело рекомендовать. Можно и на MAX3232 оно 3.3В. Тоже работает прекрасно.

 

В общем отдали бы вы девайсы в руки людям которые понимают что делают.

 

и программатор PL2303HX 1446964530634193568.jpg

 

ЭТО НЕ ПРОГРАММАТОР!!!.

Share this post


Link to post
Share on other sites
Guest Tovictory

ОК. Но на живом роутере тоже тишина, почему? Питание от БП роутера, подключение тремя проводами как положено... Однако же....?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now