Добрый день.

Настраиваю Queue Tree и столкнулся со следующей проблемой: трафик не попадает в очередь.

 

Конфигурация:

/ip firewall address-list
add address=192.168.17.201 list=srv_ippbx
add address=172.17.16.0/24 list=net_vpn_usr
add address=172.17.17.0/24 list=net_vpn_usr

/ip firewall mangle
add action=mark-packet chain=prerouting dst-address-list=net_vpn_usr new-packet-mark=igw-down-uvpn-ippbx passthrough=yes src-address-list=srv_ippbx

/queue type
add kind=pcq name=igw-down-uvpn-ippbx pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-src-address6-mask=64

/queue tree
add max-limit=48M name=igw-down parent=global
add max-limit=10M name=igw-down-uvpn parent=igw-down
add limit-at=1M max-limit=5M name=igw-down-uvpn-ippbx packet-mark=igw-down-uvpn-ippbx parent=igw-down-uvpn priority=7 queue=igw-down-uvpn-ippbx

 

Пакеты маркируются, это подтверждают как счетчики правила, так и логи.

Указанное правило маркировки стоит последним, так что перемаркировываться эти пакеты тоже не должны.

 

Но трафика в очереди нет.

Как понять причину?

pic1.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Fasttrack в фаерволе отключили и после этого [соединения сбросили | перезагрузили роутер] ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Fasttrack был отключен давно:

/ip settings pr
              ip-forward: yes
          send-redirects: yes
     accept-source-route: no
        accept-redirects: no
        secure-redirects: yes
               rp-filter: no
          tcp-syncookies: no
    max-neighbor-entries: 8192
             arp-timeout: 30s
         icmp-rate-limit: 10
          icmp-rate-mask: 0x1818
             route-cache: yes
         allow-fast-path: yes
   ipv4-fast-path-active: no
  ipv4-fast-path-packets: 0
    ipv4-fast-path-bytes: 0
   ipv4-fasttrack-active: no
  ipv4-fasttrack-packets: 0
    ipv4-fasttrack-bytes: 0

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Alexey_G , загляните в mangle-forward. Возможно перемаркировка происходит там. Либо вышестоящая очередь с более общим правилом ловит этот трафик.

Изменено пользователем nkusnetsov

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблема действительно была в перемаркировке.

Только цепочка была не forward, а postrouting.

 

Спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти
Подписчики 0