Перейти к содержимому
Калькуляторы

DMM-1701IM-04 не работает TS/IP-1 после восстановления прошивки

Всем привет. Прошу совета.

Обновляли 2 модуля до прошивки 37, минуя 2B. Оба перестали загружаться. Восстановили с консоли методом замены pbiinit.db. После восстановления:

1. Не работает TS/IP-1 - на коммутаторе не виден мак и нет ни одного входящего пакета на порту. Control TS/IP-2 работает нормально.

2. При сбросе в Factory defaults, настройки сетевых интерфейсов не меняются, что через web, что с джойстика. Вручную меняются.

Прошивку заливали 2B, 37, 39 - без изменений. Консоль подключали в верхний разъем.

Что еще можно попробовать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я бы рискнул выкинуть и забыть как страшный сон продукцию PBI ,

но думаю вряд ли Вы согласитесь ...

 

зачем Вы это говнище покупаете я ума не приложу ???

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
20 минут назад, sky star сказал:

я бы рискнул выкинуть и забыть как страшный сон продукцию PBI ,

но думаю вряд ли Вы согласитесь ...

 

зачем Вы это говнище покупаете я ума не приложу ???

Что можно купить в качестве ird, кроме pbi?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
24 минуты назад, sky star сказал:

я бы рискнул выкинуть и забыть как страшный сон продукцию PBI

У себя в Валиноре можете выбрасывать что угодно, не спрашивая мнения работодателя.

25 минут назад, sky star сказал:

зачем Вы это говнище покупаете я ума не приложу ???

Мы любим страдать, не мешайте.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 29.08.2017 в 06:08, s2n сказал:

Что еще можно попробовать?

Вот тут ребята восстановлением занимались. Может поможет

https://cesbo.com/forum/topic/1174-pbi-dmm-1701im-искусство-плакать/?page=3

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
8 часов назад, fatman80 сказал:

Вот тут ребята восстановлением занимались. Может поможет

https://cesbo.com/forum/topic/1174-pbi-dmm-1701im-искусство-плакать/?page=3

Читал. Попробовал воткнуть консоль в нижний разъем - удалось поднять интерфейс и залить конфиг и прошивку, однако после перезагрузки интерфейс снова не работает, хотя и загрузилось нормально, судя по логу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

мог просто не подняться встроенный веб-сервер. Если с программатора все ок, то нужно просто прописать правильную команду в консоли.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я такое наблюдал с 39-ой прошивкой.

После обновление в морде русует, что потока нет, а на самом деле поток есть и модулятор работает.

Понижение до 37, решало проблему.

 

У вас после обновления, точно меняется ядро и другие компоненты? Гляньте в морде.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Цитата

мог просто не подняться встроенный веб-сервер

Control работает нормально, см. выше.

4 часа назад, Zuhell сказал:

После обновление в морде русует, что потока нет, а на самом деле поток есть и модулятор работает.

Интерфейс не пингуется даже, т.е. в системе он в DOWN.

 

Игрался тут с конфигурацией pbiinit.db на живом модуле. Конкретно, надо было поменять МАК на TS/IP-1. В общем, если заливать конфиг на управляющий интерфейс, то в веб-морде МАК виден новый, а на порту коммутатора светится вполне себе старый) Т.е. конфиг нужно ложить в обе системы, факт. Подозреваю, что и образ 1701PM.bin заливать - тоже.

 

Кто знает, как в консоли попасть в шелл после нормальной загрузки? Какая команда?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 02.09.2017 в 01:24, s2n сказал:

Control работает нормально, см. выше.

Интерфейс не пингуется даже, т.е. в системе он в DOWN.

 

Игрался тут с конфигурацией pbiinit.db на живом модуле. Конкретно, надо было поменять МАК на TS/IP-1. В общем, если заливать конфиг на управляющий интерфейс, то в веб-морде МАК виден новый, а на порту коммутатора светится вполне себе старый) Т.е. конфиг нужно ложить в обе системы, факт. Подозреваю, что и образ 1701PM.bin заливать - тоже.

 

Кто знает, как в консоли попасть в шелл после нормальной загрузки? Какая команда?

Любую команду в консоли можно вводить через shell " --- " (команда пишется в кавычках, вместо знака тире)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 05.09.2017 в 16:28, SirShadow сказал:

Любую команду в консоли можно вводить через shell " --- " (команда пишется в кавычках, вместо знака тире)

 Благодарю, смог увидеть что интерфейс поднят и работает с неправильным IP адресом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 02.09.2017 в 02:41, Zuhell сказал:

Понижение до 37, решало проблему.

Понизил, заработал IGMP на обоих интерфейсах. Но зато умерла веб-морда(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вобщем, всем кто будет экспериментировать с pbiinit.db:

 

1. Восстанавливать (перезаливать) файл нужно не только на первом интерфейсе, но и на втором (нижний консольный разъем).

 

2. Образы не знают о существовании друг друга, каждый считает свой интерфейс eth0.

 

3. Все операции с настройками и обновление прошивки ЖЕЛАТЕЛЬНО делать через веб-интерфейс, т.к. только он знает о наличии второй системы и пишет в нее.

 

4. При операциях с pbiinit.db их нужно дублировать для обеих систем, причем для второй - настройки (MAC, IP) необходимо записывать в поля, предназначенные для ПЕРВОГО интерфейса (см. п.2).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за информацию.

Прошивки выше 39 у вас нет в наличии?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не появилось прошивка?

Изменено пользователем Zuhell

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Перешил несколько модулей через telnet.

Проблем с отвалом интерфейсов при перепрошивке ни разу не было.

Первое, что бросилось в глаза после перепрошивки - перелопатили snmp-сервер:

1)Через web-интерфейс стало можно включать snmp-trapы, правда свои комьюнити можно создать только редактируя pbiinit.db

2) Поменялись OIDы при работе по snmp по сравнению с версией 2B

Ветка .1.3.6.1.4.1.38295.15 поменялась на .1.3.6.1.4.1.38295.46

3) Часть OID перестала отдавать значения, например битрейт потока

4) При запросе некоторых OID snmp-сервер и web-сервер перестают отвечать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 13.03.2018 в 08:35, fatman80 сказал:

Перешил несколько модулей через telnet.

Проблем с отвалом интерфейсов при перепрошивке ни разу не было.

Первое, что бросилось в глаза после перепрошивки - перелопатили snmp-сервер:

1)Через web-интерфейс стало можно включать snmp-trapы, правда свои комьюнити можно создать только редактируя pbiinit.db

2) Поменялись OIDы при работе по snmp по сравнению с версией 2B

Ветка .1.3.6.1.4.1.38295.15 поменялась на .1.3.6.1.4.1.38295.46

3) Часть OID перестала отдавать значения, например битрейт потока

4) При запросе некоторых OID snmp-сервер и web-сервер перестают отвечать.

Насколько я знаю, с этой версией прошивки идут отдельные mib файлы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 28.03.2018 в 10:29, SirShadow сказал:

Насколько я знаю, с этой версией прошивки идут отдельные mib файлы.

Да, но дело не в MIB-файлах, а в snmp-сервере модуля, который перестал отдавать некоторые значения, которые можно было использовать для мониторинга.

 

Несколько недель тестирования показали:

1)Пока ни разу не проявлялась проблема с самостоятельным переключением на другой канал из MPTS-потока. На 2B такое случалось.

2)Пропадание звука через несколько дней на аналоговом выходе на потоках с VBR и/или большим разбросом PCR Jitter сохранились.

3)Сохранилось появление заикания звука через сутки-двое на некоторых каналах с региональными вставками из первого мультиплекса РТРС-1(там битрейт постоянный и PCR Jitter в норме)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
12 часов назад, fatman80 сказал:

1)Пока ни разу не проявлялась проблема с самостоятельным переключением на другой канал из MPTS-потока. На 2B такое случалось.

2)Пропадание звука через несколько дней на аналоговом выходе на потоках с VBR и/или большим разбросом PCR Jitter сохранились.

3)Сохранилось появление заикания звука через сутки-двое на некоторых каналах с региональными вставками из первого мультиплекса РТРС-1(там битрейт постоянный и PCR Jitter в норме)

сколь шляпу не перекрашивай - шляпой оно и останется

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 29.03.2018 в 14:05, fatman80 сказал:

Да, но дело не в MIB-файлах, а в snmp-сервере модуля, который перестал отдавать некоторые значения, которые можно было использовать для мониторинга.

 

Несколько недель тестирования показали:

1)Пока ни разу не проявлялась проблема с самостоятельным переключением на другой канал из MPTS-потока. На 2B такое случалось.

2)Пропадание звука через несколько дней на аналоговом выходе на потоках с VBR и/или большим разбросом PCR Jitter сохранились.

3)Сохранилось появление заикания звука через сутки-двое на некоторых каналах с региональными вставками из первого мультиплекса РТРС-1(там битрейт постоянный и PCR Jitter в норме)

По SNMP спорить не буду, а вот по:

 

- 2му пункту - а что удивительного? Вы, все-таки, модулируете сигнал в несущую, а не передаете его для просмотра в IPTV, где потери не возникают благодаря буферам. Это нормальное ведь, вроде как, явление, что если поток не соответствует TR 101290 и RFC 4445 - то могут быть проблемы. Я бы сказал, что у этих модулей, пока что, самое терпимое к входящему потоку отношение среди всех IP-PAL...

 

- 3му пункту тоже не совсем понятно при чем тут сам модуль... Вы же сами утверждаете, что проблема наблюдается только на каналах с региональными вставками. А их, насколько  мне известно, три штуки. И если Вы проведете анализ этих каналов не только по TR 101290, но и по RFC 4445 - то заметите причину. Где растут ноги этой причины, думаю, не сложно догадаться :) Причем, кстати, уже не в таком большом количестве регионов, как было раньше.

 

12 часов назад, sky star сказал:

сколь шляпу не перекрашивай - шляпой оно и останется

Это разумеется, но, блин, нельзя же вешать внешние, не относящиеся к нему проблемы на, хоть и кривоватое, но все-таки иногда работающее железо :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
8 минут назад, SirShadow сказал:

Это разумеется, но, блин, нельзя же вешать внешние, не относящиеся к нему проблемы на, хоть и кривоватое, но все-таки иногда работающее железо :)

Мои посты не обвинительные или ругательные.

Просто описываю, что имею. Может кому-то поможет.

Что-то народ не больно спешит делиться опытом эксплуатации :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 минут назад, fatman80 сказал:

Мои посты не обвинительные или ругательные.

Просто описываю, что имею. Может кому-то поможет.

Что-то народ не больно спешит делиться опытом эксплуатации :)

Я понимаю, просто хочу призвать Вас оценивать именно саму железку, а не внешние факторы :)

 

А то ведь, не все будут отфильтровывать, так сразу и решат что это проблемы модуля, а не регионального РТРС или правильной подачи потоков на модуль

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас