Jump to content
Калькуляторы

cisco ospf

Добрый день!

 

Хочу сделать резервирование каналов через ospf.

Хочу чтоб локалка за роутером А была доступна через два канала между А и B. а роутер B был дефолтным маршрутом.

Соседство устанавливается, но маршруты не анонсятся. Что я делаю не так?

 

Роутер А:

Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.1(3)T, RELEASE SOFTWARE (fc1)

interface Tunnel1
desc Канал 1 
ip address 192.168.100.10 255.255.255.252
ip ospf network point-to-point
tunnel source 10.23.200.162
tunnel destination 10.23.200.42

interface Vlan1
description Локалка
ip address 172.18.24.1 255.255.255.0
!
interface Vlan2
description Канал 2
ip address 192.168.101.102 255.255.255.252
ip ospf network point-to-point

router ospf 1
passive-interface default
no passive-interface Tunnel1
no passive-interface Vlan2
network 172.18.0.0 0.0.255.255 area 0
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0

 

 

Роутер Б

Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)

interface Tunnel22
ip address 192.168.100.9 255.255.255.252
ip ospf network point-to-point
tunnel source 10.23.200.42
tunnel destination 10.23.200.162

interface FastEthernet0/0
ip address 192.168.101.101 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto

router ospf 1
router-id 255.255.255.255
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Tunnel22
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0
default-information originate

Share this post


Link to post
Share on other sites

Добрый день!

 

Хочу сделать резервирование каналов через ospf.

Хочу чтоб локалка за роутером А была доступна через два канала между А и B. а роутер B был дефолтным маршрутом.

Соседство устанавливается, но маршруты не анонсятся. Что я делаю не так?

 

Роутер А:

Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.1(3)T, RELEASE SOFTWARE (fc1)

interface Tunnel1
desc Канал 1 
ip address 192.168.100.10 255.255.255.252
ip ospf network point-to-point
tunnel source 10.23.200.162
tunnel destination 10.23.200.42

interface Vlan1
description Локалка
ip address 172.18.24.1 255.255.255.0
!
interface Vlan2
description Канал 2
ip address 192.168.101.102 255.255.255.252
ip ospf network point-to-point

router ospf 1
passive-interface default
no passive-interface Tunnel1
no passive-interface Vlan2
network 172.18.0.0 0.0.255.255 area 0
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0

 

 

Роутер Б

Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)

interface Tunnel22
ip address 192.168.100.9 255.255.255.252
ip ospf network point-to-point
tunnel source 10.23.200.42
tunnel destination 10.23.200.162

interface FastEthernet0/0
ip address 192.168.101.101 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto

router ospf 1
router-id 255.255.255.255
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Tunnel22
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0
default-information originate

в протоколе OSPF

redistribute connected

redistribute static

после этих команд OSPF подхватит (произойдет редистрибьюция, show ip ospf database) из ТМ маршруты помеченные S,C (show ip route) и объявит соседям

Edited by QWE

Share this post


Link to post
Share on other sites

На вид какая-то Каша. Конфиги не полные. Может стоит начать с рисунка и расписывания интерфейсов?

Share this post


Link to post
Share on other sites

команда network 172.18.0.0 0.0.255.255 area 0 на Роутере А не нужна. У Вас же в локалке не будет OSPF соседей?

Share this post


Link to post
Share on other sites

Наверное таки redistribute static subnets и redistribute connected subnets :0 но да. оно тут не нужно.

 

default-information originate

у вас дефолт в таблице маршрутизации на Б есть?

Share this post


Link to post
Share on other sites

QWE там вроде как passive-interface default

Какой смысл команды network 172.18.0.0 0.0.255.255 area 0 на Роутере А ?

Видимо автор топика считает - что эта команда должна заставить OSPF объявить сети/подсети(subnets) соседям.

Edited by QWE

Share this post


Link to post
Share on other sites

Наверное таки redistribute static subnets и redistribute connected subnets :0 но да. оно тут не нужно.

 

default-information originate

у вас дефолт в таблице маршрутизации на Б есть?

да subnets

Разве Важно что бы был дефолт в ТМ? И для чего?

Я так понимаю смысл Вашего вопроса в том что если в ТМ дефолта нет то OSPF его никому не объявит.

Edited by QWE

Share this post


Link to post
Share on other sites

Using default-information originate will advertise a default route, if there is one in the routing table. By adding the 'always' the default will be advertised even if there is no default route in the table.

Share this post


Link to post
Share on other sites

QWE смысл - без команды redistribute распространить информацию о 172.18.0.0 в LSA 1.

Edited by purecopper

Share this post


Link to post
Share on other sites

Выкладываю полностью конфиги, относящееся к теме выделил жирным.

 

Роутер А

[b]interface Tunnel1
description Канал 1
ip address 192.168.100.10 255.255.255.252
ip ospf network point-to-point
tunnel source 10.23.200.162
tunnel destination 10.23.200.42[/b]
!
interface Tunnel2
ip address 192.168.100.29 255.255.255.252
tunnel source 10.23.200.162
tunnel destination 10.23.200.102
!
interface Tunnel3
description 
ip address 192.168.100.42 255.255.255.252
tunnel source 10.23.200.162
tunnel destination 10.23.200.146
!
interface Tunnel4
description 
ip address 192.168.100.49 255.255.255.252
tunnel source 10.23.200.162
tunnel destination 10.23.200.2
!
interface Tunnel5
description 
ip address 192.168.100.85 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.50
!
interface Tunnel6
description 
ip address 192.168.100.105 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.98
!
interface Tunnel7
description 
ip address 192.168.100.69 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.154
!
interface Tunnel8
description 
ip address 192.168.100.157 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.122
!
interface Tunnel9
description 
ip address 192.168.100.57 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.74
!
interface Tunnel10
description 
ip address 192.168.100.205 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.54
!
interface Tunnel11
description 
ip address 192.168.101.5 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.62
!
interface Tunnel12
description 
ip address 192.168.101.13 255.255.255.252
tunnel source FastEthernet4
tunnel destination 10.23.200.58
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
switchport access vlan 2
!
interface FastEthernet4
description Rostelecom
ip address 10.23.200.162 255.255.255.252
duplex auto
speed auto
!
[b]interface Vlan1
description Localnet 172.18.24.0/24
ip address 172.18.24.1 255.255.255.0
!
interface Vlan2
description Канал 2
ip address 192.168.101.102 255.255.255.252
ip ospf network point-to-point
!
router ospf 1
redistribute connected subnets
passive-interface default
no passive-interface Tunnel1
no passive-interface Vlan2
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0[/b]
!
ip forward-protocol nd
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip route 0.0.0.0 0.0.0.0 192.168.100.9
ip route 10.23.0.0 255.255.0.0 10.23.200.161
ip route 172.18.5.0 255.255.255.0 192.168.100.50
ip route 172.18.8.0 255.255.255.0 192.168.100.70
ip route 172.18.14.0 255.255.255.0 192.168.100.86
ip route 172.18.16.0 255.255.255.0 192.168.101.14
ip route 172.18.17.0 255.255.255.0 192.168.101.6
ip route 172.18.19.0 255.255.255.0 192.168.100.41
ip route 172.18.20.0 255.255.255.0 192.168.100.58
ip route 172.18.26.0 255.255.255.0 192.168.100.106
ip route 172.18.27.0 255.255.255.0 192.168.100.30
ip route 172.18.32.0 255.255.255.0 192.168.100.158
ip route 172.18.34.0 255.255.255.0 192.168.100.206
!
end

 

 

Роутер Б

interface Tunnel21
description to 
ip address 192.168.100.1 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.146
!
[b]interface Tunnel22
description to Канал 1
ip address 192.168.100.9 255.255.255.252
ip ospf network point-to-point
tunnel source 10.23.200.42
tunnel destination 10.23.200.162[/b]
!
interface Tunnel23
description to 
ip address 192.168.100.5 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.74
!
interface Tunnel24
description to 
ip address 192.168.100.21 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.154
!
interface Tunnel25
description to 
ip address 192.168.100.137 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.50
!
interface Tunnel26
description to 
ip address 192.168.100.13 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.98
!
interface Tunnel27
description to 
ip address 192.168.100.17 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.102
!
interface Tunnel28
description to 
ip address 192.168.100.149 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.122
!
interface Tunnel30
description to 
ip address 192.168.100.133 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.2
!
interface Tunnel31
description to 
ip address 192.168.101.21 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.150
!
interface Tunnel32
description to 
ip address 192.168.100.185 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.158
!
interface Tunnel33
description to 
ip address 192.168.101.9 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.58
!
interface Tunnel34
description to 
ip address 192.168.100.201 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.54
!
interface Tunnel35
description to 
ip address 192.168.101.1 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.62
!
interface Tunnel36
description to 
ip address 192.168.101.29 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.46
!
interface Tunnel37
description to 
ip address 192.168.101.33 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.110
!
interface Tunnel38
description to 
ip address 192.168.100.189 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.66
!
interface Tunnel39
description to 
ip address 192.168.100.217 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.6
!
interface Tunnel40
description to 
ip address 192.168.101.69 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.118
!
interface Tunnel41
description to 
ip address 192.168.100.229 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.106
!
interface Tunnel42
description to 
ip address 192.168.100.253 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.22
!
interface Tunnel43
description to 
ip address 192.168.100.241 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.18
!
interface Tunnel44
description to 
ip address 192.168.101.53 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.82
!
interface Tunnel45
description to 
ip address 192.168.101.45 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.78
!
interface Tunnel46
description to 
ip address 192.168.101.61 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.86
!
interface Tunnel47
description to 
ip address 192.168.101.89 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.26
!
interface Tunnel48
description to 
ip address 192.168.101.81 255.255.255.252
tunnel source 10.23.200.42
tunnel destination 10.23.200.126
!
[b]interface FastEthernet0/0
description Канал 2
ip address 192.168.101.101 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto[/b]
!
interface FastEthernet0/1
description Trunk to 3560 (10,2597)
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 172.18.62.68 255.255.255.240
no cdp enable
!
interface FastEthernet0/1.2597
encapsulation dot1Q 2597
ip address 10.23.200.42 255.255.255.252
no cdp enable
!
[b]router ospf 1
router-id 255.255.255.255
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Tunnel22
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0
default-information originate always[/b]
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.18.62.65
ip route 10.23.0.0 255.255.0.0 10.23.200.41
ip route 172.18.0.0 255.255.255.0 172.18.62.67
ip route 172.18.1.0 255.255.255.0 192.168.100.218
ip route 172.18.2.0 255.255.255.0 192.168.100.230
ip route 172.18.3.0 255.255.255.0 192.168.100.186
ip route 172.18.4.0 255.255.255.0 192.168.100.242
ip route 172.18.5.0 255.255.255.0 192.168.100.134
ip route 172.18.6.0 255.255.255.0 192.168.100.254
ip route 172.18.7.0 255.255.255.0 192.168.101.22
ip route 172.18.8.0 255.255.255.0 192.168.100.22
ip route 172.18.12.0 255.255.255.0 192.168.101.30
ip route 172.18.14.0 255.255.255.0 192.168.100.138
ip route 172.18.16.0 255.255.255.0 192.168.101.10
ip route 172.18.17.0 255.255.255.0 192.168.101.2
ip route 172.18.18.0 255.255.255.0 192.168.100.190
ip route 172.18.19.0 255.255.255.0 192.168.100.2
ip route 172.18.20.0 255.255.255.0 192.168.100.6
ip route 172.18.21.0 255.255.255.0 192.168.101.46
ip route 172.18.22.0 255.255.255.0 192.168.101.54
ip route 172.18.23.0 255.255.255.0 192.168.101.62
ip route 172.18.24.0 255.255.255.0 192.168.100.10
ip route 172.18.26.0 255.255.255.0 192.168.100.14
ip route 172.18.27.0 255.255.255.0 192.168.100.18
ip route 172.18.29.0 255.255.255.0 192.168.101.34
ip route 172.18.30.0 255.255.255.0 192.168.101.90
ip route 172.18.31.0 255.255.255.0 192.168.101.70
ip route 172.18.32.0 255.255.255.0 192.168.100.150
ip route 172.18.33.0 255.255.255.0 192.168.101.82
ip route 172.18.34.0 255.255.255.0 192.168.100.202
ip route 172.18.35.0 255.255.255.0 172.18.62.67
ip route 172.18.36.32 255.255.255.224 172.18.62.67
ip route 172.18.58.0 255.255.255.0 172.18.62.67
ip route 172.18.61.0 255.255.255.0 172.18.62.67
ip route 172.18.62.32 255.255.255.252 192.168.100.14
ip route 172.18.63.0 255.255.255.0 172.18.62.67
ip route 172.18.64.0 255.255.192.0 172.18.62.66
ip route 172.18.90.0 255.255.255.0 172.18.62.66
ip route 172.18.91.0 255.255.255.0 172.18.62.66
ip route 172.18.128.0 255.255.192.0 172.18.62.66
ip route 172.18.192.0 255.255.224.0 172.18.62.66
ip route 172.18.224.0 255.255.224.0 172.18.62.66
ip route 172.30.32.0 255.255.224.0 172.18.62.66

 

При таком раскладе имеем на А:

cisco#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
      + - replicated route, % - next hop override

Gateway of last resort is 192.168.100.9 to network 0.0.0.0

 

 

на Б:

[b]cisco-router(config)#do sh ip route ospf
    10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O E2    10.23.200.160/30
          [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
    192.168.100.0/30 is subnetted, 25 subnets
O E2    192.168.100.28 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.40 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.56 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.48 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.68 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.84 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.104
          [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.156
          [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.100.204
          [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
    192.168.101.0/30 is subnetted, 14 subnets
O E2    192.168.101.12 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0
O E2    192.168.101.4 [110/20] via 192.168.101.102, 00:15:20, FastEthernet0/0[/b]

Почему на Б нет маршрута на 172.18.24.0/24? А на А дефолта?

Share this post


Link to post
Share on other sites

Потому что у вас статический дефолт. АД почитайте , что такое.

В тм маршрут с наименьшим ад

 

Оспф маршрут не заменит статику с ад дефолтным.

Share this post


Link to post
Share on other sites

а в show ip ospf database видны маршруты которые должны объявляться соседям,

т.е. на А в LSADB есть маршрут к 172.18.24.0?

попробуйте

ip subnet-zero

ip classless

 

На А дефолт в LSADB есть?

Edited by QWE

Share this post


Link to post
Share on other sites

Покажите пожалуйста show ip ospf dat с обоих роутеров.

Что циски пишут в логи? Рекурсии случайно не возникает?

Share this post


Link to post
Share on other sites

А:

#do sh ip ospf da

 

OSPF Router with ID (192.168.101.102) (Process ID 1)

 

Router Link States (Area 0)

 

Link ID ADV Router Age Seq# Checksum Link count

192.168.101.102 192.168.101.102 974 0x80000029 0x00BEC9 4

255.255.255.255 255.255.255.255 235 0x8000001A 0x00D972 4

 

Type-5 AS External Link States

 

Link ID ADV Router Age Seq# Checksum Tag

0.0.0.0 255.255.255.255 724 0x80000017 0x000F8D 1

10.23.200.160 192.168.101.102 974 0x80000003 0x001BC6 0

172.18.24.0 192.168.101.102 974 0x80000003 0x00058D 0

192.168.100.28 192.168.101.102 974 0x80000003 0x007E04 0

192.168.100.40 192.168.101.102 974 0x80000003 0x000670 0

192.168.100.48 192.168.101.102 974 0x80000003 0x00B5B8 0

192.168.100.56 192.168.101.102 974 0x80000003 0x006501 0

192.168.100.68 192.168.101.102 974 0x80000003 0x00EC6D 0

192.168.100.84 192.168.101.102 974 0x80000003 0x004CFD 0

192.168.100.104 192.168.101.102 974 0x80000003 0x0083B2 0

192.168.100.156 192.168.101.102 974 0x80000003 0x007988 0

192.168.100.204 192.168.101.102 974 0x80000003 0x00973A 0

192.168.101.4 192.168.101.102 974 0x80000003 0x006435 0

192.168.101.12 192.168.101.102 974 0x80000003 0x00147D 0

 

 

Б:

cisco-router#sh ip ospf database

 

OSPF Router with ID (255.255.255.255) (Process ID 1)

 

Router Link States (Area 0)

 

Link ID ADV Router Age Seq# Checksum Link count

192.168.101.102 192.168.101.102 1027 0x80000029 0x00BEC9 4

255.255.255.255 255.255.255.255 286 0x8000001A 0x00D972 4

 

Type-5 AS External Link States

 

Link ID ADV Router Age Seq# Checksum Tag

0.0.0.0 255.255.255.255 776 0x80000017 0x000F8D 1

10.23.200.160 192.168.101.102 1027 0x80000003 0x001BC6 0

172.18.24.0 192.168.101.102 1027 0x80000003 0x00058D 0

192.168.100.28 192.168.101.102 1027 0x80000003 0x007E04 0

192.168.100.40 192.168.101.102 1027 0x80000003 0x000670 0

192.168.100.48 192.168.101.102 1027 0x80000003 0x00B5B8 0

192.168.100.56 192.168.101.102 1027 0x80000003 0x006501 0

192.168.100.68 192.168.101.102 1027 0x80000003 0x00EC6D 0

192.168.100.84 192.168.101.102 1027 0x80000003 0x004CFD 0

192.168.100.104 192.168.101.102 1027 0x80000003 0x0083B2 0

192.168.100.156 192.168.101.102 1027 0x80000003 0x007988 0

192.168.100.204 192.168.101.102 1027 0x80000003 0x00973A 0

192.168.101.4 192.168.101.102 1027 0x80000003 0x006435 0

192.168.101.12 192.168.101.102 1027 0x80000003 0x00147D 0

 

попробуйте

ip subnet-zero

ip classless

не помогло

Share this post


Link to post
Share on other sites

удалите на Б маршрут no ip route 172.18.24.0 255.255.255.0 192.168.100.10

удалите так же дефолт ip route 0.0.0.0 0.0.0.0 172.18.62.65 или перевоткните его с худшим АД ip route 0.0.0.0 0.0.0.0 172.18.62.65 111

 

на А удалите ip route 0.0.0.0 0.0.0.0 192.168.100.9

Edited by QWE

Share this post


Link to post
Share on other sites

смысл - без команды redistribute распространить информацию о 172.18.0.0 в LSA 1.

Вам шашечки или ехать? вы объявили network /16, при этом пытаетесь скормить т.н. more-specific /24, да еще и indirect connected, т.е. static. Мне как-то давно попадалась статейка из серии "Best Practices" где через network анонсили сети как internal, но в той статейке это было применительно к direct connected сети, в то время как вы скармливаете static.

Когда устанете биться с текущей конфигурацией, попробуйте такой вариант:

роутер А

router ospf 1
redistribute connected subnets
redistribute static subnets
passive-interface default
no passive-interface Tunnel1
no passive-interface Vlan2
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0
distribute list 11 out static
!
access-list 11 permit 172.18.0.0 0.0.255.255

 

роутер Б

router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Tunnel22
network 192.168.100.8 0.0.0.3 area 0
network 192.168.101.100 0.0.0.3 area 0
default-information originate always

 

И router-id лучше указать реально-существующего интерфейса (желательно, если это будет loopback интерфейс), отсебятину никто не любит.

Да, в этом случае вы получите анонс стопки 172.18.x/24 как external, но оно будет работать. Если вам критично получить 1 префикс в анонсах, можно дополнить роутер А следующим конфигом:

router ospf 1
summary-address 172.18.0.0 255.255.0.0
...
ip route 172.18.0.0 255.255.0.0 null0

 

Если вы не хотите на роутере Б делать default-informations originate always, то наличие дефолта придется явно указать,

будь то ip route 0.0.0.0 0.0.0.0 в сторону имеющегося шлюза, либо, например, в null0 если у вас там по bgp прилетает fv.

Share this post


Link to post
Share on other sites

Б:

cisco-router#sh ip ospf database

 

OSPF Router with ID (255.255.255.255) (Process ID 1)

 

Router Link States (Area 0)

 

Link ID ADV Router Age Seq# Checksum Link count

192.168.101.102 192.168.101.102 1027 0x80000029 0x00BEC9 4

255.255.255.255 255.255.255.255 286 0x8000001A 0x00D972 4

 

Type-5 AS External Link States

 

Link ID ADV Router Age Seq# Checksum Tag

...

172.18.24.0 192.168.101.102 1027 0x80000003 0x00058D 0

 

Как видим маршрут от А присутствует на Б, OSPF-у на Б осталось его воткнуть в ТМ. НО в ТМ сидит лучший маршрут к 172.18.24.0/24 который забит статикой.

Edited by QWE

Share this post


Link to post
Share on other sites

смысл - без команды redistribute распространить информацию о 172.18.0.0 в LSA 1.

Вам шашечки или ехать? вы объявили network /16, при этом пытаетесь скормить т.н. more-specific /24, да еще и indirect connected, т.е. static. Мне как-то давно попадалась статейка из серии "Best Practices" где через network анонсили сети как internal, но в той статейке это было применительно к direct connected сети, в то время как вы скармливаете static.

Дык вот же оно у ТС:

interface Vlan1

description Локалка

ip address 172.18.24.1 255.255.255.0

!

Вроде как оно должно улететь в IGP. Я могу ошибаться - сижу на джуне.

Share this post


Link to post
Share on other sites

Давно отказались от OSPF в сторону BGP на приват AS - там сразу настолько все удобнее в плане приоритетов.

Share this post


Link to post
Share on other sites

Full mesh на iBGP делаете?

Наверное, два роут-рефлектора, как у всех.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this