Jump to content
Калькуляторы

Маршрутизатор Cisco в режиме моста

Всем привет!

 

Бьюсь несколько дней над задачей и все никак, пришло время спросить гуру.

 

Оборудование: Cisco router 7201.

Задача: сконфигурировать 2 порта мостом и иметь возможность резать скорость на проходящем vlan, или группе проходящих vlan через этот мост.

 

Что сделано:

Мост работает (пока только 14 vlan)

 

Что требуется: Ограничить скорость в этом vlan

 

 

Конфигурация:

 

class-map match-all Internet_limit

match vlan 14

!

!

policy-map Internet_5

class Internet_limit

police 1024000 153600 307200 conform-action transmit exceed-action drop violate-action drop

class class-default

police 1024000 153600 307200 conform-action transmit exceed-action drop violate-action drop

!

bridge irb

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

no ip route-cache cef

no ip route-cache

duplex full

speed auto

!

interface GigabitEthernet0/0

no ip address

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

media-type rj45

negotiation auto

!

interface GigabitEthernet0/0.14

description OTPSPD

encapsulation dot1Q 14

no ip route-cache

bridge-group 1

service-policy input Internet_5

service-policy output Internet_5

!

interface GigabitEthernet0/1

no ip address

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

media-type rj45

negotiation auto

!

interface GigabitEthernet0/1.14

encapsulation dot1Q 14

no ip route-cache

bridge-group 1

service-policy input Internet_5

service-policy output Internet_5

!

interface GigabitEthernet0/2

no ip address

no ip route-cache cef

no ip route-cache

shutdown

duplex auto

speed auto

negotiation auto

!

interface GigabitEthernet0/3

no ip address

no ip route-cache cef

no ip route-cache

shutdown

duplex auto

speed auto

negotiation auto

!

interface BVI1

no ip address

service-policy input Internet_5

service-policy output Internet_5

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

!

!

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

!

end

 

Как видно policy выставлены, даже с BVI интерфейсов (а вдруг))) )

Вобщем не хотит роутер резать скорость.

Edited by bbober25

Share this post


Link to post
Share on other sites

1. Зарезать только на input на 2х интерфейсах 0/0.14 и 0/1.14

2. Вместо bvi собрать ccc

connect test GigabitEthernet 0/0.14 GigabitEthernet 0/1.14

Share this post


Link to post
Share on other sites

Всем привет!

 

Вы же не коммутатор настраиваете а сабинтерфейсы - match vlan это лишнее КМК.

Достаточно типа

policy-map 1024K

class class-default

police cir 1024000 bc 256000 conform-action transmit exceed-action drop

 

и повесить только на выход на обоих сабах.

Share this post


Link to post
Share on other sites

1. Зарезать только на input на 2х интерфейсах 0/0.14 и 0/1.14

2. Вместо bvi собрать ccc

connect test GigabitEthernet 0/0.14 GigabitEthernet 0/1.14

 

если реализовывать так, как вы описали, то получается ограничить можно только один проходящий вилан.

Задача стоит ограничивать скорость по группам виланов. Ниже приблизительная схема. Как это реализовать пока не могу понять.

post-138646-062121800 1500013237_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this