Jump to content
Калькуляторы

Почему не работает форвард зоны в BIND?

У меня есть DNS-сервер dnsmasq для одной небольшой зоны sub.domain.ru.

Мне нужно форвардить на него запросы с основных DNS-серверов.

Делаю так (10.1.128.13 - это dnsmasq):

zone "sub.domain.ru." { type forward; forwarders { 10.1.128.13; }; };

Ошибок конфигурации не выдает, но и не работает, имена из sub.domain.ru не ресолвит, говорит NXDOMAIN.

Причем на 10.1.128.13 запросы вообще не приходят.

В логах ошибок нет, просто не работает.

У меня было предположение, что если BIND получает запрос с одного интерфейса (внешнего), он с него и пытается сделать пересылку. Но даже если делать запросы на внутреннем интерфейсе 10.1.128.11, все-равно не работает.

 

Рекурсия в глобальных настройках выключена, но по идее forward это не рекурсивный запрос.

Но на всякий случай рекурсию разрешал - не помогло.

 

На 10.1.128.13 DNS работает, если с 10.1.128.11 выполнить nslookup test.sub.domain.ru 10.1.128.13, он ресолвится.

Share this post


Link to post
Share on other sites

На 10.1.128.13 ничего — на него запросы не приходят.

На 10.1.128.11 исходящих пакетов тоже нет.

Впечатление, что forward просто не указан в конфигурации.

Share this post


Link to post
Share on other sites

А в конфигах зон Вашего bind-а есть упоминания зоны "domain.ru" или clue-records на "sub.domain.ru". Кто держит зону "domain.ru" ?

Share this post


Link to post
Share on other sites

Я думаю, проблема в точке в конце названии зоны.

Share this post


Link to post
Share on other sites

Первоначально я указывал без точки, то же не работало.

Точку добавил потом, она не должна мешать.

 

На всякий случай убрал - не помогло.

Share this post


Link to post
Share on other sites

Что именно не работает?

Вы для начала корректно укажите текущее состоянии.

А то понабирали результатов с разных вариантов.

У меня на бинде форвардинг работает.

Share this post


Link to post
Share on other sites

Сейчас в конфигурации указано так:

zone "sub.domain.ru" { type forward; forward only; forwarders { 10.1.128.13; }; };

Включал/выключал в настройках рекурсию и dnssec, ничего не менялось.

Share this post


Link to post
Share on other sites

Вьюхи не используются случайно?

Share this post


Link to post
Share on other sites

Используются.

Полностью выглядит так:

options {
       ...
       recursion               no;
       dnssec-enable           no;
       dnssec-validation       no;
       ...
};

server 0.0.0.0/0 {
       bogus                   no;
       edns                    no;
       edns-udp-size           1432;
       max-udp-size            1432;
};

view "local" in {
       match-clients           { ... };
       allow-query             { any; };
       allow-transfer          { none; };
       recursion               yes;
       additional-from-auth    yes;
       additional-from-cache   yes;
       zone "."                { type hint; file "/etc/namedb/named.root"; };
       zone "localhost"        { type master; file "/etc/namedb/master/localhost-forward.db"; };
       zone "127.in-addr.arpa" { type master; file "/etc/namedb/master/localhost-reverse.db"; };
       ...
       zone "domain.ru"  { type master; file "/etc/namedb/master/forward/ru.domain"; };
       zone "in-addr.arpa"  { type master; file "/etc/namedb/master/reverse/public"; };
       ...
       // Forwarder for active sessions
       zone "users.domain.ru" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "aa.aa.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "bb.bb.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "cc.cc.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "dd.dd.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };

};

view "world" in {
       match-clients           { any; };
       allow-transfer          { none; };
       ...
       zone "domain.ru"  { type master; file "/etc/namedb/master/forward/ru.domain"; };
       zone "in-addr.arpa"  { type master; file "/etc/namedb/master/reverse/public"; };
       ...
       // Forwarder for active sessions
       zone "users.domain.ru" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "aa.aa.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "bb.bb.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "cc.cc.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };
       zone "dd.dd.in-addr.arpa" { type forward; forward only; forwarders { 10.1.128.13; }; };

};

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this