Jump to content
Калькуляторы

Перезапрос IP при продлении адреса Происходит сброс адреса у клиента, когда он пытается продлить аренду

Добрый день.

Имеется следующая проблема.

Используется ISC DHCP с опцией 82.

На нем настроено время аренды 8 часов, время перезапроса 4 часа. Хочется уменьшить данные временные диапазоны, но есть проблема.

Раз в 4 часа, у всех клиентов происходит DHCPNAK и через секунду выдача адреса по новой. Соответственно теряется доступ к сети.

Перед сервером стоит cisco 3550. Ее настройки

ip dhcp relay information policy keep
ip dhcp relay information trust-all
!
!
ip dhcp snooping vlan 2,10,18-55,160-180,200-220,300-320,400-420,500-520,600
ip dhcp snooping vlan 601-663,700-720,900
ip dhcp snooping
ip dhcp-server 172.16.0.2

interface Loopback0
description Users loopback
ip address 172.16.7.254 255.255.252.0
end
interface Vlan25
description user vlan
ip unnumbered Loopback0
ip helper-address 172.16.0.2
no ip mroute-cache
end
interface GigabitEthernet0/6
 switchport trunk encapsulation dot1q
switchport mode trunk
ip dhcp snooping trust
end

Остальные порты и vlan настроены идентично.

Сервер к ней подключен через порт с конфигурацией

interface GigabitEthernet0/8
description Server
switchport access vlan 2
switchport mode access
ip dhcp snooping trust
end

У клиентов стоят Dlink DES 3526, 3210 и некоторые другие.

Настройка опций

Command: show dhcp_local_relay

DHCP/BOOTP Local Relay Status         : Enabled
DHCP/BOOTP Local Relay VID LIST       : 209

DHCP Relay Agent Information Option 82 Remote ID : "172.16.1.32"

Между Dlink'ами и cisco стоят edge-core - но они просто агрегируют линки и ничего не меняют в пакетах.

Лог с клиента:

May  5 11:16:00 dhcpd: DHCPINFORM from 172.16.4.125 via 172.16.7.254
May  5 11:16:00 dhcpd: DHCPACK to 172.16.4.125 (60:a4:4c:b4:61:3b) via eth1
May  5 14:44:58 dhcpd: DHCPREQUEST for 172.16.4.125 from 60:a4:4c:b4:61:3b via 172.16.7.254: lease 172.16.4.125 unavailable.
May  5 14:44:58 dhcpd: DHCPNAK on 172.16.4.125 to 60:a4:4c:b4:61:3b via 172.16.7.254
May  5 14:44:58 dhcpd: RAW:: Lease for 172.16.4.125agent.circuit-id txt=
May  5 14:44:58 dhcpd: PARS_TEST:: Lease for 172.16.4.125 SWIP=none VLAN=30 PORT=15 PARAM=none MAC=none GPON_MODEM_PORT=none SVLAN=none
May  5 14:44:59 dhcpd: DHCPOFFER on 172.16.4.125 to 60:a4:4c:b4:61:3b (zheka_) via 172.16.7.254
May  5 14:44:59 dhcpd: RAW:: Lease for 172.16.4.125agent.circuit-id txt=
May  5 14:44:59  dhcpd: PARS_TEST:: Lease for 172.16.4.125 SWIP=none VLAN=30 PORT=15 PARAM=none MAC=none GPON_MODEM_PORT=none SVLAN=none
May  5 14:44:59 dhcpd: DHCPREQUEST for 172.16.4.125 (172.16.0.2) from 60:a4:4c:b4:61:3b (zheka_) via 172.16.7.254
May  5 14:44:59 dhcpd: DHCPACK on 172.16.4.125 to 60:a4:4c:b4:61:3b (zheka_) via 172.16.7.254

Как удалось выяснить при анализе, клиент перезапрашивает адрес запросом

DHCPREQUEST for 172.16.4.125 from 60:a4:4c:b4:61:3b via 172.16.7.254: lease 172.16.4.125 unavailable.

и аренда уже ему не доступна, т.к. при выдаче идет запрос DHCPREQUEST for 172.16.4.125 (172.16.0.2) from 60:a4:4c:b4:61:3b (zheka_) via 172.16.7.254

и видимо лиза создается немного другая.

Подскажите куда стоит посмотреть, чтобы победить подобную проблему?

Edited by yurok666

Share this post


Link to post
Share on other sites

Была такая же проблема именно когда на циске включен dhcp snooping для влана, в сторону даунлинка на порту Ip dhcp snooping trust, а саму опцию навешивала нижестоящая железка.

Победить так и не удалось, интересно что скажут другие.

Share this post


Link to post
Share on other sites

Тоже cisco релеит на агрегации, но без dhcp-snooping (зачем он, если опцию вставлять не нужно?). Есть такие свичи на доступе (длинк), которые не умеют юникаст-dhcp, с помощью которого клиент продляет лизу, т.е. запрос на сервер приходит без опции, соответственно от сервера NACK. Это в основном на старых моделях длинков, в том числе 3526, DES-1228/ME/A2. У себя в сети вижу именно такое поведение и на этом старье выдаю по маку.

Edited by infery

Share this post


Link to post
Share on other sites

Потому что не хочу делать ip unnumbered lo0 poll, что б на основе DHCP работало.

Share this post


Link to post
Share on other sites

Потому что не хочу делать ip unnumbered lo0 poll, что б на основе DHCP работало.

А как делаешь? И что на агрегации?

Share this post


Link to post
Share on other sites

Потому что не хочу делать ip unnumbered lo0 poll, что б на основе DHCP работало.

А как делаешь? И что на агрегации?

 

Cisco 4948 на агрегации. IP unnumbered + dhcp relay + dhcp snooping. Но это всё *** и е*** без нормального браса, который будет терминировать кучу вланов и абонов :(

Share this post


Link to post
Share on other sites

Cisco 4948 на агрегации. IP unnumbered + dhcp relay + dhcp snooping. Но это всё *** и е*** без нормального браса, который будет терминировать кучу вланов и абонов :(

Мне без L3 жизни нет - потому как точек агрегации много.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this