Jump to content
Калькуляторы

Router OS + X86 Отзывы

Есть ли какие-либо существенные недостатки при работе Mikrotik RoutrOS на "тазиках" по сравнению с классическими аппаратными решениями от MT?

Share this post


Link to post
Share on other sites

если железо нормально то работать будет стабильнее и производительнее, только количество используемой RAM будет ограничено примерно 1800 Mb. Работает намного адекватнее CCR линейки.

Share this post


Link to post
Share on other sites

Есть ли какие-либо существенные недостатки при работе Mikrotik RoutrOS на "тазиках" по сравнению с классическими аппаратными решениями от MT?

 

наверно самый существенный недостаток, это оперативная память, которой больше 2гб не вставишь.

энергопотребление выше

 

в остальном всё стабильно и более производительно чем CCR

Share this post


Link to post
Share on other sites

А вы не пробовали V6.31 для снятия ограничения по оперативной памяти?

Share this post


Link to post
Share on other sites
Guest Гость

На тазиках одни преимущества. Если жлектричества не жалко

Share this post


Link to post
Share on other sites

А вы не пробовали V6.31 для снятия ограничения по оперативной памяти?

 

на х86 больше 2х гб не поддерживается. Не важно какая версия.

Share this post


Link to post
Share on other sites

Есть ли какие-либо существенные недостатки при работе Mikrotik RoutrOS на "тазиках" по сравнению с классическими аппаратными решениями от MT?

 

Из недостатков только некоторые не стыковки с некоторыми сетевыми адаптерами - в списке устройств у сетевой не определяется MTU, отсюда максимальный размер пакета на передачу идет как 1500 байт, и вланы не этом порту обрезаются. Такое замечено на некоторых, порой не дешевых, 2-4 портовых картах.

Однако обычно дешевые карты и встроенные определяются правильно и работают без проблем. Для исключения этой проблемы лучше всего использовать микротиковский сетевой адаптер на 4 порта.

 

Производительность выше только по факту быстрых ядер, если брать производительность всей системы, то CCR обходит x86 решения. Ведь ядра гипертрединга нужно отключать, а на процессорах среднего ценового диапазона тут остаются либо 2, либо 4 физических ядра.

 

Кроме всего нужно учитывать время перезагрузки - CCR перезапускается намного быстрее, чем x86. Кроме всего у CCR есть оптические порты и много сетевых портов - что иногда перевешивает вопросы производительности - всегда удобно подключать каждый кабель к своему сетевому порту, а не раскидывать вланами с ближайшего коммутатора.

Share this post


Link to post
Share on other sites

время перезагрузки

важнейший аргумент

 

Производительность выше только по факту быстрых ядер, если брать производительность всей системы, то CCR обходит x86 решения

серьезно?

Share this post


Link to post
Share on other sites

серьезно?

 

Конечно. Уже не раз делали замены x86 на CCR, общая скорость работы и объемы трафика возрастали. Это шейпер и PPPoE концентратор. Заводить все задачи на одном устройстве не выгодно по производительности.

Share this post


Link to post
Share on other sites

на х86 больше 2х гб не поддерживается. Не важно какая версия.

Сорри, разумеется тут я имел ввиду x64

Share this post


Link to post
Share on other sites

Существенный недостаток RouterOS на "тазиках", наличие самого RouterOS. Уж если решили ставить x86, ставьте линуксы.

Share this post


Link to post
Share on other sites

Существенный недостаток RouterOS на "тазиках", наличие самого RouterOS. Уж если решили ставить x86, ставьте линуксы.

 

А приведите ка пример настройки линукса, скажем, в роли PPPoE сервера, что бы даже новичок разобрался?

Share this post


Link to post
Share on other sites

Существенный недостаток RouterOS на "тазиках", наличие самого RouterOS. Уж если решили ставить x86, ставьте линуксы.

Был бы в природе Winbox для Linux - ох и тяжко пришлось бы MT. Webmin не считается

Share this post


Link to post
Share on other sites

OPNsense, pfSense, Zeroshell, Devil-Linux, IPFire, VyOS, Endian Firewall Community, Sphirewall firewall, SME Server, NethServer, CentOS итд.

 

А приведите ка пример настройки линукса, скажем, в роли PPPoE сервера, что бы даже новичок разобрался?

Edited by Chexov

Share this post


Link to post
Share on other sites

Производительность выше только по факту быстрых ядер, если брать производительность всей системы, то CCR обходит x86 решения. Ведь ядра гипертрединга нужно отключать, а на процессорах среднего ценового диапазона тут остаются либо 2, либо 4 физических ядра.

 

сааб мы вроде с тобой тему производительности уже порешали.

FX 8350 стоит 11т рублей. Вот тебе 8 ядер, а не 2 и не 4. И работает оно лучше чем i5 3570.

 

Производительность выше только по факту быстрых ядер, если брать производительность всей системы, то CCR обходит x86 решения.

 

тебе скинуть свой конфиг микротика, чтобы твой CCR раком загнулся? Аааа.. Нужно просто второй микротик поставить, точно. Только тогда где производительность всей системы в целом?

 

Кроме всего нужно учитывать время перезагрузки - CCR перезапускается намного быстрее, чем x86.

 

ты это серьёзно? ну секунд 15 презапускается х86 на SSD.

 

Кроме всего у CCR есть оптические порты и много сетевых портов - что иногда перевешивает вопросы производительности - всегда удобно подключать каждый кабель к своему сетевому порту, а не раскидывать вланами с ближайшего коммутатора.

 

а х86 оптических портов то быть не может, да?

 

Я соглашусь, что под определённые задачи CCR гораздо удобнее, но если только не пихать в него всё и сразу.

Share this post


Link to post
Share on other sites

А приведите ка пример настройки линукса, скажем, в роли PPPoE сервера, что бы даже новичок разобрался?

А приведите ка пример настройки микротика, скажем, в роли dhcp сервера, с тремя тысячами вланов.

Share this post


Link to post
Share on other sites

А приведите ка пример настройки линукса, скажем, в роли PPPoE сервера, что бы даже новичок разобрался?

А приведите ка пример настройки микротика, скажем, в роли dhcp сервера, с тремя тысячами вланов.

Песня о старом всю всегда упирается в знания(финансы):D

 

Пример из жизни в мою контору требуется вот такой инженер:

https://tyumen.zarplata.ru/vacancy/card/121149223/Inzhener_uchastka_svyazi?position=13

 

Да у меня пачка шлакротиков CCR1036 2+к абонентов PPPOE 150 виланов. Все работает 24/7 да схема не идеальна, но за те деньги, что я получаю контора согласна меня держать т.к. есть Микротики и не кто не пойдет за эти деньги суда трудится.

 

ПК с линксом на борту спору нет рвет микротик по всем параметрам, но есть главное НО нужно, найти человека, который бы его приготовил. Да и я смогу поднять линукс и создать такой сервер, но есть много нюансов. Juniper MX, который я один внедряю в сеть, чтобы работала: авторизация, флоу, нат, отчетность в билинге нормально ушло много времени, хотя микротик я сварю за минут 15.

 

Можно вечно спорить о этом, но для каждой задачи свой инструмент если нужно загнать 1к пользователей в инет, достаточно двух CCR1036, да схема не идеальна, но работодателю выгодно это т.к. затрат меньше и всегда можно заменить человека.

 

Был горький опыт заганял я 1к пользователей на такой сервер, инженер стучал пяткой в грудь он еще больше прожует. В 8 часов вечера пришлось искать инет, чтобы вернуть все обратно. Да можно затюнить все, но всё упирается в финансы лучше лежать 1 рубль, чем бежать за 1,5

 

З.Ы. Какая должна быть ЗП у инженера, который держит FreeBSD PPPoE, IPoE? Только по чесноку.

З.З.Ы. ИМХО мне х86 не понравился, но работать можно.

микротик х86.jpg

Share this post


Link to post
Share on other sites

Juniper MX, который я один внедряю в сеть, чтобы работала: авторизация, флоу, нат, отчетность в билинге нормально ушло много времени, хотя микротик я сварю за минут 15.

Может потому, что вы не знаете джун, так же как микротик?

Мой гл.инженер поднимает Cisco ядро намного быстрее, чем тот же микротик.

Share this post


Link to post
Share on other sites

Juniper MX, который я один внедряю в сеть, чтобы работала: авторизация, флоу, нат, отчетность в билинге нормально ушло много времени, хотя микротик я сварю за минут 15.

Может потому, что вы не знаете джун, так же как микротик?

Мой гл.инженер поднимает Cisco ядро намного быстрее, чем тот же микротик.

 

Да я не умею его подымать, но много было проблем с билингом, которые с легкостью работают с микротиком. Модель пришлось переделать около 4 раз, либо подождать 1-3 года. Джун очень гибкий роутер, и его большое количество функционала с начало вводит в ступор, на русскоязычном пространстве менее распространен, нежели циска.

 

Так гл.инженер какую ЗП имеет? Для настройки микротика у него уйдет очень мало времени т.к. он популярен и доступен, но за эту работу платят меньше.

Share this post


Link to post
Share on other sites

OPNsense, pfSense, Zeroshell, Devil-Linux, IPFire, VyOS, Endian Firewall Community, Sphirewall firewall, SME Server, NethServer, CentOS итд.

 

Вы сами работали с этими системами?

Знаю людей, которые изучили одну оболочку и везде ее пихают, типа она очень хорошая, удобная и т.п. Однако некоторые вопросы они до сих пор решить на ней не могут.

 

сааб мы вроде с тобой тему производительности уже порешали.

FX 8350 стоит 11т рублей. Вот тебе 8 ядер, а не 2 и не 4. И работает оно лучше чем i5 3570.

 

Не знаю как оно там лучше работает, но AMD не рекомендуется к использованию даже микротиком. Я много видел серверов микротика на x86 на разном железе, и у меня у самого они были, даже на P2, т.к. в те давние времена все стоило дорого, а древние компы были в достатке. И ко мне обращаются люди, у которых есть сервера с микротиком на х86, с целью перевода на CCR, и в большинстве случаев наблюдаются только положительные стороны от такой замены. Т.к. основной парк таких серверов эти либо б/у деллы и HP с многоядерными процессорами, но медленными по частоте, либо i3-i5, редко i7 или последние ксеноны. Так вот, медленные многоядерные почти всегда проигрывают CCR, те, что посовременнее (а это и память) можно пока подержать в работе, если нет ограничений по портам.

 

Кроме всего, когда идет вопрос о стабильности и производительности, как можно экономить на железе?

 

тебе скинуть свой конфиг микротика, чтобы твой CCR раком загнулся? Аааа.. Нужно просто второй микротик поставить, точно. Только тогда где производительность всей системы в целом?

 

Проблема в том, что у разных провайдеров разные схемы сети, у кого-то один канал 1Г и стоит один сервер, который все делает. У кого-то 2 канала по 1Г, при этом на каждый канал надо поставить по своему серверу НАТ, то есть уже две железки, общий шейпер и 1 или 2 терминатора абонентов. И вот с какого бока тут х86 поставить не ясно - в него придется 4 сетевухи засунуть, только что бы сеть скоммутировать=) Так же разделение задач очень полезно для отказоустойчивости и поиска неполадок, и всегда видно, какая задача сколько загружает оборудование, а не смотреть на загрузку процессора единственного сервера.

 

ты это серьёзно? ну секунд 15 презапускается х86 на SSD.

 

Не знаю как у вас, но те сервера, что у меня были, и я видел у других, перезагружаются около минуты и более, т.к. одни только 15 секунд тратятся на инициализацию системных ресурсов, далее инициализация сетевых адаптеров (если они дорогие и серьезные), и дискового контроллера. А если еще и ipKVM есть, то и на его инициализацию время требуется.

 

а х86 оптических портов то быть не может, да?

 

Может, но это если сервер на базе обычного корпуса, или 3-4 юнитовый. В одноюнитовом сервере может быть только один внешний адаптер, а на сегодняшний день это максимум 2 порта SFP+, которые еще не все корректно работают, например не определяют некоторые модули или кроссовые кабели. У CCR такого нет.

 

Я соглашусь, что под определённые задачи CCR гораздо удобнее, но если только не пихать в него всё и сразу.

 

Он под любые удобнее. Т.к. при покупке уже лицензия в комплекте, портов много, один юнит, малое потребление электропитания.

 

А приведите ка пример настройки микротика, скажем, в роли dhcp сервера, с тремя тысячами вланов.

 

/interface vlan
add arp=reply-only interface=bridge_vlan name=vlan_2 vlan-id=2

/ip address
add address=10.1.2.1/32 network=10.1.2.2 interface=vlan_2

/ip pool
add name=dhcp_pool_2 ranges=10.1.2.2

/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool_2 disabled=no interface=vlan_2 lease-time=5m name=dhcp_2

 

Вот множите 3000 раз и готово.

 

Может потому, что вы не знаете джун, так же как микротик?

Мой гл.инженер поднимает Cisco ядро намного быстрее, чем тот же микротик.

 

Микротик проще изучить, т.к. можно купить коробочку за 3000р. и собрать любое сетевое решение.

Что бы изучить джун его просто так не купить - это либо надо идти работать куда-то, или зубрить инструкции и документации, а проверить на практике как оно работает все равно нельзя - оборудование дорогое=)

 

ПК с линксом на борту спору нет рвет микротик по всем параметрам, но есть главное НО нужно, найти человека, который бы его приготовил. Да и я смогу поднять линукс и создать такой сервер, но есть много нюансов. Juniper MX, который я один внедряю в сеть, чтобы работала: авторизация, флоу, нат, отчетность в билинге нормально ушло много времени, хотя микротик я сварю за минут 15.

 

ПК с линуксом не конкурент микротику, т.к. обходит его только в некоторых задачах и то при должной настройке. У линукса многое очень неудобно - например файрвол, нет удобной оболочки для управления. Вот как на линуксе мониторить трафик на портах? На микротике графики открыл в нескольких окошках и можно смотреть в реальном времени, да еще сразу 2-3 пинга запустить тоже в разных окошках, и еще тест скорости. При этом все перед глазами - тут же еще можно и список PPPoE клиентов наблюдать, загруженность правил шейпера и т.п.

 

То есть работая с линуксом придется тратить намного больше времени на те действия, которые в микротике пару щелчков мышкой делаются. А рекордная производительность не всегда и нужна - например тот же CCR1036 легко натит под 3-4 гига трафика, шепит так же 2-3 гига, обрабатывает 2-3 тысячи PPPoE клиентов (при должной настройки L2 каналов от абонентов), обслуживает 2-3 тысячи вланов с DHCP серверами. При этом настройки легки и всем понятны, легко подгружаются из шаблонов.

 

Так гл.инженер какую ЗП имеет? Для настройки микротика у него уйдет очень мало времени т.к. он популярен и доступен, но за эту работу платят меньше.

 

Сейчас наблюдается другая тенденция. Специалистов по линуксу много, но каждый практикует только свою схему правильных настроек. И один специалист порой не может разобрать, что сделал предыдущий. При этом он сразу дает советы что все надо переделать и настраивать вот по такой схеме. И самое интересное - что он постоянно там что-то делает в настройках, что бы изменить некоторые из них требуется перезагрузка - а это простой услуги у абонентов. Тот же MPLS, разные L2 туннели, линукс нормально не умеет, да и не все спецы по линуксу умеют MPLS настраивать не просто в виде VPLS туннеля, а в более глобальной схеме с TE и несколькими L3 кольцами.

 

По микротику тоже есть проблемы с настройщиками. Сейчас развелось курсов, где за 15 тыс.руб. научат с ним работать и даже дадут сертификат, и новички-настройщики начинают настраивать сети на микротике, не особо понимая то, что те знания, которые им предоставили, несколько не отражают действительность. Первым делом они отключают мак-службы микротика, блокируют на него доступ откуда только можно, создают правила на перебор паролей и т.п., а после удивляются, что же CCR никак более 1 гига трафика пропустить не может.

 

Это все сложилось на опыте поиска специалистов под разные проекты - порой приходилось провести собеседование с 20-30 специалистами по линуксу или микротику, что бы найти нормального специалиста, который может сходу объяснить, как бы он решил типовые задачи по подключению абонентов, или соединения различных роутеров между собой.

Share this post


Link to post
Share on other sites

Так гл.инженер какую ЗП имеет? Для настройки микротика у него уйдет очень мало времени т.к. он популярен и доступен, но за эту работу платят меньше.

Микротик я и сам могу настроить и работал с ними начиная еще с 2005 года (и первая статья для использования микротика в качестве PPPoE NAS + LB писалась мной), но на своей сети всякие CCR видеть не особо желаю. А зп - не обсуждается.

ПыСы

Что умеет циско, джун, ериксон, алкатель и не снится микротику, как по функционалу, так и по стабильности работы.

Share this post


Link to post
Share on other sites

Для быстро развивающегося рынка IT - стабильность - не самое важное. Зачем мне сверхдорогая железка с гарантированным аптаймом 100 лет, если я в связи с расширением каналов, ростом числа абонентов, появлением новых фишек типа MPLS регулярно должен менять само оборудование. Опять же, приемлемого уровня стабильности можно добиться резервированием, дублированием и правильными настройками, запасами на складе, благо цены позволяют.

Share this post


Link to post
Share on other sites
регулярно должен менять само оборудование

Это как раз про микротики.

Cisco 7201 будет чуть ли не старше фирмы Микротик, однако до сих пор актуальна и превосходит последний практически по всем характеристикам, кроме разве что количества портов.

Share this post


Link to post
Share on other sites

регулярно должен менять само оборудование

Странно )) С чего вы это взяли? 4 по 10Г и все wirespeed мне в ядре надолго хватит к примеру.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this